Sony Bravia plugin seems to be broken with Indigo 7.0

Posted on
Tue Jan 17, 2017 1:13 pm
Shutter offline
Posts: 345
Joined: Mar 07, 2014
Location: London, UK

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

Hi,

Tried again with the latest version you posted. No joy. Still see the following when I try to send a command:

Code: Select all
   Sony Bravia Network Remote Plugin Debug Processing SOAP/JSON operation to http://192.168.0.28:80/sony/IRCC
   Sony Bravia Network Remote Plugin Error An error occurred processing the SOAP/JSON POST request: (Device: 1026295930): 500


The TV pairs ok. Is there meant to be a state shown in Indigo when the device is created? Also, in the Device Found menu my TV is never shown, though when I add the IP the MAC address is retrieved and it pairs ok.

When I create the device the following shows up in the logs:

Code: Select all
 Sony Bravia Network Remote Plugin Debug Found uPnP Device: <SSDPResponse(http://192.168.0.1:1900/rootDesc.xml, uuid:9d695d40-dc19-11e6-ab7f-e4f4c6caf3fc, uuid:9d695d40-dc19-11e6-ab7f-e4f4c6caf3fc, Ubuntu/lucid UPnP/1.1 MiniUPnPd/1.7)>[('opt', '"http://schemas.upnp.org/upnp/1/0/"; ns=01'), ('usn', 'uuid:9d695d40-dc19-11e6-ab7f-e4f4c6caf3fc'), ('st', 'uuid:9d695d40-dc19-11e6-ab7f-e4f4c6caf3fc'), ('ext', ''), ('location', 'http://192.168.0.1:1900/rootDesc.xml'), ('cache-control', 'max-age=120'), ('bootid.upnp.org', '1'), ('server', 'Ubuntu/lucid UPnP/1.1 MiniUPnPd/1.7'), ('configid.upnp.org', '1337'), ('01-nls', '1')]</SSDPResonse>
   Sony Bravia Network Remote Plugin Debug Found uPnP Device: <SSDPResponse(http://192.168.0.28:52323/MediaRenderer.xml, urn:schemas-rvualliance-org:service:StreamSplicing:1, uuid:23456789-1234-1010-8000-104fa8a87b48::urn:schemas-rvualliance-org:service:StreamSplicing:1, Android/1.6 UPnP/1.0 Huey Sample DMR/0.1)>[('usn', 'uuid:23456789-1234-1010-8000-104fa8a87b48::urn:schemas-rvualliance-org:service:StreamSplicing:1'), ('server', 'Android/1.6 UPnP/1.0 Huey Sample DMR/0.1'), ('ext', ''), ('location', 'http://192.168.0.28:52323/MediaRenderer.xml'), ('cache-control', 'max-age=1800'), ('x-av-server-info', 'av=5.0; hn=""; cn="Sony Corporation"; mn="Huey Sample DMR"; mv="0.1";'), ('st', 'urn:schemas-rvualliance-org:service:StreamSplicing:1')]</SSDPResonse>
   Sony Bravia Network Remote Plugin Debug Found uPnP Device: <SSDPResponse(http://192.168.0.28:18062/sony/webapi/ssdp/dd.xml, urn:schemas-sony-com:service:IRCC:1, uuid:fa263662-1b6e-409f-b8a5-399554ccd0ba::urn:schemas-sony-com:service:IRCC:1, FedoraCore/2 UPnP/1.0 MINT-X/1.8.1)>[('usn', 'uuid:fa263662-1b6e-409f-b8a5-399554ccd0ba::urn:schemas-sony-com:service:IRCC:1'), ('server', 'FedoraCore/2 UPnP/1.0 MINT-X/1.8.1'), ('ext', ''), ('location', 'http://192.168.0.28:18062/sony/webapi/ssdp/dd.xml'), ('cache-control', 'max-age=1800'), ('st', 'urn:schemas-sony-com:service:IRCC:1')]</SSDPResonse>
   Sony Bravia Network Remote Plugin Debug Found uPnP Device: <SSDPResponse(http://192.168.0.28:41698/dd.xml, urn:dial-multiscreen-org:service:dial:1, uuid:6a454942-4697-4c00-a81d-e60488f34000::urn:dial-multiscreen-org:service:dial:1, FedoraCore/2 UPnP/1.0 MINT-X/1.8.1)>[('usn', 'uuid:6a454942-4697-4c00-a81d-e60488f34000::urn:dial-multiscreen-org:service:dial:1'), ('server', 'FedoraCore/2 UPnP/1.0 MINT-X/1.8.1'), ('ext', ''), ('location', 'http://192.168.0.28:41698/dd.xml'), ('cache-control', 'max-age=1800'), ('st', 'urn:dial-multiscreen-org:service:dial:1')]</SSDPResonse>


Any use?

Thanks,

Simon

Posted on
Tue Jan 17, 2017 1:45 pm
RogueProeliator offline
User avatar
Posts: 2418
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

So we are back to where we started.

Not entirely - what is the IP address of that TV-GBR-new device? It looks like at least one is somewhat advertising itself, but without the full typical information returned. Also, could you go to the menu and do the Log Device Details for that device?

Note if you already deleted the -new device, the old one is fine to use.

Posted on
Tue Jan 17, 2017 1:48 pm
RogueProeliator offline
User avatar
Posts: 2418
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

@Simon:

Maybe... similar to the one I just posted, there is some advertisement of the Sony device; I suspect their pattern has changed from what I was previously looking for in order to identify it as a Sony TV. I'll see if I can work with it to recognize those...

In the meantime, could you please go to http://192.168.0.28:18062/sony/webapi/ssdp/dd.xml in a browser? That should have a bit more information about the TV control service.

Adam

Posted on
Tue Jan 17, 2017 2:16 pm
Shutter offline
Posts: 345
Joined: Mar 07, 2014
Location: London, UK

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

Below is the output from the URL, but before I send you off on a wild goose chase, I just want to make sure I've configured the TV correctly. I've enabled all the setting on the TV that appear to be connected with control and tested it with a Sony iOS app, which I paired and I'm able to control the TV with. So I don't think it's that, but I'm mentioning this just in case there's anything else I should look for.

By the way, thanks for this.

Code: Select all
<root xmlns="urn:schemas-upnp-org:device-1-0">
<specVersion>
<major>1</major>
<minor>0</minor>
</specVersion>
<device>
<deviceType>urn:schemas-upnp-org:device:Basic:1</deviceType>
<friendlyName>KD-55XD8005</friendlyName>
<manufacturer>Sony Corporation</manufacturer>
<manufacturerURL>http://www.sony.net/</manufacturerURL>
<modelName>KD-55XD8005</modelName>
<UDN>uuid:fa263662-1b6e-409f-b8a5-399554ccd0ba</UDN>
<av:X_Telepathy_Enabled xmlns:av="urn:schemas-sony-com:av"/>
<iconList>
<icon>
<mimetype>image/jpeg</mimetype>
<width>120</width>
<height>120</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/dlna_tv_120.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>120</width>
<height>120</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/dlna_tv_120.png</url>
</icon>
<icon>
<mimetype>image/jpeg</mimetype>
<width>32</width>
<height>32</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/dlna_tv_32.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>32</width>
<height>32</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/dlna_tv_32.png</url>
</icon>
<icon>
<mimetype>image/jpeg</mimetype>
<width>48</width>
<height>48</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/dlna_tv_48.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>48</width>
<height>48</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/dlna_tv_48.png</url>
</icon>
<icon>
<mimetype>image/jpeg</mimetype>
<width>60</width>
<height>60</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/dlna_tv_60.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>60</width>
<height>60</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/dlna_tv_60.png</url>
</icon>
</iconList>
<serviceList>
<service>
<serviceType>urn:schemas-sony-com:service:ScalarWebAPI:1</serviceType>
<serviceId>urn:schemas-sony-com:serviceId:ScalarWebAPI</serviceId>
<SCPDURL>/sony/webapi/ssdp/scpd/WebApiSCPD.xml</SCPDURL>
<controlURL>http://192.168.0.28/sony</controlURL>
<eventSubURL/>
</service>
<service>
<serviceType>urn:schemas-sony-com:service:IRCC:1</serviceType>
<serviceId>urn:schemas-sony-com:serviceId:IRCC</serviceId>
<SCPDURL>http://192.168.0.28/sony/ircc/IRCCSCPD.xml</SCPDURL>
<controlURL>http://192.168.0.28/sony/ircc</controlURL>
<eventSubURL/>
</service>
</serviceList>
<av:X_ScalarWebAPI_DeviceInfo xmlns:av="urn:schemas-sony-com:av">
<av:X_ScalarWebAPI_Version>1.0</av:X_ScalarWebAPI_Version>
<av:X_ScalarWebAPI_BaseURL>http://192.168.0.28/sony</av:X_ScalarWebAPI_BaseURL>
<av:X_ScalarWebAPI_ServiceList>
<av:X_ScalarWebAPI_ServiceType>guide</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>recording</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>browser</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>accessControl</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>encryption</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>contentshare</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>avContent</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>cec</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>audio</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>system</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>appControl</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>videoScreen</av:X_ScalarWebAPI_ServiceType>
</av:X_ScalarWebAPI_ServiceList>
</av:X_ScalarWebAPI_DeviceInfo>
<av:X_IRCC_DeviceInfo xmlns:av="urn:schemas-sony-com:av">
<av:X_IRCC_Version>1.0</av:X_IRCC_Version>
<av:X_IRCC_CategoryList>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAEAAAAB</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAACk</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAACX</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAAB3</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAAAa</av:X_CategoryInfo>
</av:X_IRCC_Category>
</av:X_IRCC_CategoryList>
</av:X_IRCC_DeviceInfo>
<av:X_IRCCCodeList xmlns:av="urn:schemas-sony-com:av">
<av:X_IRCCCode command="Power">AAAAAQAAAAEAAAAVAw==</av:X_IRCCCode>
</av:X_IRCCCodeList>
<av:X_RDIS_DeviceInfo xmlns:av="urn:schemas-sony-com:av">
<av:X_RDIS_Version>1.0</av:X_RDIS_Version>
<av:X_RDIS_SESSION_CONTROL>true</av:X_RDIS_SESSION_CONTROL>
<av:X_RDIS_KEEP_ALIVE>false</av:X_RDIS_KEEP_ALIVE>
<av:X_RDIS_ENTRY_PORT>49677</av:X_RDIS_ENTRY_PORT>
</av:X_RDIS_DeviceInfo>
</device>
</root>

Posted on
Tue Jan 17, 2017 4:26 pm
brianlloyd offline
User avatar
Posts: 212
Joined: May 26, 2013
Location: San Antonio, TX, USA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

Logging device details. Here is the dump of TV-GBR (old instance):

Jan 17, 2017, 4:21:03 PM
Sony Bravia Network Remote Plugin Dumping details for DeviceID: 118323906
Sony Bravia Network Remote Plugin address : 172.16.48.33:80
batteryLevel : None
buttonGroupCount : 0
configured : True
description :
deviceTypeId : sonyTvRemoteDevice
displayStateId :
displayStateImageSel : None
displayStateValRaw : None
displayStateValUi :
enabled : True
energyAccumBaseTime : None
energyAccumTimeDelta : None
energyAccumTotal : None
energyCurLevel : None
errorState :
folderId : 1143336567
globalProps : MetaProps : (dict)
com.duncanware.sonyBraviaNetworkRemote : (dict)
address : 172.16.48.33:80 (string)
authCookie : auth=3EA52FE4EE617060C2AB8F581C1F9625F0C6FD4F (string)
authMethod : accessControl (string)
httpAddress : 172.16.48.33 (string)
httpPort : 80 (string)
macAddress : ac:9b:0a:82:c7:7d (string)
queryPath : /sony/IRCC (string)
upnpEnumeratedDevices : (string)
validationMsgControl : 0 (string)
id : 118323906
lastChanged : 2000-01-01 00:00:00
lastSuccessfulComm : 2000-01-01 00:00:00
model : Sony TV Network Remote Control
name : TV-GBR
ownerProps : com.duncanware.sonyBraviaNetworkRemote : (dict)
address : 172.16.48.33:80 (string)
authCookie : auth=3EA52FE4EE617060C2AB8F581C1F9625F0C6FD4F (string)
authMethod : accessControl (string)
httpAddress : 172.16.48.33 (string)
httpPort : 80 (string)
macAddress : ac:9b:0a:82:c7:7d (string)
queryPath : /sony/IRCC (string)
upnpEnumeratedDevices : (string)
validationMsgControl : 0 (string)
pluginId : com.duncanware.sonyBraviaNetworkRemote
pluginProps : com.duncanware.sonyBraviaNetworkRemote : (dict)
address : 172.16.48.33:80 (string)
authCookie : auth=3EA52FE4EE617060C2AB8F581C1F9625F0C6FD4F (string)
authMethod : accessControl (string)
httpAddress : 172.16.48.33 (string)
httpPort : 80 (string)
macAddress : ac:9b:0a:82:c7:7d (string)
queryPath : /sony/IRCC (string)
upnpEnumeratedDevices : (string)
validationMsgControl : 0 (string)
protocol : Plugin
remoteDisplay : False
states : States : (dict)
subModel :
supportsAllLightsOnOff : False
supportsAllOff : False
supportsStatusRequest : False
version : None

Here is the new instance, TV-GBR-new:

Jan 17, 2017, 4:22:56 PM
Sony Bravia Network Remote Plugin Dumping details for DeviceID: 489574350
Sony Bravia Network Remote Plugin address : 172. 16.48.33:80
batteryLevel : None
buttonGroupCount : 0
configured : True
description :
deviceTypeId : sonyTvRemoteDevice
displayStateId :
displayStateImageSel : None
displayStateValRaw : None
displayStateValUi :
enabled : True
energyAccumBaseTime : None
energyAccumTimeDelta : None
energyAccumTotal : None
energyCurLevel : None
errorState :
folderId : 0
globalProps : MetaProps : (dict)
com.duncanware.sonyBraviaNetworkRemote : (dict)
address : 172. 16.48.33:80 (string)
authCookie : (string)
authMethod : accessControl (string)
httpAddress : 172. 16.48.33 (string)
httpPort : 80 (string)
macAddress : ac:9b:0a:82:c7:7d (string)
queryPath : /sony/IRCC (string)
upnpEnumeratedDevices : (string)
validationMsgControl : 0 (string)
id : 489574350
lastChanged : 2000-01-01 00:00:00
lastSuccessfulComm : 2000-01-01 00:00:00
model : Sony TV Network Remote Control
name : TV-GBR-new
ownerProps : com.duncanware.sonyBraviaNetworkRemote : (dict)
address : 172. 16.48.33:80 (string)
authCookie : (string)
authMethod : accessControl (string)
httpAddress : 172. 16.48.33 (string)
httpPort : 80 (string)
macAddress : ac:9b:0a:82:c7:7d (string)
queryPath : /sony/IRCC (string)
upnpEnumeratedDevices : (string)
validationMsgControl : 0 (string)
pluginId : com.duncanware.sonyBraviaNetworkRemote
pluginProps : com.duncanware.sonyBraviaNetworkRemote : (dict)
address : 172. 16.48.33:80 (string)
authCookie : (string)
authMethod : accessControl (string)
httpAddress : 172. 16.48.33 (string)
httpPort : 80 (string)
macAddress : ac:9b:0a:82:c7:7d (string)
queryPath : /sony/IRCC (string)
upnpEnumeratedDevices : (string)
validationMsgControl : 0 (string)
protocol : Plugin
remoteDisplay : False
states : States : (dict)
subModel :
supportsAllLightsOnOff : False
supportsAllOff : False
supportsStatusRequest : False
version : None

Here is the TV that still responds to commands. Note, this is the NON-ANDROID TV:


Jan 17, 2017, 4:24:20 PM
Sony Bravia Network Remote Plugin Dumping details for DeviceID: 1793081090
Sony Bravia Network Remote Plugin address : 172.16.48.30:80
batteryLevel : None
buttonGroupCount : 0
configured : True
description :
deviceTypeId : sonyTvRemoteDevice
displayStateId :
displayStateImageSel : None
displayStateValRaw : None
displayStateValUi :
enabled : True
energyAccumBaseTime : None
energyAccumTimeDelta : None
energyAccumTotal : None
energyCurLevel : None
errorState :
folderId : 1143336567
globalProps : MetaProps : (dict)
com.duncanware.sonyBraviaNetworkRemote : (dict)
address : 172.16.48.30:80 (string)
authCookie : auth=46d8f68e8a1d2581a3bff7791b83863f8e5341a1224a58c47d295dc56ac25475 (string)
authMethod : accessControl (string)
httpAddress : 172.16.48.30 (string)
httpPort : 80 (string)
macAddress : fc:f1:52:58:14:52 (string)
queryPath : /sony/IRCC (string)
upnpEnumeratedDevices : (string)
validationMsgControl : 99 (string)
id : 1793081090
lastChanged : 2015-01-28 15:41:22
lastSuccessfulComm : 2015-01-28 15:41:22
model : Sony TV Network Remote Control
name : TV-LR
ownerProps : com.duncanware.sonyBraviaNetworkRemote : (dict)
address : 172.16.48.30:80 (string)
authCookie : auth=46d8f68e8a1d2581a3bff7791b83863f8e5341a1224a58c47d295dc56ac25475 (string)
authMethod : accessControl (string)
httpAddress : 172.16.48.30 (string)
httpPort : 80 (string)
macAddress : fc:f1:52:58:14:52 (string)
queryPath : /sony/IRCC (string)
upnpEnumeratedDevices : (string)
validationMsgControl : 99 (string)
pluginId : com.duncanware.sonyBraviaNetworkRemote
pluginProps : com.duncanware.sonyBraviaNetworkRemote : (dict)
address : 172.16.48.30:80 (string)
authCookie : auth=46d8f68e8a1d2581a3bff7791b83863f8e5341a1224a58c47d295dc56ac25475 (string)
authMethod : accessControl (string)
httpAddress : 172.16.48.30 (string)
httpPort : 80 (string)
macAddress : fc:f1:52:58:14:52 (string)
queryPath : /sony/IRCC (string)
upnpEnumeratedDevices : (string)
validationMsgControl : 99 (string)
protocol : Plugin
remoteDisplay : False
states : States : (dict)
subModel :
supportsAllLightsOnOff : False
supportsAllOff : False
supportsStatusRequest : False
version : None

Posted on
Tue Jan 17, 2017 11:38 pm
RogueProeliator offline
User avatar
Posts: 2418
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

@Simon -- I do not know if this is an issue, but it most definitely could be -- the XML file you posted shows the path to the control page having a lower case IRCC; given that they run some form of Linux it could be case sensitive. Please try editing the Indigo TV device and change the Path value to /sony/ircc all lower case. Normally, if the plugin were finding the TVs it would take care of this for you. I just looked up the identification string I am using and I definitely need to expand it.

@Brian -- it looks like your new device's IP address has a space in it... but clearly that is not the overall problem. Would you mind posting the same XML file as Simon; yours would be located at: http://172.16.48.33:61908/sony/webapi/ssdp/dd.xml. I'll need the XML tags, so you may need to view the source and paste into a code block in the forum.

Adam

Posted on
Wed Jan 18, 2017 7:54 am
brianlloyd offline
User avatar
Posts: 212
Joined: May 26, 2013
Location: San Antonio, TX, USA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

Adam,

Here's the XML:

<root xmlns="urn:schemas-upnp-org:device-1-0">
<specVersion>
<major>1</major>
<minor>0</minor>
</specVersion>
<device>
<deviceType>urn:schemas-upnp-org:device:Basic:1</deviceType>
<friendlyName>XBR-49X830C</friendlyName>
<manufacturer>Sony Corporation</manufacturer>
<manufacturerURL>http://www.sony.net/</manufacturerURL>
<modelName>XBR-49X830C</modelName>
<UDN>uuid:48a12ff1-c223-49b5-a829-2f60c0a15c64</UDN>
<iconList>
<icon>
<mimetype>image/jpeg</mimetype>
<width>120</width>
<height>120</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_120.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>120</width>
<height>120</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_120.png</url>
</icon>
<icon>
<mimetype>image/jpeg</mimetype>
<width>32</width>
<height>32</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_32.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>32</width>
<height>32</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_32.png</url>
</icon>
<icon>
<mimetype>image/jpeg</mimetype>
<width>48</width>
<height>48</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_48.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>48</width>
<height>48</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_48.png</url>
</icon>
<icon>
<mimetype>image/jpeg</mimetype>
<width>60</width>
<height>60</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_60.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>60</width>
<height>60</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_60.png</url>
</icon>
</iconList>
<serviceList>
<service>
<serviceType>urn:schemas-sony-com:service:ScalarWebAPI:1</serviceType>
<serviceId>urn:schemas-sony-com:serviceId:ScalarWebAPI</serviceId>
<SCPDURL>/sony/webapi/ssdp/scpd/WebApiSCPD.xml</SCPDURL>
<controlURL>http://172.16.48.33/sony</controlURL>
<eventSubURL/>
</service>
<service>
<serviceType>urn:schemas-sony-com:service:IRCC:1</serviceType>
<serviceId>urn:schemas-sony-com:serviceId:IRCC</serviceId>
<SCPDURL>http://172.16.48.33/sony/ircc/IRCCSCPD.xml</SCPDURL>
<controlURL>http://172.16.48.33/sony/ircc</controlURL>
<eventSubURL/>
</service>
</serviceList>
<av:X_ScalarWebAPI_DeviceInfo xmlns:av="urn:schemas-sony-com:av">
<av:X_ScalarWebAPI_Version>1.0</av:X_ScalarWebAPI_Version>
<av:X_ScalarWebAPI_BaseURL>http://172.16.48.33/sony</av:X_ScalarWebAPI_BaseURL>
<av:X_ScalarWebAPI_ServiceList>
<av:X_ScalarWebAPI_ServiceType>guide</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>accessControl</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>encryption</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>contentshare</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>avContent</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>cec</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>audio</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>system</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>appControl</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>videoScreen</av:X_ScalarWebAPI_ServiceType>
</av:X_ScalarWebAPI_ServiceList>
</av:X_ScalarWebAPI_DeviceInfo>
<av:X_IRCC_DeviceInfo xmlns:av="urn:schemas-sony-com:av">
<av:X_IRCC_Version>1.0</av:X_IRCC_Version>
<av:X_IRCC_CategoryList>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAEAAAAB</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAACk</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAACX</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAAB3</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAAAa</av:X_CategoryInfo>
</av:X_IRCC_Category>
</av:X_IRCC_CategoryList>
</av:X_IRCC_DeviceInfo>
<av:X_IRCCCodeList xmlns:av="urn:schemas-sony-com:av">
<av:X_IRCCCode command="Power">AAAAAQAAAAEAAAAVAw==</av:X_IRCCCode>
</av:X_IRCCCodeList>
<av:X_RDIS_DeviceInfo xmlns:av="urn:schemas-sony-com:av">
<av:X_RDIS_Version>1.0</av:X_RDIS_Version>
<av:X_RDIS_SESSION_CONTROL>true</av:X_RDIS_SESSION_CONTROL>
<av:X_RDIS_KEEP_ALIVE>false</av:X_RDIS_KEEP_ALIVE>
<av:X_RDIS_ENTRY_PORT>39395</av:X_RDIS_ENTRY_PORT>
</av:X_RDIS_DeviceInfo>
</device>
</root>

Posted on
Wed Jan 18, 2017 2:29 pm
Shutter offline
Posts: 345
Joined: Mar 07, 2014
Location: London, UK

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

I've made it all lowercase.

So, if I use Power On as a Send button-pressed command I get the following in the logs:

Code: Select all
Sony Bravia Network Remote Plugin Debug Processing SOAP/JSON operation to http://192.168.0.28:80/sony/iirc
Sony Bravia Network Remote Plugin Error Error executing command: Page Not Found on Device


But when use the preset Power On action type there is nothing in the logs, it may not work, but no error is shown.

Let me know if you would like me to try anything else?

Once again thanks.

Simon

Posted on
Thu Jan 19, 2017 8:48 am
RogueProeliator offline
User avatar
Posts: 2418
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

Code: Select all
Sony Bravia Network Remote Plugin Debug Processing SOAP/JSON operation to http://192.168.0.28:80/sony/iirc
Sony Bravia Network Remote Plugin Error Error executing command: Page Not Found on Device

That IP address doesn't match the one we were looking at in the XML that I mentioned trying all lower case... did you pick up a new IP address since or might you have tried a different TV? In the XML it was referencing http://172.16.48.33/sony/ircc.

The PowerOn is probably not a good first test -- make sure the TV is already on and try something like Volume or Input changes. Some TV models do not support Power On, though most do and just require one extra step in settings; using a more generic command should ensure it isn't a TV setup issue.

Posted on
Thu Jan 19, 2017 8:50 am
RogueProeliator offline
User avatar
Posts: 2418
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

@Brian: Would you mind trying the same advice as I gave Simon... change the Path to all lower case as your XML is also showing all lower case instead of the IIRC upper case default. As with his, no idea if this even makes a difference but it is a first difference to eliminate.

Adam

Posted on
Thu Jan 19, 2017 9:13 am
brianlloyd offline
User avatar
Posts: 212
Joined: May 26, 2013
Location: San Antonio, TX, USA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

@Adam

OK, I changed the case of the path. No soap. (Sorry, pun intended.) I then recreated the device, recreated the action group, and attempted to then turn the display off. That still elicits the same "500" error.

Action Group Office TV Desk off
Sony Bravia Network Remote Plugin Threaddebug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
Sony Bravia Network Remote Plugin Threaddebug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
Sony Bravia Network Remote Plugin Threaddebug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
Sony Bravia Network Remote Plugin Threaddebug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
Sony Bravia Network Remote Plugin Threaddebug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
Sony Bravia Network Remote Plugin Threaddebug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
Sony Bravia Network Remote Plugin Threaddebug Command queue has 2 command(s) waiting
Sony Bravia Network Remote Plugin Threaddebug Received SOAP/JSON command request:
/sony/ircc
urn:schemas-sony-com:service:IRCC:1#X_SendIRCC
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<m:X_SendIRCC xmlns:m="urn:schemas-sony-com:service:IRCC:1">
<IRCCCode xmlns:dt="urn:schemas-microsoft-com:datatypes" dt:dt="string">AAAAAQAAAAEAAAAvAw==</IRCCCode>
</m:X_SendIRCC>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

Sony Bravia Network Remote Plugin Debug Processing SOAP/JSON operation to http://172.16.48.31:80/sony/ircc
Sony Bravia Network Remote Plugin Threaddebug Sending SOAP/JSON request:
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<m:X_SendIRCC xmlns:m="urn:schemas-sony-com:service:IRCC:1">
<IRCCCode xmlns:dt="urn:schemas-microsoft-com:datatypes" dt:dt="string">AAAAAQAAAAEAAAAvAw==</IRCCCode>
</m:X_SendIRCC>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
Sony Bravia Network Remote Plugin Error An error occurred processing the SOAP/JSON POST request: (Device: 293143562): 500
Sony Bravia Network Remote Plugin Threaddebug Command queue has 1 command(s) waiting
Sony Bravia Network Remote Plugin Threaddebug Received SOAP/JSON command request:
/sony/ircc
urn:schemas-sony-com:service:IRCC:1#X_SendIRCC
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<m:X_SendIRCC xmlns:m="urn:schemas-sony-com:service:IRCC:1">
<IRCCCode xmlns:dt="urn:schemas-microsoft-com:datatypes" dt:dt="string">AAAAAQAAAAEAAAAvAw==</IRCCCode>
</m:X_SendIRCC>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

Sony Bravia Network Remote Plugin Debug Processing SOAP/JSON operation to http://172.16.48.31:80/sony/ircc
Sony Bravia Network Remote Plugin Threaddebug Sending SOAP/JSON request:
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<m:X_SendIRCC xmlns:m="urn:schemas-sony-com:service:IRCC:1">
<IRCCCode xmlns:dt="urn:schemas-microsoft-com:datatypes" dt:dt="string">AAAAAQAAAAEAAAAvAw==</IRCCCode>
</m:X_SendIRCC>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
Sony Bravia Network Remote Plugin Error An error occurred processing the SOAP/JSON POST request: (Device: 293143562): 500

Posted on
Thu Jan 19, 2017 2:53 pm
Shutter offline
Posts: 345
Joined: Mar 07, 2014
Location: London, UK

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

RogueProeliator wrote:
Code: Select all
Sony Bravia Network Remote Plugin Debug Processing SOAP/JSON operation to http://192.168.0.28:80/sony/iirc
Sony Bravia Network Remote Plugin Error Error executing command: Page Not Found on Device

That IP address doesn't match the one we were looking at in the XML that I mentioned trying all lower case... did you pick up a new IP address since or might you have tried a different TV? In the XML it was referencing http://172.16.48.33/sony/ircc.

The PowerOn is probably not a good first test -- make sure the TV is already on and try something like Volume or Input changes. Some TV models do not support Power On, though most do and just require one extra step in settings; using a more generic command should ensure it isn't a TV setup issue.



That's the same IP as before. Tried the volume up and I sill see the following:

Sony Bravia Network Remote Plugin Debug Processing SOAP/JSON operation to http://192.168.0.28:80/sony/iirc
Sony Bravia Network Remote Plugin Error Error executing command: Page Not Found on Device


:(

Posted on
Thu Jan 19, 2017 4:04 pm
brianlloyd offline
User avatar
Posts: 212
Joined: May 26, 2013
Location: San Antonio, TX, USA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

Sorry. I used a different TV. I have 4 TVs that are the same (two in my office, one in the guest bedroom, and one in the master BR.) It depends on which one I am sitting at. I was previously using the display in the guest bedroom but then decided it was a whole lot easier to work with the display where I was sitting.

So the change in IP address is a red-herring. The problem remains that all 4 Android TVs have stopped responding to commands while the older non-Android display in my LR continues to work fine with the plugin. I am betting that Sony pushed out a firmware upgrade that broke everything. I think it is about time to block internet access on these displays in the firewall so that they cannot get firmware updates ever again.

Posted on
Thu Jan 19, 2017 4:07 pm
brianlloyd offline
User avatar
Posts: 212
Joined: May 26, 2013
Location: San Antonio, TX, USA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

I forgot to add that my "power on" action group sends "Power on" followed by the button-push for power on. Same for power off. I remembered that some would and would-not respond to one or the other, so my action group does both.

I use these TVs strictly as displays. The only commands I ever send are power on, power off, and select HDMI [1|2|3|4].

Posted on
Sun Jan 29, 2017 10:18 pm
RogueProeliator offline
User avatar
Posts: 2418
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Sony Bravia plugin seems to be broken with Indigo 7.0

I have a new release for you guys to test out -- I do not expect that this will actually resolve the issue but hopefully give us more information in order to fully diagnose the issue. If you would, please download and install this pre-release:

https://github.com/RogueProeliator/IndigoPlugins-Sony-Network-Remote/archive/v2.4.1.zip

Then, test two things for me, both with the TV already powered on:
1. See if the device is now found in the list of available options when it searches (i.e. when creating a new device)
2. Set Debug Level to HIGH and try, say, an HDMI selection or volume command and post the logged details

Thanks for sticking with it!

Who is online

Users browsing this forum: No registered users and 1 guest