New TV does not respond to commands

Posted on
Fri Aug 05, 2016 5:31 am
swwempa offline
Posts: 5
Joined: Jul 22, 2016

New TV does not respond to commands

My new Sony Bravia kd-55x8005c and it is possible too pair itkd-55x8005c when i use the IP for the TV but when i try too send commands the tv doesnt respond.

Here is a simple Action just too change input too HDMI

Action Group Display test
Sony Bravia Network Remote Plugin Debug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
Sony Bravia Network Remote Plugin Debug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
Sony Bravia Network Remote Plugin Debug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
Sony Bravia Network Remote Plugin Debug Command queue has 1 command(s) waiting
Sony Bravia Network Remote Plugin Debug Received SOAP/JSON command request:
/sony/IRCC
urn:schemas-sony-com:service:IRCC:1#X_SendIRCC
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<m:X_SendIRCC xmlns:m="urn:schemas-sony-com:service:IRCC:1">
<IRCCCode xmlns:dt="urn:schemas-microsoft-com:datatypes" dt:dt="string">AAAAAgAAABoAAABcAw==</IRCCCode>
</m:X_SendIRCC>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

Sony Bravia Network Remote Plugin Debug Processing SOAP/JSON operation to http://172.25.1.73:80/sony/IRCC
Sony Bravia Network Remote Plugin Debug Sending SOAP/JSON request:
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Body>
<m:X_SendIRCC xmlns:m="urn:schemas-sony-com:service:IRCC:1">
<IRCCCode xmlns:dt="urn:schemas-microsoft-com:datatypes" dt:dt="string">AAAAAgAAABoAAABcAw==</IRCCCode>
</m:X_SendIRCC>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
Sony Bravia Network Remote Plugin Error An error occurred processing the SOAP/JSON POST request: (Device: 393289618): 500
Sony Bravia Network Remote Plugin Error Error in plugin execution:

None


It is possible too control the TV with Video & TV SideView.

Do you have any clue what i can do too make it work.

Posted on
Fri Aug 05, 2016 8:49 am
RogueProeliator offline
User avatar
Posts: 2243
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: New TV does not respond to commands

You said that you could pair to the TV - did you do that through the Plugins menu in Indigo or just pair the phone / SideView app? If you haven't done the pairing to the TV from Indigo, start with that and try again.

If you have already paired and/or try it and it still doesn't work, try going to the Indigo application and execute the "Perform UPnP Search" from the Plugins -> Sony Bravia plugin menu. Make sure that your receiver is on prior to doing executing this command. Once that is complete, it should pop up a web browser on your Indigo server with the results. Copy/paste any values that correspond to your receiver's IP here so that we can check the path to the control pages.

Posted on
Tue Aug 09, 2016 7:44 am
swwempa offline
Posts: 5
Joined: Jul 22, 2016

Re: New TV does not respond to commands

I can pair the TV with the plugin and SideVieW app.

Here is the result of the PNP search

RogueProeliator's RPFramework UPnP Discovery Report
Requesting Plugin:Sony Bravia Network Remote Plugin
Service Query:ssdp:all
Date Run:1470750053.56
Location:http://172.25.1.55:80/bmlinks/ddf.xml
USN:uuid:d38f8804-1dd1-11b2-843a-aa7140ef2d06
ST:uuid:d38f8804-1dd1-11b2-843a-aa7140ef2d06
Cache Time:10800s
content-length:409
content-language:ja
server:LPUX/1.3 UPnP/1.0 SP 4510DN/1.0
content-type:text/xml; charset="utf-8"
Location:http://172.25.1.73:10702/dd.xml
USN:uuid:58f51d05-fb2a-490e-adcb-9a1606fa00fc::urn:dial-multiscreen-org:service:dial:1
ST:urn:dial-multiscreen-org:service:dial:1
Cache Time:1800s
server:FedoraCore/2 UPnP/1.0 MINT-X/1.8.1
Location:http://172.25.1.73:19348/sony/webapi/ssdp/dd.xml
USN:uuid:065ece98-6f84-414d-8cba-248910c5f0f4::urn:schemas-sony-com:service:IRCC:1
ST:urn:schemas-sony-com:service:IRCC:1
Cache Time:1800s
server:FedoraCore/2 UPnP/1.0 MINT-X/1.8.1
Location:http://172.25.1.15:80/bmlinks/ddf.xml
USN:uuid:93958ab0-1dd1-11b2-9e4d-ee678993ea07
ST:uuid:93958ab0-1dd1-11b2-9e4d-ee678993ea07
Cache Time:10800s
content-length:409
content-language:ja
server:LPUX/1.3 UPnP/1.0 MP C305/1.0
content-type:text/xml; charset="utf-8"
Location:http://172.25.1.52:80/bmlinks/ddf.xml
USN:uuid:6596a470-1dd2-11b2-9ccf-e96328c26eab
ST:uuid:6596a470-1dd2-11b2-9ccf-e96328c26eab
Cache Time:10800s
content-length:409
content-language:ja
server:LPUX/1.3 UPnP/1.0 MP C3003/1.0
content-type:text/xml; charset="utf-8"

Posted on
Tue Aug 09, 2016 9:53 am
RogueProeliator offline
User avatar
Posts: 2243
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: New TV does not respond to commands

Cache Time:1800s
server:FedoraCore/2 UPnP/1.0 MINT-X/1.8.1
Location:http://172.25.1.73:19348/sony/webapi/ssdp/dd.xml
USN:uuid:065ece98-6f84-414d-8cba-248910c5f0f4::urn:schemas-sony-com:service:IRCC:1
ST:urn:schemas-sony-com:service:IRCC:1

This node is what we are interested in and it is returning a different URL format from other Sony TVs. Just a guess, but perhaps the TV also has a different control URL and the plugin is failing to identify it correctly. Can you please load this in your web browser and give me the results? Hopefully with it we can determine what URL to put in the plugin to make it work!

http://172.25.1.73:19348/sony/webapi/ssdp/dd.xml

(Note I will need the XML markup, so you may have to "View Source" to get it all once you load the page, depending upon your browser)

Posted on
Fri Aug 12, 2016 4:46 am
swwempa offline
Posts: 5
Joined: Jul 22, 2016

Re: New TV does not respond to commands

Hi!

Thanks for fast responding here are the result.


<?xml version="1.0"?>
<root xmlns="urn:schemas-upnp-org:device-1-0">
<specVersion>
<major>1</major>
<minor>0</minor>
</specVersion>
<device>
<deviceType>urn:schemas-upnp-org:device:Basic:1</deviceType>
<friendlyName>KD-55X8005C</friendlyName>
<manufacturer>Sony Corporation</manufacturer>
<manufacturerURL>http://www.sony.net/</manufacturerURL>
<modelName>KD-55X8005C</modelName>
<UDN>uuid:065ece98-6f84-414d-8cba-248910c5f0f4</UDN>
<av:X_Telepathy_Enabled xmlns:av="urn:schemas-sony-com:av" />
<iconList>
<icon>
<mimetype>image/jpeg</mimetype>
<width>120</width>
<height>120</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_120.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>120</width>
<height>120</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_120.png</url>
</icon>
<icon>
<mimetype>image/jpeg</mimetype>
<width>32</width>
<height>32</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_32.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>32</width>
<height>32</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_32.png</url>
</icon>
<icon>
<mimetype>image/jpeg</mimetype>
<width>48</width>
<height>48</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_48.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>48</width>
<height>48</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_48.png</url>
</icon>
<icon>
<mimetype>image/jpeg</mimetype>
<width>60</width>
<height>60</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_60.jpg</url>
</icon>
<icon>
<mimetype>image/png</mimetype>
<width>60</width>
<height>60</height>
<depth>24</depth>
<url>/sony/webapi/ssdp/icon/xfh_65_60.png</url>
</icon>
</iconList>
<serviceList>
<service>
<serviceType>urn:schemas-sony-com:service:ScalarWebAPI:1</serviceType>
<serviceId>urn:schemas-sony-com:serviceId:ScalarWebAPI</serviceId>
<SCPDURL>/sony/webapi/ssdp/scpd/WebApiSCPD.xml</SCPDURL>
<controlURL>http://172.25.1.73/sony</controlURL>
<eventSubURL></eventSubURL>
</service>
<service>
<serviceType>urn:schemas-sony-com:service:IRCC:1</serviceType>
<serviceId>urn:schemas-sony-com:serviceId:IRCC</serviceId>
<SCPDURL>http://172.25.1.73/sony/ircc/IRCCSCPD.xml</SCPDURL>
<controlURL>http://172.25.1.73/sony/ircc</controlURL>
<eventSubURL/>
</service>
</serviceList>
<av:X_ScalarWebAPI_DeviceInfo xmlns:av="urn:schemas-sony-com:av">
<av:X_ScalarWebAPI_Version>1.0</av:X_ScalarWebAPI_Version>
<av:X_ScalarWebAPI_BaseURL>http://172.25.1.73/sony</av:X_ScalarWebAPI_BaseURL>
<av:X_ScalarWebAPI_ServiceList>
<av:X_ScalarWebAPI_ServiceType>guide</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>recording</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>browser</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>accessControl</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>encryption</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>contentshare</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>avContent</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>cec</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>audio</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>system</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>appControl</av:X_ScalarWebAPI_ServiceType>
<av:X_ScalarWebAPI_ServiceType>videoScreen</av:X_ScalarWebAPI_ServiceType>
</av:X_ScalarWebAPI_ServiceList>
</av:X_ScalarWebAPI_DeviceInfo>
<av:X_IRCC_DeviceInfo xmlns:av="urn:schemas-sony-com:av">
<av:X_IRCC_Version>1.0</av:X_IRCC_Version>
<av:X_IRCC_CategoryList>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAEAAAAB</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAACk</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAACX</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAAB3</av:X_CategoryInfo>
</av:X_IRCC_Category>
<av:X_IRCC_Category>
<av:X_CategoryInfo>AAIAAAAa</av:X_CategoryInfo>
</av:X_IRCC_Category>
</av:X_IRCC_CategoryList>
</av:X_IRCC_DeviceInfo>
<av:X_IRCCCodeList xmlns:av="urn:schemas-sony-com:av">
<av:X_IRCCCode command="Power">AAAAAQAAAAEAAAAVAw==</av:X_IRCCCode>
</av:X_IRCCCodeList>
<av:X_RDIS_DeviceInfo xmlns:av="urn:schemas-sony-com:av">
<av:X_RDIS_Version>1.0</av:X_RDIS_Version>
<av:X_RDIS_SESSION_CONTROL>true</av:X_RDIS_SESSION_CONTROL>
<av:X_RDIS_KEEP_ALIVE>false</av:X_RDIS_KEEP_ALIVE>
<av:X_RDIS_ENTRY_PORT>46787</av:X_RDIS_ENTRY_PORT>
</av:X_RDIS_DeviceInfo>
</device>
</root>

Posted on
Wed Sep 14, 2016 5:20 pm
swwempa offline
Posts: 5
Joined: Jul 22, 2016

Re: New TV does not respond to commands

Hi

Any news about an update or fix for the new Tv?

Posted on
Wed Sep 14, 2016 10:12 pm
RogueProeliator offline
User avatar
Posts: 2243
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: New TV does not respond to commands

Any news about an update or fix for the new Tv?

Wow, so I owe you an apology -- your previous post was the day that basically our entire city flooded and we lost power... and I forgot to follow up once things started to settle down.

At any rate, the first thing that I notice is that your television's control URL is ever so slightly different - specifically it is in a differing case (all lower). Since the control system is some flavor of embedded linux, this could potentially be case sensitive. To test this, edit your device properties and change the Path setting from /sony/IRCC to /sony/ircc

If that does not fix you up, try going to http://172.25.1.73/sony/ircc/IRCCSCPD.xml in a browser and grabbing the contents returned (note it is XML so may have to View Source, depending on your browser).

Adam

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest