Everspring SP815-1 motion detector not working

Posted on
Sat Feb 20, 2021 12:07 pm
rijdat offline
Posts: 17
Joined: Mar 06, 2011

Everspring SP815-1 motion detector not working

Hi, I am in the UK and trying to get a pair of Everspring motion detectors working, I bought them from Vesternet. The Indigo list of compatible devices lists the SP814 and the SP816 but I have the SP815. They both successfully auto-include, calling themselves Notification Sensors. With the back off I can get them to send status updates (just battery state) and tell me about parameters. But with the back on they soon fall asleep and don't respond to either status requests or parameter requests and they never send any kind of alert. So they are as useful as a pair of stones. Anyone had any luck with these ?

Cheers, Richard

Posted on
Sat Feb 20, 2021 2:34 pm
matt (support) offline
Site Admin
User avatar
Posts: 20436
Joined: Jan 27, 2003
Location: Texas

Re: Everspring SP815-1 motion detector not working

Hi Richard,

See if using a Trigger matching on the raw motion commands from the module works as detailed here. Also can you wake it, re-sync, then copy/paste the Event Log results into a reply for us? I'd like to see the details of how the module reports its ID and capabilities.

Image

Posted on
Sun Feb 21, 2021 3:31 am
rijdat offline
Posts: 17
Joined: Mar 06, 2011

Everspring SP815-1 motion detector not working

Thanks for your very swift response Matt.

I have set up the trigger as you suggest but it is never triggered. I know the detector is working at least in test mode - with the back off and the tamper switch off - because it lights an LED when it detects movement, but nothing appears in the Event Log and the trigger I set up doesn't come into action.

Here is the info the device sent Indigo on Sync:

Syncing - started for "Kitchen motion sensor"
Z-Wave Syncing - retrieved module neighbors list: 1, 2, 3, 5, 7, 8, 13, 14, 15, 16, 19, 20
Z-Wave Syncing - assigning return route to "021 - Kitchen motion sensor"
Z-Wave Syncing - assigned return route
Z-Wave Syncing - retrieved manufacture and model names: Everspring - 0060, Notification Sensor - 00010004
Z-Wave Syncing - retrieved protocol version 5.03, app version 1.01
Z-Wave Syncing - retrieved class hierarchy: Routing Slave : Notification Sensor : Notification Sensor (04 : 07 : 01, base 00)
Z-Wave Syncing - retrieved command classes: 80v1 84v2 85v1 86v1 55v1 98v1 59v1 5Av1 5Ev1 9Fv1 20v1 71v1 6Cv1 70v1 31v5 72v1 73v1 7Av1
Z-Wave Syncing - retrieved encrypt commands: - none -
Z-Wave Syncing - retrieved capabilities: routing, battery, beaming, security, waking
Z-Wave Syncing - retrieved wake interval of 60 minutes
Z-Wave Syncing - device "021 - Kitchen motion sensor" wake interval changed to 60 minutes
Z-Wave Syncing - retrieved group 1 associations: [1]
Z-Wave Syncing - retrieved group 2 associations: []
Z-Wave Syncing - group 1 association to interface already exists (skipping)
Z-Wave Syncing - retrieved battery level of 100%
Z-Wave Syncing - complete

Cheers, Richard

Posted on
Sun Feb 21, 2021 3:48 am
rijdat offline
Posts: 17
Joined: Mar 06, 2011

Re: Everspring SP815-1 motion detector not working

For info, I also have two Everspring SP814s on my network and these work well.

Posted on
Sun Feb 21, 2021 6:05 am
rijdat offline
Posts: 17
Joined: Mar 06, 2011

Re: Everspring SP815-1 motion detector not working

Some progress. I found that the sensor is sending 0x01 0x0F 0x00 0x04 0x00 0x15 0x09 0x71 0x05 0x00 0x00 0x00 0xFF 0x07 0x08 0x00 0x6C when it detects motion and put that in the trigger event. So it now tells Indigo when it detects motion, but only when it is awake, which is hardly ever.

Posted on
Sun Feb 21, 2021 7:02 am
rijdat offline
Posts: 17
Joined: Mar 06, 2011

Re: Everspring SP815-1 motion detector not working

Some more progress, it's still asleep most of the time I ask it for a status update but is working much better at detecting motion and sending a Z Wave signal. I'll see how it does over the next few days and let you know.

Thanks again for your help.

Posted on
Sun Feb 21, 2021 8:24 am
autolog offline
Posts: 3441
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: Everspring SP815-1 motion detector not working

rijdat wrote:
Some more progress, it's still asleep most of the time I ask it for a status update but is working much better at detecting motion and sending a Z Wave signal. ...


This device is powered by a battery therefore it won't respond to status requests as it only wakes up periodically or when it detects motion. It is the nature of battery powered motion detectors and is absolutely normal. :)

Posted on
Mon Mar 01, 2021 3:24 pm
rijdat offline
Posts: 17
Joined: Mar 06, 2011

Re: Everspring SP815-1 motion detector not working

Final update, this device is now working well, thanks for the tip on looking at the raw Z-wave data.

I have a second one and it does not report any motion, presumably the full string I have used includes some data unique to the device so one works but the other doesn't. For full integration this device claims it should also report temperature and humidity.

Thanks again for the help in getting this working.

Posted on
Tue Mar 02, 2021 8:16 am
CliveS offline
Posts: 534
Joined: Jan 10, 2016
Location: Medomsley, County Durham, UK

Re: Everspring SP815-1 motion detector not working

rijdat wrote:
Final update, this device is now working well, thanks for the tip on looking at the raw Z-wave data.

I have a second one and it does not report any motion, presumably the full string I have used includes some data unique to the device so one works but the other doesn't. For full integration this device claims it should also report temperature and humidity.

Thanks again for the help in getting this working.


Yes part of the string is pointing to the Device Number "021 - Kitchen motion sensor" which is 0x15 in your string, I spent several months adding to Peter's Z-Wave plugin to add many types of unsupported devices to Indigo and it is a minefield :) but it taught me a lot about Python (and how bad I am at it)

I think if you use
Code: Select all
* 0x15 ? 0x71 ? ? ? ? ? 0x07 0x08 *

That will trigger motion on and

Code: Select all
* 0x15 ? 0x71 ? ? ? ? ? 0x07 0x00 *

Should trigger motion off.

To use the other device find the device number and then ask Google to convert that to Hex, so say it was device number 43 then that is Hex 2b so change the the 0x15 to 0x2b (using your Hex value).

That should get your second motion sensor working.

CliveS

Indigo 7.5.0 : MacOS Catalina 10.15.1 : Mac mini Server (Mid 2011) : 2 GHz Core i7. : 8 GB. : 2 x 256GB Samsung EVO SSD
----------------------------------------------------------------------------------
The best way to get the right answer on the Internet is not to ask a question, it's to post the wrong answer

Posted on
Wed Mar 03, 2021 1:48 am
rijdat offline
Posts: 17
Joined: Mar 06, 2011

Re: Everspring SP815-1 motion detector not working

Thanks Clive, that's really helpful.

Cheers, Richard

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 4 guests

cron