How to stop temperature reporting from HS-LS100+ leak sensor

Posted on
Tue Jan 12, 2021 6:53 pm
ken_jacobs offline
Posts: 164
Joined: Jul 23, 2005

How to stop temperature reporting from HS-LS100+ leak sensor

I can not stop temperature reporting from the subject leak sensor. I have tried 0, 144, and 254 for a reporting interval . Has anyone been successful in eliminating this unwanted drain on the sensor battery.

Posted on
Tue Jan 12, 2021 8:08 pm
matt (support) offline
Site Admin
User avatar
Posts: 20380
Joined: Jan 27, 2003
Location: Texas

Re: How to stop temperature reporting from HS-LS100+ leak se

I just checked the manual and Indigo's device definition and it looks correct (based on the manual at least). Indigo uses parameter 19 for the temperature interval. After you set it, re-sync it in Indigo then copy/paste the Event Log window results of both setting it and the re-sync. I'm curious if the re-sync shows that the setting "took" or not.

Image

Posted on
Wed Jan 13, 2021 9:14 am
ken_jacobs offline
Posts: 164
Joined: Jul 23, 2005

Re: How to stop temperature reporting from HS-LS100+ leak se

Listed below is the log of a change in temperature reporting interval:

2021-01-01 10:08:17.328 Z-Wave Error device "Dishwasher Leak Detector" may be asleep. configuration changes will be set during the next wake interval.
2021-01-01 10:08:36.377 Application Indigo Cocoa client disconnected
2021-01-01 10:08:37.882 Z-Wave received "025 - Washing Machine Leak Detector" status update battery level 94%
2021-01-01 10:08:38.026 Z-Wave device "025 - Washing Machine Leak Detector" parameter 19 "Temperature interval" changed to 250 minutes
2021-01-01 10:08:38.186 Z-Wave received "025 - Washing Machine Leak Detector" status update battery level 94%

Posted on
Wed Jan 13, 2021 12:19 pm
matt (support) offline
Site Admin
User avatar
Posts: 20380
Joined: Jan 27, 2003
Location: Texas

Re: How to stop temperature reporting from HS-LS100+ leak se

What about the re-sync log results?

Image

Posted on
Fri Jan 15, 2021 9:25 am
ken_jacobs offline
Posts: 164
Joined: Jul 23, 2005

Re: How to stop temperature reporting from HS-LS100+ leak se

Listed below is resync with temperature interval changed to 254:

Jan 15, 2021 at 10:21:49 AM
Z-Wave Syncing - started for "Water Heater Leak Detector"
Z-Wave Syncing - retrieved module neighbors list: 5, 6, 8, 10, 11, 14, 17
Z-Wave Syncing - assigning return route to "020 - Water Heater Leak Detector"
Z-Wave Error Syncing - failed to assign return route
Z-Wave Syncing - retrieved manufacture and model names: HomeSeer - 000C, Leak Sensor (HS-LS100+) - 0201000A
Z-Wave Syncing - retrieved protocol version 4.61, app version 1.03
Z-Wave Syncing - retrieved class hierarchy: Routing Slave : Binary Sensor : Binary Sensor (routing) (04 : 20 : 01, base 30)
Z-Wave Syncing - retrieved command classes: 20v1 80v1 84v2 85v1 86v1 71v1 70v1 6Cv1 30v1 31v5 72v1 73v1 55v1 59v1 5Av1 7Av1 5Ev1 9Fv1
Z-Wave Syncing - retrieved encrypt commands: - none -
Z-Wave Syncing - retrieved capabilities: routing, battery, beaming, waking
Z-Wave Syncing - retrieved wake interval of 1440 minutes
Z-Wave Syncing - device "020 - Water Heater Leak Detector" wake interval changed to 1440 minutes
Z-Wave Syncing - retrieved group 1 associations: [1]
Z-Wave Syncing - retrieved group 2 associations: []
Z-Wave Syncing - group 1 association to interface already exists (skipping)
Z-Wave Syncing - retrieved parameter 17 "Leak interval" is 5 minutes
Z-Wave Syncing - retrieved parameter 19 "Temperature interval" is 144 minutes
Z-Wave Syncing - device "020 - Water Heater Leak Detector" parameter 19 "Temperature interval" changed to 254 minutes (was 144 minutes)
Z-Wave Syncing - retrieved parameter 18 "Enable tamper alert" is false
Z-Wave Syncing - retrieved battery level of 37%
Z-Wave Syncing - complete
Z-Wave Error send "Water Heater Leak Detector" status request failed
Z-Wave Error send "020 - Temperature" status request failed
Z-Wave Error send "020 - Tamper" status request failed

Posted on
Fri Jan 15, 2021 4:29 pm
matt (support) offline
Site Admin
User avatar
Posts: 20380
Joined: Jan 27, 2003
Location: Texas

Re: How to stop temperature reporting from HS-LS100+ leak se

Based on the log it looks like at the time of the sync the module reported parameter 14 to be 144, even though you had probably set it to 254. It then modified the value. If you re-sync it twice back to back, does it have to try to "fix" the value both times? If so that is definitely a sign the change to the parameter isn't "taking" for some reason.

Regardless of the results of the sync, this feels like s firmware bug to me. Have you tried contacting HomeSeer to see if they have any suggestions? This might be a known problem.

Image

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 3 guests

cron