Error reading plugin configuration, plugin stopped working

Posted on
Mon Feb 18, 2019 10:50 pm
peszko offline
Posts: 170
Joined: Mar 07, 2012

Error reading plugin configuration, plugin stopped working

I have a problem with the plugin. Recently I got a smoke detector tripped and in order to stop the plugin from continuously saying the tripped zone, I re-started the plugin. Now the plugin has stopped working completely. If I switch the logging level on the plugin to debug, I get the following repeated continuously.

Code: Select all
   DSC Alarm Debug                 STATE: Startup
   DSC Alarm Debug                 getConfiguration start
   DSC Alarm                       Error reading plugin configuration. (happens on very first launch)
   DSC Alarm Debug                 STATE: Startup
   DSC Alarm Debug                 getConfiguration start
   DSC Alarm                       Error reading plugin configuration. (happens on very first launch)


I tried to restart the plugin, restart indigo, reboot the computer, disconnect and re-connect the usb cable to the alarm. Nothing is working.

Posted on
Mon Feb 18, 2019 11:58 pm
peszko offline
Posts: 170
Joined: Mar 07, 2012

Re: Error reading plugin configuration, plugin stopped worki

I restored from last backup and it works again, but... Since I wanted to disable the speaking, I went in to configuration and cleared "enable speaking" All of the sudden all DSC functions stopped. When I re-enable it didn't make it work again. I think there is some glitch in how this setting is being handled.

Posted on
Tue Feb 19, 2019 4:49 pm
Monstergerm offline
Posts: 155
Joined: Sep 01, 2009

Re: Error reading plugin configuration, plugin stopped worki

This is weird. I cannot reproduce any of what you describe here.
Did you change any of the default variable and DSC folder names?
As Matt suggested I would delete the config pref file and start a fresh one. Perhaps it got corrupted. Make sure to write down all the settings before deleting it.

Posted on
Tue Feb 19, 2019 8:00 pm
peszko offline
Posts: 170
Joined: Mar 07, 2012

Re: Error reading plugin configuration, plugin stopped worki

I deleted the pref file and had the plugin re-create it as you suggested and it all seems to back to normal. I didn't rename any of the folders or variables (at least not knowingly).

Thanks for the help.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest