Problems after applying Mac OSX 10.12.6 security update

Posted on
Mon Feb 05, 2018 6:37 pm
aarono offline
Posts: 6
Joined: Jan 09, 2013

Problems after applying Mac OSX 10.12.6 security update

I'm still running sierra and have not upgraded to high sierra yet. I do stay up-to-date with security updates and one was recently released: 10.12.6 so I installed. Not long after, the security update was installed, Indigo started to loose connection with my DSC alarm plugin. I can see that the TCP connection gets reset and never re-establishes. If I login to eyez-on I can reboot the envisalink 2DS and it reconnects and works great for about a half hour (seems coincidentally as long a typical TCP session monitor). Looking in the indigo logs I see: "DSC Alarm Error - Connection RX Error: connection failed ([Errno 54] Connection reset by peer), DSC Alarm Error - Error in plugin execution runConcurrentThread:
Traceback (most recent call last): File "plugin.py", line 1410, in runConcurrentThread ValueError: invalid literal for int() with base 10: '-'
DSC Alarm Error - plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds), DSC Alarm - Initializing communication at address: x.x.x.x:4025 - DSC Alarm Error - Error opening socket: Could not open port socket://x.x.x.x:4025: [Errno 61] Connection refused.

Here is the log after I reboot the 2DS and disable and enable the DSC plugin:
Code: Select all
  DSC Alarm                       Log level preferences are set to "Verbose".
   Started plugin "DSC Alarm 2.2.2"
   DSC Alarm                       Initializing communication at address: x.x.x.x:4025
   DSC Alarm                       Communication established
   DSC Alarm                       Connected to Envisalink.
   DSC Alarm                       Enabling Time Broadcast
   DSC Alarm                       Time Broadcast enabled.
   DSC Alarm                       Pinging the panel to test communication...
   DSC Alarm                       Ping was successful.
   DSC Alarm                       Requesting a full state update.
   DSC Alarm                       State update request successful, initialization complete, starting normal operation.
   DSC Alarm                       Trouble Status Restore (LED OFF). (Partition 1)
   DSC Alarm                       Trouble Status Restore (LED OFF). (Partition 2)
   DSC Alarm                       Trouble Status Restore (LED OFF). (Partition 3)
   DSC Alarm                       Trouble Status Restore (LED OFF). (Partition 4)
   DSC Alarm                       Trouble Status Restore (LED OFF). (Partition 5)
   DSC Alarm                       Trouble Status Restore (LED OFF). (Partition 6)
   DSC Alarm                       Trouble Status Restore (LED OFF). (Partition 7)
   DSC Alarm                       Trouble Status Restore (LED OFF). (Partition 8)

I have the native Mac OS firewall disabled as it sits behind an SMB UTM firewall. For grins I tried to enable the firewall, but it blocked my mobile app access (port forwarding thru my FW) so I disabled it again.

I was running an older version of the DSC plugin and noticed the one that is in the plugin store was newer, so I updated, but it did not help.

Anyone seeing the same problem? Anyone have a work around?
Thanks! - Aaron

Posted on
Wed Feb 07, 2018 5:42 pm
jay (support) offline
Site Admin
User avatar
Posts: 14656
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Problems after applying Mac OSX 10.12.6 security update

Unfortunately, your lost posts for the actual errors are so munged in your post above that it's really difficult to see what the error actually is. I edited your post to put the bottom section of log entries in a code block so they're more readable, but they don't really show anything.

Please repost the errors in a code block so we can see what they say. I personally don't use a network connection to talk to my DSC (it's direct serial) so I'm not sure I'll be much help, but maybe once the errors are more readable someone else will have some ideas.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Feb 08, 2018 8:28 am
aarono offline
Posts: 6
Joined: Jan 09, 2013

NOT related to Mac OSX 10.12.6 security update!!

UPDATE: I restored a time machine backup that was taken just prior to the Mac OSX security update and my problem persisted. I kept loosing connection to the Envisalink, even though I could use the Envisalink website to interact with the module! After much looking, tracing, hoping... I have finally figured out that there was another device on my network trying to use the same IP as my Envisalink 2DS, even though I had the IP's reserved in my DHCP server. This explains why it would work for a little then stop! I've moved the address to the higher end of my network, so it can't be accidentally handed out to another device. Hopefully this information helps someone else that may run into this same problem! Hopefully my house will be back to normal now!

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest