Disarmed by user codes not showing up in Indigo

Posted on
Thu Dec 08, 2016 6:59 pm
dnomode offline
Posts: 364
Joined: Apr 12, 2008
Location: North Georgia

Disarmed by user codes not showing up in Indigo

Hello,

I'm trying to setup several triggers using Events: Alarm Disarmed by User Code. The problem I'm having is that non of the user codes show up in the log and the triggers never get triggered.

All I get is:
Code: Select all
   DSC Alarm                       Alarm Disarmed. (Partition 1)

Am I missing something?

Thanks for the help
Edmond

Posted on
Thu Dec 08, 2016 7:53 pm
Monstergerm offline
Posts: 174
Joined: Sep 01, 2009

Re: Disarmed by user codes not showing up in Indigo

The DSC panel is sending up to three disarm commands depending on the situation of the disarm (e.g. disarm during arming, disarm with a keyswitch, disarm by entering the code). Only one of the commands has the user information.
It looks like the way you disarm the panel does not trigger the command that has the user information in it. There is nothing that can be done by the plugin to fix this. How exactly are you disarming the panel and what is your hardware?

Posted on
Thu Dec 08, 2016 11:04 pm
dnomode offline
Posts: 364
Joined: Apr 12, 2008
Location: North Georgia

Re: Disarmed by user codes not showing up in Indigo

I'm disarming by typing in the code. I have a PK5501 and a RFK5564. Any ideas?


Sent from my iPhone using Tapatalk

Posted on
Fri Dec 09, 2016 12:09 am
Monstergerm offline
Posts: 174
Joined: Sep 01, 2009

Re: Disarmed by user codes not showing up in Indigo

And what alarm panel? And which Envisalink?

Posted on
Fri Dec 09, 2016 1:51 am
dnomode offline
Posts: 364
Joined: Apr 12, 2008
Location: North Georgia

Re: Disarmed by user codes not showing up in Indigo

PS1864 and I use the IT-100 to communicate with the plugin.


Sent from my iPhone using Tapatalk

Posted on
Fri Dec 09, 2016 11:24 am
Monstergerm offline
Posts: 174
Joined: Sep 01, 2009

Re: Disarmed by user codes not showing up in Indigo

This is weird. I have the PC1864 and PK5501 but the main difference is, I am using the Envisalink-4. However, the IT-100 is supposed to send the disarm command 750, which contains the user ID. Perhaps someone else using the IT-100 can test this feature.

And you are testing this by having the system fully armed before disarming? If you interrupt the arming during exit delay, the command 750 does not get triggered.

Posted on
Fri Dec 09, 2016 2:39 pm
kidney offline
Posts: 213
Joined: Jul 15, 2007

Re: Disarmed by user codes not showing up in Indigo

I have the IT-100 and I get the user,

2016-12-09 07:36:12.075 DSC Alarm Alarm Panel Disarmed by User 05 'Audrey'. (Partition 1 'Maison')

Do you have the "User Code Labelling" checked?

What version of the plugin do you have?

Posted on
Sun Dec 11, 2016 1:15 am
dnomode offline
Posts: 364
Joined: Apr 12, 2008
Location: North Georgia

Re: Disarmed by user codes not showing up in Indigo

Oh dang... I was not allowing the system to fully arm as I was testing the trigger. Thanks for pointing that out. It's sending correctly. Thx

Edmond


Sent from my iPhone using Tapatalk

Posted on
Tue Aug 29, 2017 3:42 am
agame offline
Posts: 402
Joined: Jul 13, 2017
Location: Melbourne, Australia

Re: Disarmed by user codes not showing up in Indigo

OK....everything working fine with the plugin (thanks) except when it comes to disarmed alerts, I am having no luck getting the notification to translate the user code to the user name (even though this is configured in the plugin setup). Is there a trick to this ??

Posted on
Tue Aug 29, 2017 10:38 am
Monstergerm offline
Posts: 174
Joined: Sep 01, 2009

Re: Disarmed by user codes not showing up in Indigo

What does your log say when you disarm the alarm panel?

Posted on
Tue Aug 29, 2017 9:29 pm
agame offline
Posts: 402
Joined: Jul 13, 2017
Location: Melbourne, Australia

Re: Disarmed by user codes not showing up in Indigo

It just reports the user ID (04; 05 etc) of who disarmed, but not the 'name' of that user as specified in the plugin config.
e.g.
DSC Alarm Alarm Panel Disarmed by User 01. (Partition 1 'main partition')

Posted on
Wed Aug 30, 2017 12:20 pm
Monstergerm offline
Posts: 174
Joined: Sep 01, 2009

Re: Disarmed by user codes not showing up in Indigo

It should say something like this if you use the master code:
Alarm Panel Disarmed by User 40 'Joe and Jane'. (Partition 1 'Mainhouse')

I suspect you did not enter the user ID/name information correctly. User ID 40 is the master code. I assume you have the other user IDs, e.g. 01, 02 etc setup correctly on the DSC panel to be associated with their corresponding disarm codes.

Click on Show/Hide User Code Labeling.
Make sure there is no space between the comma when you enter the IDs and names.
In the User Code field enter for example: 40,01,02 (DO NOT ENTER THE ACTUAL CODES; JUST THE IDs)
In the User Label field enter: Joe and Jane,Homer,Bart

Posted on
Thu Aug 31, 2017 8:32 pm
agame offline
Posts: 402
Joined: Jul 13, 2017
Location: Melbourne, Australia

Re: Disarmed by user codes not showing up in Indigo

hmmm. still struggling to spot my issue. I'll start from scratch on the weekend.
Would special characters in the user names screw things up (e.g. bill&ben)? I see you have spaces in your example so assume only the comma is significant? I also assume the list doesn't need to be exhaustive (indigo won't know if there are 'dormant' codes configured in the DSC that aren't being used...).

Posted on
Fri Sep 01, 2017 11:55 am
Monstergerm offline
Posts: 174
Joined: Sep 01, 2009

Re: Disarmed by user codes not showing up in Indigo

One of my IDs is Bill & Ben, which works fine with the space and the ambersand character. The comma is used as a list separator.
The User IDs do not need to be in order and do not need to be a complete list.

How are you disarming? Is the alarm panel fully armed and then you disarm from the keypad?

Posted on
Sun Dec 10, 2017 11:00 pm
agame offline
Posts: 402
Joined: Jul 13, 2017
Location: Melbourne, Australia

Re: Disarmed by user codes not showing up in Indigo

[sorry about the silence]...yes I have been disarming wit the keypad.
still no joy lol. I must be doing something odd!

Who is online

Users browsing this forum: No registered users and 1 guest