Aeon Labs MultiSensor (DSB05)

Posted on
Mon Mar 09, 2015 10:09 am
matt (support) offline
Site Admin
User avatar
Posts: 19175
Joined: Jan 27, 2003
Location: Texas

Re: Aeon Labs MultiSensor (DSB05)

The new internal library should work with it, but that version is not in the public version of Indigo 6 yet. It will be in the next release.

Image

Posted on
Sun Mar 29, 2015 3:59 pm
edrabbit offline
User avatar
Posts: 34
Joined: Apr 09, 2014

Re: Aeon Labs MultiSensor (DSB05)

Getting some weird behavior with a Multisensor. I used the ZWave stick to include it, seemed to work fine, but I've had all sorts of trouble syncing it. I've gotten it to work once successfully, but every other time it seems to fail at the point in the logs below. This is regardless of whether it's on battery and is awake or if it's on USB power. Think this is just a defective unit?

Code: Select all
Mar 29, 2015, 2:53:38 PM
  Z-Wave                          Syncing - started for device "(Motion) Living Room"
  Z-Wave                          Syncing - retrieved module neighbors list: 1, 6, 7
  Z-Wave                          Syncing - requesting neighbor list update of "011 - (Motion) Living Room"
  Z-Wave                          Syncing - neighbor list update complete (no change)
  Z-Wave                          Syncing - assigning return route to "011 - (Motion) Living Room"
  Z-Wave                          Syncing - assigned return route
  Z-Wave                          Syncing - retrieved manufacture and model names: Aeon Labs - 0086, Multi Sensor (DSB05) - 00020005
  Z-Wave                          Syncing - retrieved protocol version 3.28, app version 1.18
  Z-Wave                          Syncing - retrieved class hierarchy: Routing Slave : Binary Sensor : Binary Sensor (routing) (04 : 20 : 01, base 30)
  Z-Wave                          Syncing - retrieved command classes: 20v1 80v1 84v2 85v1 86v1 70v1 30v1 31v5 72v1
  Z-Wave                          Syncing - retrieved wake interval of 240 minutes
  Z-Wave                          Syncing - device "011 - (Motion) Living Room" wake interval changed to 240 minutes
  Z-Wave                          Syncing - retrieved group 1 associations: [1]
  Z-Wave                          Syncing - group 1 association to interface already exists (skipping)
  Z-Wave                          Syncing - retrieved Wake for 10 minutes after battery change is true
  Z-Wave                          Syncing - retrieved Enable motion sensor is true
  Z-Wave                          Syncing - retrieved parameter 3 "Delay after no motion before OFF sent" is 60 seconds
  Z-Wave                          Syncing - retrieved parameter 5 "Motion sensor command sent flags" is 1
  Z-Wave                          Syncing - retrieved parameter 101 "Group 1 report sent flags" is 224
  Z-Wave                          Syncing - retrieved parameter 102 "Group 2 report sent flags" is 0
  Z-Wave                          Syncing - retrieved parameter 103 "Group 3 report sent flags" is 0
  Z-Wave                          Syncing - module returned parameter 103 instead of parameter 111 "Delay between reporting sensors values" (skipping)
  Z-Wave                          Syncing - retrieved parameter 111 "Delay between reporting sensors values" is 300 seconds
  Z-Wave                          Syncing - retrieved parameter 112 "Delay between reporting for group 2 (unused)" is 720 seconds
  Z-Wave                          Syncing - retrieved parameter 113 "Delay between reporting for group 3 (unused)" is 720 seconds
  Z-Wave                          received "(Motion) Living Room" status update is on
  Z-Wave Error                    Timeout waiting for "011 - (Motion) Living Room". Module might be asleep, or is unreachable.
  Z-Wave                          Indigo Device "(Motion) Living Room" Z-Wave Properties:

Indigo Z-Wave Version: 1.0.281
Node ID: 11
Model: Multi Sensor (DSB05)
Model ID: 00020005
Manufacturer: Aeon Labs
Manufacturer ID: 0086
Protocol Version: 3.28
Application Version: 1.18
Model Definition Version: 4
Library Type: 6
Class Name: Binary Sensor (routing)
Class Hierarchy: 04 : 20 : 01
Command Class Base: 30
Command Versions: 20v1 80v1 84v2 85v1 86v1 70v1 30v1 31v5 72v1
Multi-Endpoint Types: - none -
Multi-Endpoint Classes: - none -
Multi-Instance Counts: - none -
Features: routing, battery, beaming, waking
Neighbors: 1, 6, 7
Associations: 1:[1]
Config Values: 112:720 113:720 2:1 3:60 4:1 5:1 102:0 103:0 111:300 101:224


Here are the logs from the one time I was finally able to sync:
Code: Select all
Mar 29, 2015, 2:50:28 PM
  Z-Wave                          Syncing - started for device "(Motion) Living Room"
  Z-Wave                          Syncing - retrieved module neighbors list: 1, 6, 7
  Z-Wave                          Syncing - requesting neighbor list update of "011 - (Motion) Living Room"
  Z-Wave                          received "(Motion) Living Room" status update is off
  Z-Wave                          Syncing - neighbor list update complete (no change)
  Z-Wave                          Syncing - assigning return route to "011 - (Motion) Living Room"
  Z-Wave                          Syncing - assigned return route
  Z-Wave                          Syncing - retrieved manufacture and model names: Aeon Labs - 0086, Multi Sensor (DSB05) - 00020005
  Z-Wave                          Syncing - retrieved protocol version 3.28, app version 1.18
  Z-Wave                          Syncing - retrieved class hierarchy: Routing Slave : Binary Sensor : Binary Sensor (routing) (04 : 20 : 01, base 30)
  Z-Wave                          Syncing - retrieved command classes: 20v1 80v1 84v2 85v1 86v1 70v1 30v1 31v5 72v1
  Z-Wave                          Syncing - retrieved wake interval of 240 minutes
  Z-Wave                          Syncing - device "011 - (Motion) Living Room" wake interval changed to 240 minutes
  Z-Wave                          received "(Lux) Downstairs" sensor update to 258 lux
  Z-Wave                          received "(Humidity) Downstairs" sensor update to 45%
  Z-Wave                          received "(Temp) Downstairs" sensor update to 73.6 °F
  Z-Wave                          Syncing - retrieved group 1 associations: [1]
  Z-Wave                          Syncing - group 1 association to interface already exists (skipping)
  Z-Wave                          Syncing - retrieved Wake for 10 minutes after battery change is true
  Z-Wave                          Syncing - retrieved Enable motion sensor is true
  Z-Wave                          Syncing - retrieved parameter 3 "Delay after no motion before OFF sent" is 60 seconds
  Z-Wave                          Syncing - retrieved parameter 5 "Motion sensor command sent flags" is 1
  Z-Wave                          Syncing - retrieved parameter 101 "Group 1 report sent flags" is 224
  Z-Wave                          Syncing - retrieved parameter 102 "Group 2 report sent flags" is 0
  Z-Wave                          Syncing - retrieved parameter 103 "Group 3 report sent flags" is 0
  Z-Wave                          Syncing - retrieved parameter 111 "Delay between reporting sensors values" is 300 seconds
  Z-Wave                          Syncing - retrieved parameter 112 "Delay between reporting for group 2 (unused)" is 720 seconds
  Z-Wave                          received "(Lux) Living Room" sensor update to 86 lux
  Z-Wave                          received "(Lux) Living Room" units changed to lux
  Z-Wave Error                    rcvd incomplete interface requestConfigVal packet (parm index 113, size 4): 01 0C 00 04 00 0B 06 70 06 71 04 00 00 F9 (expected 16 bytes)
  Z-Wave                          Syncing - retrieved battery level of 100%
  Z-Wave                          Syncing - complete
  Z-Wave                          sent "(Motion) Living Room" status request
  Z-Wave                          received "(Motion) Living Room" status update is off
  Z-Wave                          received "011 - (Motion) Living Room" status update battery level 100%
  Z-Wave                          Syncing - started for device "(Motion) Living Room"
  Z-Wave                          Syncing - retrieved module neighbors list: 1, 6, 7
  Z-Wave                          Syncing - requesting neighbor list update of "011 - (Motion) Living Room"
  Z-Wave                          Syncing - neighbor list update complete (no change)
  Z-Wave                          Syncing - assigning return route to "011 - (Motion) Living Room"
  Z-Wave                          Syncing - assigned return route
  Z-Wave                          Syncing - retrieved manufacture and model names: Aeon Labs - 0086, Multi Sensor (DSB05) - 00020005
  Z-Wave                          Syncing - retrieved protocol version 3.28, app version 1.18
  Z-Wave                          Syncing - retrieved class hierarchy: Routing Slave : Binary Sensor : Binary Sensor (routing) (04 : 20 : 01, base 30)
  Z-Wave                          Syncing - retrieved command classes: 20v1 80v1 84v2 85v1 86v1 70v1 30v1 31v5 72v1
  Z-Wave                          Syncing - retrieved wake interval of 240 minutes
  Z-Wave                          Syncing - device "011 - (Motion) Living Room" wake interval changed to 240 minutes
  Z-Wave                          Syncing - retrieved group 1 associations: [1]
  Z-Wave                          Syncing - group 1 association to interface already exists (skipping)
  Z-Wave                          Syncing - retrieved Wake for 10 minutes after battery change is true
  Z-Wave                          Syncing - retrieved Enable motion sensor is true
  Z-Wave                          Syncing - retrieved parameter 3 "Delay after no motion before OFF sent" is 60 seconds
  Z-Wave                          Syncing - retrieved parameter 5 "Motion sensor command sent flags" is 1
  Z-Wave                          Syncing - retrieved parameter 101 "Group 1 report sent flags" is 224
  Z-Wave                          Syncing - retrieved parameter 102 "Group 2 report sent flags" is 0
  Z-Wave                          Syncing - retrieved parameter 103 "Group 3 report sent flags" is 0
  Z-Wave                          Syncing - retrieved parameter 111 "Delay between reporting sensors values" is 300 seconds
  Z-Wave                          Syncing - retrieved parameter 112 "Delay between reporting for group 2 (unused)" is 720 seconds
  Z-Wave                          Syncing - retrieved parameter 113 "Delay between reporting for group 3 (unused)" is 720 seconds
  Z-Wave                          Syncing - retrieved battery level of 100%
  Z-Wave                          received "(Lux) Living Room" sensor update to 88 lux
  Z-Wave                          received "(Humidity) Living Room" sensor update to 38%
  Z-Wave                          received "(Humidity) Living Room" units changed to %
  Z-Wave                          received "(Temp) Living Room" sensor update to 78.1 °F
  Z-Wave                          received "(Temp) Living Room" units changed to °F
  Z-Wave                          Syncing - complete
  Z-Wave                          sent "(Motion) Living Room" status request
  Z-Wave                          received "(Motion) Living Room" status update is off
  Z-Wave                          received "011 - (Motion) Living Room" status update battery level 100%
  Z-Wave                          received "(Motion) Living Room" status update is on

Posted on
Sun Mar 29, 2015 9:25 pm
matt (support) offline
Site Admin
User avatar
Posts: 19175
Joined: Jan 27, 2003
Location: Texas

Re: Aeon Labs MultiSensor (DSB05)

Is your Z-Stick plugged directly into your Mac (and not a USB extension cable or hub)?

And have you tried re-syncing it within a few feet of the Z-Stick to see if might be a range issue?

Image

Posted on
Mon Mar 30, 2015 10:00 pm
edrabbit offline
User avatar
Posts: 34
Joined: Apr 09, 2014

Re: Aeon Labs MultiSensor (DSB05)

Z-Stick is plugged directly into the back of my Mac Mini. I've got 4 other Multisensors in the house, including one I successfully setup at the same time as this one.
I was able to get the one successful sync when I was in the same room as the Stick plugged into the Mac, but then an immediate subsequent sync in the same location failed too. I don't think it's a range issue as I'm successfully receiving Motion sensor on and off messages. However I have only received one or two readings from the other onboard sensors (Lux/Humidity/Temp).
FWIW, when I open the device in Indigo it says it's a "Multi Sensor (DSB05)" but now I don't see the extra settings in the dialog.
Screen Shot 2015-03-30 at 8.57.36 PM.png
Screen Shot 2015-03-30 at 8.57.36 PM.png (342.94 KiB) Viewed 2834 times

Posted on
Tue Mar 31, 2015 3:30 pm
wideglidejrp offline
User avatar
Posts: 455
Joined: Jan 15, 2012
Location: Danbury, CT

Re: Aeon Labs MultiSensor (DSB05)

I have the multi sensor installed on my z-wave network with Indigo. Works fine except the Lux is always 1,000 even in the wee hours of pitch blackness. The temp and humidity readings work fine. How can I find what level of firmware my multisensor has?

John Patrick
Author of Home Attitude
http://johnpatrick.com

Posted on
Tue Mar 31, 2015 8:22 pm
marcruggiano offline
Posts: 7
Joined: Apr 29, 2014

Re: Aeon Labs MultiSensor (DSB05)

I installed the new library, and the Gen5 multi-seonsor is working great now. It still showed up as "Remote Slave" when I added it to the Z-stick, just like it did with the old library. I was thrown off at first, but since that was the only option I sync'd it anyway. Once it started to sync, it showed as "Multi sensor (ZW074)". It has worked fine since.
Marc

Posted on
Thu Apr 02, 2015 12:59 pm
matt (support) offline
Site Admin
User avatar
Posts: 19175
Joined: Jan 27, 2003
Location: Texas

Re: Aeon Labs MultiSensor (DSB05)

edrabbit wrote:
However I have only received one or two readings from the other onboard sensors (Lux/Humidity/Temp).
FWIW, when I open the device in Indigo it says it's a "Multi Sensor (DSB05)" but now I don't see the extra settings in the dialog.
Screen Shot 2015-03-30 at 8.57.36 PM.png

I'm not sure what is going wrong. It could be a malfunctioning Z-Stick, although like you said it would be odd that some commands come in fine. But it could be failing in a subtle manner. Or the multi-sensors could be bad. That would be more likely, I think. Have you tried excluding it from the Z-Stick and re-including it (then resyncing it in Indigo)?

The settings dialog probably isn't showing the UI for the MultiSensor because the last time you did a sync it wasn't able to complete successfully.

Image

Posted on
Thu Apr 02, 2015 1:00 pm
matt (support) offline
Site Admin
User avatar
Posts: 19175
Joined: Jan 27, 2003
Location: Texas

Re: Aeon Labs MultiSensor (DSB05)

wideglidejrp wrote:
I have the multi sensor installed on my z-wave network with Indigo. Works fine except the Lux is always 1,000 even in the wee hours of pitch blackness. The temp and humidity readings work fine. How can I find what level of firmware my multisensor has?

Sounds like it is malfunctioning. I'd try excluding it from the Z-Stick, re-including it, then re-syncing it in Indigo. It can take a while for the first LUX value to be sent, so if no good values show up after an hour or two then I think it isn't working correctly.

Image

Posted on
Fri Apr 03, 2015 11:38 am
wideglidejrp offline
User avatar
Posts: 455
Joined: Jan 15, 2012
Location: Danbury, CT

Re: Aeon Labs MultiSensor (DSB05)

I excluded and included and it appears to be working. btw, I see Aeon has announced a newer better MultiSensor that will ship in May. Thanks for the tip.

John Patrick
Author of Home Attitude
http://johnpatrick.com

Posted on
Wed Apr 08, 2015 10:56 am
edrabbit offline
User avatar
Posts: 34
Joined: Apr 09, 2014

Re: Aeon Labs MultiSensor (DSB05)

FWIW, I placed the bad multisensor next to a known good one that was mere feet from the ZStick. Still no luck. Returned it as defective. Will replace with one of the new gen multisensors!

Posted on
Sat May 30, 2015 12:10 pm
edrabbit offline
User avatar
Posts: 34
Joined: Apr 09, 2014

Re: Aeon Labs MultiSensor (DSB05)

I'm back with a different kind of odd multisensor behavior. I have the reporting interval set to 300seconds, however it's actually reporting every 8 minutes (480seconds). Not a huge deal, but this appears to be happening with all of my multisensors, any idea what's going on?

Code: Select all
May 30, 2015, 11:08:25 AM
  Z-Wave                          Indigo Device "(Motion) Downstairs" Z-Wave Properties:
Indigo Z-Wave Version: 1.0.350
Node ID: 10
Model: Multi Sensor (DSB05)
Model ID: 00020005
Manufacturer: Aeon Labs
Manufacturer ID: 0086
Protocol Version: 3.28
Application Version: 1.18
Model Definition Version: 4
Library Type: 6
Class Name: Binary Sensor (routing)
Class Hierarchy: 04 : 20 : 01
Command Class Base: 30
Command Versions: 20v1 80v1 84v2 85v1 86v1 70v1 30v1 31v5 72v1
Multi-Endpoint Types: - none -
Multi-Endpoint Classes: - none -
Multi-Instance Counts: - none -
Features: routing, battery, beaming, waking
Neighbors: 1, 6, 7
Associations: 1:[1]
Config Values: 2:1 3:60 4:1 5:1 101:224 102:0 103:0 111:300 112:720 113:720


Code: Select all
./indigo_log.txt:2015-05-30 09:49:08.343   Z-Wave   received "(Lux) Downstairs" sensor update to 96 lux
./indigo_log.txt:2015-05-30 09:49:08.379   Z-Wave   received "(Humidity) Downstairs" sensor update to 45%
./indigo_log.txt:2015-05-30 09:49:08.398   Z-Wave   received "(Temp) Downstairs" sensor update to 71.1 °F
./indigo_log.txt:2015-05-30 09:57:08.317   Z-Wave   received "(Lux) Downstairs" sensor update to 103 lux
./indigo_log.txt:2015-05-30 09:57:08.319   Z-Wave   received "(Humidity) Downstairs" sensor update to 45%
./indigo_log.txt:2015-05-30 09:57:08.352   Z-Wave   received "(Temp) Downstairs" sensor update to 70.8 °F
./indigo_log.txt:2015-05-30 10:05:08.264   Z-Wave   received "(Lux) Downstairs" sensor update to 109 lux
./indigo_log.txt:2015-05-30 10:05:08.282   Z-Wave   received "(Humidity) Downstairs" sensor update to 45%
./indigo_log.txt:2015-05-30 10:05:08.320   Z-Wave   received "(Temp) Downstairs" sensor update to 70.8 °F
./indigo_log.txt:2015-05-30 10:13:08.201   Z-Wave   received "(Lux) Downstairs" sensor update to 130 lux
./indigo_log.txt:2015-05-30 10:13:08.238   Z-Wave   received "(Humidity) Downstairs" sensor update to 45%
./indigo_log.txt:2015-05-30 10:13:08.275   Z-Wave   received "(Temp) Downstairs" sensor update to 70.6 °F
./indigo_log.txt:2015-05-30 10:21:10.188   Z-Wave   received "(Lux) Downstairs" sensor update to 133 lux
./indigo_log.txt:2015-05-30 10:21:10.190   Z-Wave   received "(Humidity) Downstairs" sensor update to 45%
./indigo_log.txt:2015-05-30 10:21:10.224   Z-Wave   received "(Temp) Downstairs" sensor update to 71.0 °F
./indigo_log.txt:2015-05-30 10:29:10.146   Z-Wave   received "(Lux) Downstairs" sensor update to 147 lux
./indigo_log.txt:2015-05-30 10:29:10.148   Z-Wave   received "(Humidity) Downstairs" sensor update to 46%
./indigo_log.txt:2015-05-30 10:29:10.183   Z-Wave   received "(Temp) Downstairs" sensor update to 70.7 °F
./indigo_log.txt:2015-05-30 10:37:10.082   Z-Wave   received "(Lux) Downstairs" sensor update to 166 lux
./indigo_log.txt:2015-05-30 10:37:10.099   Z-Wave   received "(Humidity) Downstairs" sensor update to 46%
./indigo_log.txt:2015-05-30 10:37:10.136   Z-Wave   received "(Temp) Downstairs" sensor update to 70.9 °F
./indigo_log.txt:2015-05-30 10:45:10.063   Z-Wave   received "(Lux) Downstairs" sensor update to 171 lux
./indigo_log.txt:2015-05-30 10:45:10.065   Z-Wave   received "(Humidity) Downstairs" sensor update to 46%
./indigo_log.txt:2015-05-30 10:45:10.098   Z-Wave   received "(Temp) Downstairs" sensor update to 70.6 °F
./indigo_log.txt:2015-05-30 10:53:10.019   Z-Wave   received "(Lux) Downstairs" sensor update to 177 lux
./indigo_log.txt:2015-05-30 10:53:10.021   Z-Wave   received "(Humidity) Downstairs" sensor update to 46%
./indigo_log.txt:2015-05-30 10:53:10.054   Z-Wave   received "(Temp) Downstairs" sensor update to 71.0 °F
./indigo_log.txt:2015-05-30 11:01:12.935   Z-Wave   received "(Lux) Downstairs" sensor update to 201 lux
./indigo_log.txt:2015-05-30 11:01:12.973   Z-Wave   received "(Humidity) Downstairs" sensor update to 46%
./indigo_log.txt:2015-05-30 11:01:13.006   Z-Wave   received "(Temp) Downstairs" sensor update to 70.8 °F

Posted on
Sun May 31, 2015 5:25 pm
matt (support) offline
Site Admin
User avatar
Posts: 19175
Joined: Jan 27, 2003
Location: Texas

Re: Aeon Labs MultiSensor (DSB05)

Looks like a buglet in their firmware. :-)

Image

Posted on
Wed Jul 01, 2015 2:41 pm
rgspb offline
Posts: 165
Joined: Apr 24, 2009
Location: Florida

I should have done more homework!

I just purchased two of the Aeotec MultiSensors and shouldn't have. :oops: Firstly, out of the box it took me a while to get either of them to work. It seems the LED light is on the other side of the device from where the instructions say it is. That little bit of info would have been a great addition to the setup instructions here! Then I find I need an additional device for Indigo to even recognize a Z-Wave device. Unfortunately for me I just assumed that since it was compatible with Indigo that it would just work...my fault for not doing more homework first. But it seems that in the end these would not work for me anyway. I was wanting to install one in the main house and another one in the guest house. Based on what I've read it doesn't sound like I would get that sort of range out of the Z-Stick required to run these two devices. Hopefully I can return these. Is there an Insteon alternative to these? I've got Indigo controlling various things in the guest house so I know I've got the range I need for Insteon.

Hiding my head in shame...

Posted on
Thu Jul 02, 2015 4:56 pm
matt (support) offline
Site Admin
User avatar
Posts: 19175
Joined: Jan 27, 2003
Location: Texas

Re: Aeon Labs MultiSensor (DSB05)

You could try seeing if a Z-Wave repeater can help extend the range, but it may not help if it isn't placed relatively between where the Z-Stick and the multisensor are located.

There is an INSTEON motion sensor available but it does not support the other sensors (temperature, lux, etc.).

Image

Posted on
Thu Jul 02, 2015 7:30 pm
rgspb offline
Posts: 165
Joined: Apr 24, 2009
Location: Florida

Re: Aeon Labs MultiSensor (DSB05)

Thanks, I was really attracted to the multi sensors in this module.

Who is online

Users browsing this forum: No registered users and 1 guest