Aeon Labs Z-Stick Series 2 (DSA02203)

Posted on
Sat Jun 07, 2014 10:43 am
berkinet offline
User avatar
Posts: 3437
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Interface fails to find Z-Stick on reboot

This problem was identified a while ago, right after Z-Wave support was added to Indigo. Sometimes, like a power failure, or a crashed system, or at times, even a regular re-boot, the device name for the Z-Stick changes. I always have a /dev/tty.SLAB_USBtoUART and then another /dev/tty.SLAB_USBtoUARTn. The correct interface device is usually the one ending in the integer.

Anyway, the question is, has anyone come up with a fix or a work around for this problem? If there was one discussed, I guess I missed it. In that case, could someone point me to the thread.

BTW, I have just now upgraded to the latest driver with the installer dates 16-January-2014. Though the read me says CP210x Macintosh OSX VCP Driver v3.1 - December 6, 2012. If this is supposed to address this problem I guess I'll figure it out soon enough.

Posted on
Sat Jun 07, 2014 11:53 am
jay (support) offline
Site Admin
User avatar
Posts: 16902
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

The problem is that you have multiple devices that use the SILabs driver. Several discussions, including some contact with SILabs - no good resolution as the problem is either with the Silicon Labs driver or the hardware manufacturers that use the SILabs chipset - they seem to be playing the blame game.

viewtopic.php?p=61333#p61333
viewtopic.php?p=65693#p65693

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Jan 02, 2015 5:31 am
macpro offline
User avatar
Posts: 723
Joined: Dec 29, 2005
Location: Third byte on the right

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

I'm having troubles with my Z-Stick. It works fine with Indigo and all lights are controlled just the way they should be.
But when I unplug the Z-Stick and try to include new devices, it won't work. The blue lights flashes as long as I press the button and stops immediately when I release the button.
It looks like I have to replace the Z-Stick, but does this mean I have to rebuild my entire Z-Wave configuration again?
Or is Indigo capable of reading the configuration from the current Z-Stick and putting it back in a new Z-Stick?

"I tawt I taw a puddy tat!" Tweety

Posted on
Fri Jan 02, 2015 9:47 am
matt (support) offline
Site Admin
User avatar
Posts: 20606
Joined: Jan 27, 2003
Location: Texas

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

So the blue light doesn't "stick" in a flashing state, but it used to (and used to work correctly)? I've never heard of that, but if that is the case I think it has malfunctioned. The Z-Stick doesn't support reading/writing of its inclusion database (there was talk of that feature being added, but to my knowledge it doesn't work yet). So you will have to exclude/re-include all the devices if you get a replacement.

Image

Posted on
Fri Jan 02, 2015 10:48 am
macpro offline
User avatar
Posts: 723
Joined: Dec 29, 2005
Location: Third byte on the right

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

matt (support) wrote:
So the blue light doesn't "stick" in a flashing state, but it used to (and used to work correctly)?

Yep.
matt (support) wrote:
So you will have to exclude/re-include all the devices if you get a replacement.

How nice.
Not. :(

Does Indigo support other Z-Wave controllers that don't have this "feature"?

"I tawt I taw a puddy tat!" Tweety

Posted on
Sat Jan 03, 2015 1:10 pm
matt (support) offline
Site Admin
User avatar
Posts: 20606
Joined: Jan 27, 2003
Location: Texas

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

Indigo supports the EZ-Controller (aka Z-Troller) which does have network backup ability, BUT Indigo does not yet have the UI/support for that feature. It is on our ToDo list however. There are other Z-Wave interfaces as well that we are investigating that have this capability (but again we need to add the Indigo UI/support for it as well).

Image

Posted on
Sat Jan 03, 2015 2:01 pm
macpro offline
User avatar
Posts: 723
Joined: Dec 29, 2005
Location: Third byte on the right

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

You have my vote for backup / restore options! :lol:

Let's say I would order a new Z-Stick.
I can include all my Z-Wave modules into that stick, but they will probably get new IDs/numbers.
How will Indigo react when I remove the old stick and insert the new one?

"I tawt I taw a puddy tat!" Tweety

Posted on
Sat Jan 03, 2015 4:07 pm
richo offline
Posts: 155
Joined: Nov 25, 2014
Location: Pomorskie, Poland

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

You will have to resynch devices with those defined in Indigo. All tigers, actions etc should work. Be careful as some devices will try to synch automatically with new z-wave IDs.

Matt, could you please also include UZB1 stick on the list of new backup features :-)

Ryszard

Posted on
Sun Jun 28, 2015 9:40 am
resnick offline
Posts: 59
Joined: Jan 18, 2015
Location: Urbana, IL

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

I'm having some range issues. I'm trying a couple of devices to get the Z-Stick vertical and pointed in another direction, but so far I'm still getting frequent "no ack/nak/busy reply" and "status update failed" from the furthest away devices. I'm wondering if the Range Extender/Repeater (DSD37-ZWUS) is worth trying. I thought that most Z-Wave devices did their own repeating, and I've got a string of devices between the Z-Stick and the farthest device. But would a well-placed repeater help? And if so, where should I place it?

Posted on
Mon Jun 29, 2015 9:58 am
matt (support) offline
Site Admin
User avatar
Posts: 20606
Joined: Jan 27, 2003
Location: Texas

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

The repeater might help, but another routing modules should help as well. Have you re-define/sync'd the in-between routing modules? That will help the Z-Stick rebuild the routing tables which can help. If the unreachable modules are battery powered then I would wake them up before syncing the other (closer modules).

Image

Posted on
Mon Jun 29, 2015 10:14 am
resnick offline
Posts: 59
Joined: Jan 18, 2015
Location: Urbana, IL

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

So, almost everything in the house (about 35 devices) is a light switch or dimmer, mostly Leviton DZS15 switches and DZMX1 dimmers, with a couple of others thrown in. Aren't these all supposed to be routing? The only things battery powered are some Minimotes. I did re-define/sync to rebuild the routing tables (a rather tedious process), but that hasn't seemed to help. The distance between any two switches can't be more than 10 ft., and there is a switch in the same room with the Z-Stick. Is a repeater going to help any? Is there any diagnosis I can do?

Posted on
Sun Nov 20, 2016 11:42 am
gskarp offline
Posts: 116
Joined: Apr 19, 2012

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

I have the Aeon DSA02203 Z-stick and want to use it with the ZW098 bulb or the ZW100 Multisensor now that those devices are supported by Indigo 7. Does anyone know if this will talk to the newer aeotech devices?

Posted on
Sun Nov 20, 2016 5:05 pm
matt (support) offline
Site Admin
User avatar
Posts: 20606
Joined: Jan 27, 2003
Location: Texas

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

Yes, it should work fine.

Image

Posted on
Fri Mar 24, 2017 7:23 pm
epounds offline
Posts: 16
Joined: Aug 30, 2013

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

My Series 2 Z-Stick is not holding charge. When I disconnect it from the USB port and press the button, it only blinks a few times and then the light goes out. This makes it very hard to include new devices.

I tried powering it near the device I need to include, but when the USB port is connected, it cannot be put into inclusion mode.

Has anyone else experienced this? Is there any solution other than replacing the device?

Posted on
Fri Mar 24, 2017 9:21 pm
Jann offline
Posts: 105
Joined: Mar 12, 2006
Location: Auburndale, FL

Re: Aeon Labs Z-Stick Series 2 (DSA02203)

I haven't ... where'd you buy it? Amazon?

Who is online

Users browsing this forum: No registered users and 1 guest