background task not loading/running?

Posted on
Sat Apr 23, 2016 9:41 pm
dtich online
Posts: 628
Joined: Sep 24, 2005

background task not loading/running?

hey all. i have an iTunes sync script that runs in background tasks that updates variables to current iTunes tracks etc every few seconds. this has lived in background tasks folder for a long time and worked for a long time, i run it at server start.

lately however, last few versions, it doesn't seem to run and keep the process; if i manually call the update handler it will update variables, so the script is loaded, but it is no longer running as a deamon as it were.

any help with this? is background tasks still the right folder? -- this is where the weather script resides and that works fine.


thanks!

Posted on
Sun Apr 24, 2016 9:53 am
matt (support) offline
Site Admin
User avatar
Posts: 19323
Joined: Jan 27, 2003
Location: Texas

Re: background task not loading/running?

Hey dtich,

Nothing should have changed. There isn't anything special about the background tasks folder – Indigo doesn't automatically launch or manage scripts in there . I'm not sure why it would stop working, but there are a couple of approached your setup might be taking. One would be to have a script that loops forever which is called on Indigo Server startup. It would loop with a sleep/delay. The other approach is to have a repeating schedule that calls a script periodically to force the updates. I'm not sure which approach you were taking (sounds like both which is what is confusing). You might be running into the "Indigo Server not running" AppleScript bug that some folks are still seeing (and that Apple still hasn't fixed).

The best way to do this now is to use the iTunes plugin. It'll be way more reliable than an AppleScript. But you'll have to update your Control Pages and other logic to inspect the iTunes device states versus variable values. Worth doing though and is the way of the future. :twisted:

Image

Posted on
Wed May 04, 2016 5:47 pm
dtich online
Posts: 628
Joined: Sep 24, 2005

Re: background task not loading/running?

thx matt!

ya, gonna hafta bite that bullet....

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest