AppleScript "Application isn't running" (-600) Errors

Posted on
Thu Feb 26, 2015 9:03 am
matt (support) offline
Site Admin
User avatar
Posts: 19302
Joined: Jan 27, 2003
Location: Texas

Re: AppleScript "Application isn't running" (-600) Errors

We have filed a bug report with Apple, and also have an open tech support incident for it.. Unfortunately, of all the bug reports we've filed with Apple very few are fixed – most have to be worked around and as of right now there is no known workaround (other than the steps we've already outlined). We'll continue to try to find a solution for this regardless.

Image

Posted on
Mon Mar 02, 2015 2:52 pm
gregjsmith offline
Posts: 946
Joined: Apr 01, 2003
Location: Rio Rancho, NM

Re: AppleScript "Application isn't running" (-600) Errors

Anyone using the latest betas and know if this is still a problem?

Posted on
Fri Mar 27, 2015 1:50 pm
mabrown offline
User avatar
Posts: 39
Joined: Dec 08, 2012

Re: AppleScript "Application isn't running" (-600) Errors

I'm running the latest 10.10.3 beta and am seeing this, so it appears it's not fixed yet.

Posted on
Sat Mar 28, 2015 5:16 am
mike_c offline
Posts: 22
Joined: Oct 03, 2013

Re: AppleScript "Application isn't running" (-600) Errors

I've a workaround / notification system for this.

I have a timer set to 11 minutes and an action on indigo server startup to start the timer. I have an alert set if the timer and expires.
I then have an AppleScript run every 10 minutes. If successful (ie no 600 error) it sets a "reset timer variable" to true.
A trigger then restarts the timer, sets to "reset timer variable" back to false and sets a "uh-oh variable" to true.

I have this status of the timer on admin dashboard to keep in check.

May be slightly overkill but at least I KNOW if there is an issue rather than finding the heating hasn't come on!!!!


Sent from my iPhone using Tapatalk

Posted on
Fri May 01, 2015 5:05 pm
GlennNZ offline
Posts: 621
Joined: Dec 07, 2014
Location: Central Coast, Australia

Re: AppleScript "Application isn't running" (-600) Errors

Hi

Has anyone found this appears worse on 6.1? -- So far up to 8th restart and 2nd reboot with the issue ongoing -- was working initally following update of indigo - but power outage restart triggered this issue again.
Am currently updating system to see if impacts (Yosemite) and then will try 9th, etc.etc

Edit:
Wow! That was hard - took 10-15 and then Combination of repair disk permissions, and launching indigo server from script editor got it going. (Probably coincidence) - phew!

Is there any apple report that us users can put weight behind to help? (because is getting a bit difficult)

Thanks
Glenn

Posted on
Tue Aug 11, 2015 1:53 am
davinci offline
Posts: 255
Joined: Feb 14, 2015

Re: AppleScript "Application isn't running" (-600) Errors

Yes it is horrible by now. I restarted Indigo Server several times before it worked. Did nothing else though...

You can just hope the Mac never restarts as it stops working then...

Posted on
Tue Aug 11, 2015 2:26 am
macpro offline
User avatar
Posts: 693
Joined: Dec 29, 2005
Location: Third byte on the right

Re: AppleScript "Application isn't running" (-600) Errors

I've made a small AppleScript to start the Indigo server.
Something like
Code: Select all
tell application "indigoserver"
log "start the server"
end tell


Whenever I notice the AppleScript issue, I stop the server and use this script to start it.
In the end it will start the server and then this bug doesn't bug me.

Until the server stops and then it starts all over again.

"I tawt I taw a puddy tat!" Tweety

Posted on
Tue Aug 11, 2015 4:16 am
DomoPat offline
User avatar
Posts: 192
Joined: Jul 17, 2010
Location: Toulouse, France

Re: AppleScript "Application isn't running" (-600) Errors

I might be the lucky one here, but AS works fine for me under 10.10.3 and 10.10.4. I was afraid of this problem when I upgraded from al old Mini running Lion to a newer one running Yosemite, and I had the problem after I transferred all data and configuration from the old machine using 'migration assistant'. At first everything worked well during a few days. But one day, after a restart, the problem appeared !

Then I did what is recommended in this forum and deleted every old copy of Indigo, made sure there was only one indigoserver, and since then I never had the "Application isn't running" error. I had probably a dozen restarts during the past three months, and I use a lot AS communication with Indigo because all the interface to and from the Weeder boards is done through this channel.

I know it is frustrating to see that it works for some other users, without being able to find a systematic cure. Let me know if I can help with something !

Patrick

Posted on
Fri Oct 09, 2015 4:05 am
davinci offline
Posts: 255
Joined: Feb 14, 2015

Re: AppleScript "Application isn't running" (-600) Errors

Issue is still present on El Capitan. And yes I only have one Indigo version installed.

Can't Indigo just check if it is running correctly and restart the server until it works?



Anyway I have a solution for the problem using AppleScript.

Running this script will restart the server until it works.
Just disable autostart of Indigo and start the script at startup instead.

It works for me but use at own risk. This solution doesn't catch manual restarts of the server or Indigo updates. You have to start the script manually in that case or just restart the Mac.

Code: Select all
run application "Indigo 6"
delay 10

set checkFailed to true

repeat while checkFailed is equal to true
   try
      tell application "IndigoServer"
         log "Startup check"
      end tell
      set checkFailed to false
      -- display dialog "IndigoServer running properly!"
      
   on error errStr number errorNumber
      if errorNumber is equal to -600 then
         set checkFailed to true
         
         -- display dialog "Restart IndigoServer!"
         try
            tell application "Indigo 6"
               quit
            end tell
         end try
         try
            tell application "System Events"
               set ProcessList to name of every process
               if "IndigoServer" is in ProcessList then
                  set ThePID to unix id of process "IndigoServer"
                  do shell script "kill -KILL " & ThePID
               end if
            end tell
         end try
         
         delay 5
         try
            run application "Indigo 6"
            delay 10
            tell application "Indigo 6"
               quit
            end tell
         end try
      end if
   end try
   
   delay 10
   
   try
      
      tell application "IndigoServer"
         log "Startup check"
      end tell
      set checkFailed to false
      -- display dialog "IndigoServer running properly!"
      
   on error errStr number errorNumber
      if errorNumber is equal to -600 then
         set checkFailed to true
         
      end if
   end try
end repeat
tell application "Indigo 6"
   quit
end tell

Posted on
Fri Oct 09, 2015 11:21 am
jay (support) offline
Site Admin
User avatar
Posts: 15683
Joined: Mar 19, 2008
Location: Austin, Texas

Re: AppleScript "Application isn't running" (-600) Errors

davinci wrote:
Can't Indigo just check if it is running correctly and restart the server until it works?


In a word - no. Indigo is running correctly and therefore can't tell if the problem is happening or not - there's something wrong with the OS, not Indigo. Restarting the server doesn't always solve the problem for everyone (works for some, not for others).

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Oct 09, 2015 11:29 am
davinci offline
Posts: 255
Joined: Feb 14, 2015

Re: AppleScript "Application isn't running" (-600) Errors

Interesting. However restarting works for me always but I have to restart it several times. This is fixed by the script.

I know it might not be Indigos fault but I don't care if it doesn't work.

Posted on
Fri Oct 09, 2015 12:37 pm
jay (support) offline
Site Admin
User avatar
Posts: 15683
Joined: Mar 19, 2008
Location: Austin, Texas

Re: AppleScript "Application isn't running" (-600) Errors

We've posted a couple of things that might help people work around the AppleScript problem.

2015/04/16 Update. Another workaround to try to get it working again, without hopefully the requirement to stop the Indigo Server or reboot your Mac, is to copy/paste the following command into the Terminal application:

Code: Select all
 sudo killall -9 appleeventsd

Note you will be prompted to enter your Mac OS user password for the command to execute. The command will force restart the Mac OS AppleEvents daemon (AppleEvents are the event model on which AppleScript is built). This likely isn't a permanent fix for the problem, but can hopefully get the Mac OS back into a state where it doesn't occur when it starts happening.


Also, make sure that you don't have multiple versions of Indigo installed (if, say, you upgrade from one version of Indigo to another). All Indigo installations are here:

Code: Select all
/Library/Application Support/Perceptive Automation/Indigo 7/
/Library/Application Support/Perceptive Automation/Indigo 6/
[etc]


So make sure that you only have the most recent one installed (delete the others). Note, that's the Library folder at the top level of your hard drive, not the one in your user folder.

If that doesn't work, or you want to try something else, then in the Python Scripting Tutorial, we've added a section called Executing AppleScript that explains how to call an AppleScript with any number of parameters and how to get the data returned from an AppleScript. This will work in any Python environment, including an embedded or external Python script called from Indigo.

And, going the other way, we've added a section to the RESTful API docs called AppleScript & the RESTful API that describes a way to use the RESTful API from AppleScript to control devices, get variable values, set variable values, etc. For the majority of users, it will do most of what you want. Lastly, we've provided details here on how to have AppleScript directly communicate with Indigo's python scripting engine.

We believe that between these two methods, much of what you need to integrate Indigo with AppleScriptable apps/sources are covered. It's not a complete replacement for AppleScript, but we think it does about 90% of what's needed in terms of integration.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Wed Nov 18, 2015 2:41 pm
McJohn offline
User avatar
Posts: 407
Joined: Dec 18, 2012
Location: The Netherlands

Re: AppleScript "Application isn't running" (-600) Errors

Could anyone tell me why this problem, ONLY exist with the Indigo Server app.
I installed a brand new Mac mini, with fresh new Yosemite 10.10.5. and a new download of the Indigo installer and copied my old Indigo database.
Everything is working fine except the :evil: external Indigo AppleScripts.
Every other AppleScript works perfectly; SecuritySpy, iMessage scripts, all working fine.
Except the Scripts which make a "call" to the Indigo Server app. It's running (I see it 1 x in the Activity Monitor) but all the ~20 scripts are not working anymore :cry:

So, with Maverick indeed a re-install of Indigo would help. But even this "solution" don't work anymore.
This is really an Indigo problem.

Kind regards,

John
Attachments
Schermafbeelding 2015-11-18 om 21.32.48.png
Schermafbeelding 2015-11-18 om 21.32.48.png (409.86 KiB) Viewed 4038 times

Posted on
Wed Nov 18, 2015 7:54 pm
kw123 offline
User avatar
Posts: 6572
Joined: May 12, 2013
Location: Dallas, TX

Re: AppleScript "Application isn't running" (-600) Errors

John,
replace applescript:
Code: Select all
tell application "IndigoServer-x"
   set Energy_dagconsumed to (value of variable "Electra_dag" as number)
   set value of variable "EnergyCostPerDay" to (Energy_dagconsumed * 0.23) as string
end tell
with python code :
Code: Select all
v1 = float(indigo.variables["Electra_dag"].value)*0.23
indigo.variable.updateValue("EnergyCostPerDay",str(v1))

put the above code into and action in an action group or action in a schedule:
Screen Shot 2015-11-18 at 7.51.21 PM.png
Screen Shot 2015-11-18 at 7.51.21 PM.png (45.94 KiB) Viewed 4008 times


But this will only work internally = inside indigo.

doing this from the outside use either restful urls or use the plugin SATI from applescript.
Karl

Posted on
Thu Nov 19, 2015 8:46 am
McJohn offline
User avatar
Posts: 407
Joined: Dec 18, 2012
Location: The Netherlands

Re: AppleScript "Application isn't running" (-600) Errors

Thanks Karl for the fast solution.
It is very unfortunate Indigo and external AppleScripts are not supported within Yosemite.
(the most basic programs within our environment!)
Every other program works perfect.

This problem, is now getting worse and worse, so guys from Indigo, what is your solution?

Kind regards,

John

Who is online

Users browsing this forum: No registered users and 1 guest

cron