z-wave interpreter errors

Posted on
Sat Jul 02, 2022 8:20 am
dduff617 offline
Posts: 610
Joined: Jul 05, 2006
Location: Massachusetts, USA

z-wave interpreter errors

i'm seeing some errors like this. sorry i'm not certain whether these occurred prior to 2.22.1.2.

Code: Select all
Z-Wave Interpreter Error        'list index out of range' in module 'zwave_interpreter.py', method 'interpret_zwave'
   Failing statement [line 208]: 'self.zw_interpretation[ZW_COMMAND] = int(self.zw_interpretation[ZW_COMMAND_BYTES][7 + class_displacement])'
   Z-Wave Interpreter Error        ''NoneType' object is not subscriptable' in module 'plugin.py', method 'process_zwave_interpretation'
   Failing statement [line 461]: 'if zw_interpretation[ZW_INTERPRETATION_ATTEMPTED]:'
   Z-Wave Interpreter Error        'list index out of range' in module 'zwave_interpreter.py', method 'interpret_zwave'
   Failing statement [line 208]: 'self.zw_interpretation[ZW_COMMAND] = int(self.zw_interpretation[ZW_COMMAND_BYTES][7 + class_displacement])'
   Z-Wave Interpreter Error        ''NoneType' object is not subscriptable' in module 'plugin.py', method 'process_zwave_interpretation'
   Failing statement [line 461]: 'if zw_interpretation[ZW_INTERPRETATION_ATTEMPTED]:'
   Z-Wave Interpreter Error        'list index out of range' in module 'zwave_interpreter.py', method 'interpret_zwave'
   Failing statement [line 208]: 'self.zw_interpretation[ZW_COMMAND] = int(self.zw_interpretation[ZW_COMMAND_BYTES][7 + class_displacement])'
   Z-Wave Interpreter Error        ''NoneType' object is not subscriptable' in module 'plugin.py', method 'process_zwave_interpretation'
   Failing statement [line 461]: 'if zw_interpretation[ZW_INTERPRETATION_ATTEMPTED]:'
   Z-Wave Interpreter Error        'list index out of range' in module 'zwave_interpreter.py', method 'interpret_zwave'
   Failing statement [line 208]: 'self.zw_interpretation[ZW_COMMAND] = int(self.zw_interpretation[ZW_COMMAND_BYTES][7 + class_displacement])'
   Z-Wave Interpreter Error        ''NoneType' object is not subscriptable' in module 'plugin.py', method 'process_zwave_interpretation'
   Failing statement [line 461]: 'if zw_interpretation[ZW_INTERPRETATION_ATTEMPTED]:'

Posted on
Sun Jul 03, 2022 4:06 am
autolog offline
Posts: 3748
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: z-wave interpreter errors

Thanks for the report. :)

Can you confirm what version of the Z-Wave Interpreter you are running?
The latest version in the Plugin Store is: 2022.0.0

I will look at the code and try and figure out what is happening. I suspect it is a plugin problem, as opposed to an Indigo problem?

Posted on
Mon Jul 04, 2022 1:29 pm
dduff617 offline
Posts: 610
Joined: Jul 05, 2006
Location: Massachusetts, USA

Re: z-wave interpreter errors

yeah - i think i wasn't understanding clearly when i posted - i thought this was an indigo issue (and maybe posted under Indigo Help » Supported Interfaces/Technologies » Z-Wave). perhaps matt or someone redirected my post to the proper place.

i confirm i am running plugin version 2022.0.0 of z-wave interpreter plugin.

Posted on
Mon Jul 04, 2022 1:33 pm
autolog offline
Posts: 3748
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: z-wave interpreter errors

Yes, I asked Matt to move it. :)

What Z-Wave devices / types are you interpreting?

Is the error just randomly occurring, now and then?

I have seen this before; I will try and pin down what is causing it and maybe add in more debugging code.

Posted on
Mon Jul 04, 2022 1:52 pm
dduff617 offline
Posts: 610
Joined: Jul 05, 2006
Location: Massachusetts, USA

Re: z-wave interpreter errors

the plugin is configured to watch three devices, all of them are thermostats.

perhaps not a coincidence: i notice that one of the three devices had a problem a few days ago which involved me having to z-wave exclude, and reset, and then z-wave include it (so it's the same indigo device, but the underlying z-wave node-ID changed).

i see 104 pairs of Z-wave Interpreter log lines in my past 45 days of logs. so i guess it's a "now and then thing" averaging only a couple of times per day.

i see none in the last two days - so it is possible be that when i reset that thermostat, it fixed the underlying issue causing the Z-wave Interpreter problem?

Posted on
Mon Jul 04, 2022 1:56 pm
autolog offline
Posts: 3748
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: z-wave interpreter errors

Seems like that might have been the trigger for the issue.

The plugin should handle it more gracefully, so I will look at improving the error handling.

Thanks for the feedback. :)

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest