not yet programmed z-wave messages in classes 66, 68, 69

Posted on
Thu Aug 12, 2021 10:50 am
dduff617 offline
Posts: 605
Joined: Jul 05, 2006
Location: Massachusetts, USA

not yet programmed z-wave messages in classes 66, 68, 69

The plugin should decode a lot (most?) of the common Z-Wave Command Classes. If a Z-Wave Command Class / Command can't be interpreted, the plugin will indicate such. In that case, if you would like it to be decoded, post the log output in this sub-forum and I will look to add the decoding in for it into the plugin.


here are some i was wondering about. These come from thermostats.
Code: Select all
  Z-Wave Interpreter Debug        2021-08-12 12:36:24.141 RCVD: '[ 01 09 00 04 00 6B 03 44 03 00 DD ]' from ' Thermostat 1RAD' [Node: 107]
                                   Logic not programmed for Z-Wave Command Class: '68 [0x44]'

  Z-Wave Interpreter Debug        2021-08-12 12:30:30.791 RCVD: '[ 01 09 00 04 00 6B 03 42 03 00 DB ]' from ' Thermostat 1RAD' [Node: 107]
                                   Logic not programmed for Z-Wave Command Class: '66 [0x42]'

   Z-Wave Interpreter Debug        2021-08-12 12:30:52.746 RCVD: '[ 01 09 00 04 00 6E 03 42 03 02 DC ]' from ' Thermostat 1FA ZWave' [Node: 110]
                                   Logic not programmed for Z-Wave Command Class: '66 [0x42]'

  Z-Wave Interpreter Debug        2021-08-12 12:36:07.464 SEND: 'OK', [ 01 09 00 13 6B 02 45 02 25 A5 4B ] (15ms) to ' Thermostat 1RAD' [Node: 107]
                                   Logic not programmed for Z-Wave Command Class: '69 [0x45]'

as background, I've been wondering for a while why I can't seem to get a z-wave thermostat to work the way i want it to - namely, where every state change of a sensor (temperature/humidity) is reported from the device to indigo and every state change of the equipment (fan on/off, heat or cool on/off, etc.) is also reported. i have one thermostat that seems to report hundreds of minuscule humidity changes but rarely if ever reports temperature changes. i have a thermostat that reports temperature and humidity but doesn't report when the system turns on/off. so i'm hoping the plugin will give me some leverage on getting this sorted.

Posted on
Thu Aug 12, 2021 11:33 am
autolog offline
Posts: 3732
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: not yet programmed z-wave messages in classes 66, 68, 69

I will investigate and add these interpretations to the plugin. :)

  • Command Class: '66 [0x42]: Thermostat Operating State
  • Command Class: '66 [0x44]: Thermostat Fan Mode
  • Command Class: '66 [0x45]: Thermostat Fan State

There are probably a few other associated Command Classes that I will investigate as well.

It will take a few days before I can schedule in time to look at it and as I can't test the resultant code changes myself, I will put a pre-release version up on Github for you to try. :)

Posted on
Fri Aug 13, 2021 7:25 am
autolog offline
Posts: 3732
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: not yet programmed z-wave messages in classes 66, 68, 69

I managed to find some time. :)

I have uploaded a pre-release version to Github for you to try: Support Additional Command Classes

Add support for:

  • Command Class: '66 [0x42]: Thermostat Operating State
  • Command Class: '66 [0x44]: Thermostat Fan Mode
  • Command Class: '66 [0x45]: Thermostat Fan State

Let me know how it goes as I haven't been able test the changes as I don't have a fan device.

If it works, please post the logging output. Thanks. :)

Posted on
Fri Aug 13, 2021 10:44 am
dduff617 offline
Posts: 605
Joined: Jul 05, 2006
Location: Massachusetts, USA

Re: not yet programmed z-wave messages in classes 66, 68, 69

ok i am trying out the new version (0.4.4).

i haven't analyzed carefully, but i appear to still be getting "not programmed" messages for some commands in class 66. also seeing some new errors from Z-wave Interpreter.
Aug 13, 2021 at 12:30:18
Stopping plugin Z-Wave Interpreter (pid 43936)
Z-Wave Interpreter Debug shutdown called
Stopped plugin Z-Wave Interpreter
Upgrading plugin Z-Wave Interpreter to newer version 0.4.4 (previous version moved to trash)
Loading plugin "Z-Wave Interpreter 0.4.4"
Starting plugin "Z-Wave Interpreter 0.4.4" (pid 26645)
Z-Wave Interpreter
============================================= Initialising Z-Wave Interpreter Plugin =============================================
Plugin Name: Z-Wave Interpreter
Plugin Version: 0.4.4
Plugin ID: com.autologplugin.indigoplugin.zwaveinterpreter
Indigo Version: 2021.1.1
Indigo License: ActiveSubscription
Indigo API Version: 2.5
Python Version: 2.7.16 (default, Mar 25 2021, 03:11:28) [GCC 4.2.1 Compatible Apple LLVM 11.0.3 (clang-1103.0.29.20) (-macos10.15-objc-
Mac OS Version: 10.15.7
==================================================================================================================================

Z-Wave Interpreter Indigo Event Log set to 'Debugging'
Z-Wave Interpreter Plugin Log set to 'No Z-Wave Logging'
Started plugin "Z-Wave Interpreter 0.4.4"

Aug 13, 2021 at 12:31:18
Z-Wave Interpreter Debug 2021-08-13 12:31:18.080 SEND: 'OK', [ 01 09 00 13 6B 02 40 02 25 4B A0 ] (10ms) to ' Thermostat 1RAD' [Node: 107]
Class: 'Thermostat Mode [v1]', Command: 'Get'

Z-Wave received " Thermostat 1RAD" mode is heat
Z-Wave Interpreter Debug 2021-08-13 12:31:18.207 RCVD: '[ 01 09 00 04 00 6B 03 40 03 01 D8 ]' from ' Thermostat 1RAD' [Node: 107]
Class: 'Thermostat Mode [v1]', Command: 'Report', Mode: 'Heat'

Z-Wave Interpreter Debug 2021-08-13 12:31:18.218 SEND: 'OK', [ 01 09 00 13 6B 02 44 02 25 4C A3 ] (10ms) to ' Thermostat 1RAD' [Node: 107]
Class: 'Thermostat Fan Mode [v1]', Command: 'Get'

Z-Wave received " Thermostat 1RAD" fan mode is auto
Z-Wave Interpreter Error Error detected in 'ZwaveThermostatFanMode' Class, '_interpret_report' method: Line 137 has error '30'
Z-Wave Interpreter Debug 2021-08-13 12:31:18.382 RCVD: '[ 01 09 00 04 00 6B 03 44 03 00 DD ]' from ' Thermostat 1RAD' [Node: 107]


Z-Wave Interpreter Debug 2021-08-13 12:31:18.400 SEND: 'OK', [ 01 09 00 13 6B 02 42 02 25 4D A4 ] (28ms) to ' Thermostat 1RAD' [Node: 107]
Logic not programmed for Z-Wave Command Class: '66 [0x42]'

Z-Wave Interpreter Debug 2021-08-13 12:31:18.646 RCVD: '[ 01 09 00 04 00 6B 03 42 03 00 DB ]' from ' Thermostat 1RAD' [Node: 107]
Logic not programmed for Z-Wave Command Class: '66 [0x42]'

Z-Wave Interpreter Debug 2021-08-13 12:31:18.654 SEND: 'OK', [ 01 09 00 13 6B 02 45 02 25 4E A0 ] (11ms) to ' Thermostat 1RAD' [Node: 107]
Class: 'Thermostat Fan State [v1]', Command: 'Get'

Z-Wave Interpreter Error Error detected in 'ZwaveThermostatFanState' Class, '_interpret_report' method: Line 100 has error '30'
Z-Wave Interpreter Debug 2021-08-13 12:31:18.801 RCVD: '[ 01 09 00 04 00 6B 03 45 03 00 DC ]' from ' Thermostat 1RAD' [Node: 107]


Z-Wave Interpreter Debug 2021-08-13 12:31:18.808 SEND: 'OK', [ 01 0B 00 13 6B 04 31 04 05 00 25 4F D2 ] (15ms) to ' Thermostat 1RAD' [Node: 107]
Class: 'Multilevel Sensor [v5]', Command: 'Get'

Z-Wave Interpreter Debug 2021-08-13 12:31:18.971 RCVD: '[ 01 0B 00 04 00 6B 05 31 05 05 01 28 86 ]' from ' Thermostat 1RAD' [Node: 107]
Class: 'Multilevel Sensor [v5]', Command: 'Report', Sensor: 'Humidity', Value: '40%'

Z-Wave Interpreter Debug 2021-08-13 12:31:18.990 SEND: 'OK', [ 01 09 00 13 6B 02 31 04 25 50 CC ] (19ms) to ' Thermostat 1RAD' [Node: 107]
Class: 'Multilevel Sensor [v5]', Command: 'Get'

Z-Wave Interpreter Debug 2021-08-13 12:31:19.066 RCVD: '[ 01 0B 00 04 00 6B 05 31 05 05 01 28 86 ]' from ' Thermostat 1RAD' [Node: 107]
Class: 'Multilevel Sensor [v5]', Command: 'Report', Sensor: 'Humidity', Value: '40%'

Z-Wave Interpreter Debug 2021-08-13 12:31:19.073 SEND: 'OK', [ 01 0A 00 13 6B 03 43 02 01 25 51 BA ] (9ms) to ' Thermostat 1RAD' [Node: 107]
Class: 'Thermostat Setpoint [v1]', Command: 'Get', Setpoint Type: 'Heating'

Z-Wave received " Thermostat 1RAD" heat setpoint is 69 °F
Z-Wave Interpreter Debug 2021-08-13 12:31:19.302 RCVD: '[ 01 0B 00 04 00 6B 05 43 03 01 09 45 93 ]' from ' Thermostat 1RAD' [Node: 107]
Class: 'Thermostat Setpoint [v1]', Command: 'Report', Setpoint Type: 'Heating', Value: '69º F'

Z-Wave Interpreter Debug 2021-08-13 12:31:19.310 SEND: 'OK', [ 01 0A 00 13 6B 03 43 02 02 25 52 BA ] (16ms) to ' Thermostat 1RAD' [Node: 107]
Class: 'Thermostat Setpoint [v1]', Command: 'Get', Setpoint Type: 'Cooling'

Z-Wave received " Thermostat 1RAD" cool setpoint is 76 °F
Z-Wave Interpreter Debug 2021-08-13 12:31:19.359 RCVD: '[ 01 0B 00 04 00 6B 05 43 03 02 09 4C 99 ]' from ' Thermostat 1RAD' [Node: 107]
Class: 'Thermostat Setpoint [v1]', Command: 'Report', Setpoint Type: 'Cooling', Value: '76º F'

Z-Wave received " Thermostat 1RAD" fan mode is auto
Z-Wave Interpreter Error Error detected in 'ZwaveThermostatFanMode' Class, '_interpret_report' method: Line 137 has error '30'
Z-Wave Interpreter Debug 2021-08-13 12:31:24.479 RCVD: '[ 01 09 00 04 00 6B 03 44 03 00 DD ]' from ' Thermostat 1RAD' [Node: 107]

Posted on
Fri Aug 13, 2021 11:52 am
autolog offline
Posts: 3732
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: not yet programmed z-wave messages in classes 66, 68, 69

Corrections made and new pre-release loaded up on Github: V 0.4.5 :)

Posted on
Mon Aug 23, 2021 10:45 am
dduff617 offline
Posts: 605
Joined: Jul 05, 2006
Location: Massachusetts, USA

Re: not yet programmed z-wave messages in classes 66, 68, 69

just installed 0.4.5

looks like the "logic not programmed" reports are gone, however i'm still seeing similar errors as before in _interpret_report method.
Code: Select all
   Z-Wave Interpreter Debug        2021-08-23 12:42:45.664 RCVD: '[ 01 09 00 04 00 6B 03 44 03 00 DD ]' from ' Thermostat 1RAD' [Node: 107]
   Z-Wave Interpreter Error        Error detected in 'ZwaveThermostatFanState' Class, '_interpret_report' method: Line 100 has error '30'
   Z-Wave Interpreter Debug        2021-08-23 12:42:46.252 RCVD: '[ 01 09 00 04 00 6B 03 45 03 00 DC ]' from ' Thermostat 1RAD' [Node: 107]

Posted on
Mon Aug 23, 2021 11:00 am
autolog offline
Posts: 3732
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: not yet programmed z-wave messages in classes 66, 68, 69

Correction made and new pre-release loaded up on Github: Version 0.4.6 :)

Posted on
Mon Aug 23, 2021 11:14 am
dduff617 offline
Posts: 605
Joined: Jul 05, 2006
Location: Massachusetts, USA

Re: not yet programmed z-wave messages in classes 66, 68, 69

previously reported issues seem to be cleared up with 0.4.6.

thanks again for the plugin and the fixes.

Posted on
Mon Aug 23, 2021 11:25 am
autolog offline
Posts: 3732
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: not yet programmed z-wave messages in classes 66, 68, 69

dduff617 wrote:
previously reported issues seem to be cleared up with 0.4.6.

thanks again for the plugin and the fixes.

Thanks for the update: Now released to the Indigo Plugin Store. :)

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest