Email+ Error after Upgrading to 2021.1

Posted on
Sun Jul 25, 2021 12:14 pm
Betacruxis offline
Posts: 41
Joined: Apr 03, 2010

Email+ Error after Upgrading to 2021.1

After upgrading from 7.5 to 2021.1, Email+ created a "Email+ SMTP Server" device and its configuration seems to be correct.
But when a trigger tries to send an email, I get the following error message from the plugin:

Trigger Remoto Mac Bat eMail
Email+ sending email 'Batería Baja' to 'xxxx@xxxx.com' using Email+ SMTP Server
Email+ Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 345, in sendEmailAction
File "/Library/Application Support/Perceptive Automation/Indigo 2021.1/Plugins/Email+.indigoPlugin/Contents/Server Plugin/SMTPServer.py", line 66, in poll
File "/Library/Application Support/Perceptive Automation/Indigo 2021.1/Plugins/Email+.indigoPlugin/Contents/Server Plugin/SMTPServer.py", line 130, in smtpSend
UnicodeEncodeError: 'ascii' codec can't encode character u'\xed' in position 5: ordinal not in range(128)


Any idea what is it about?
Thanks.

Posted on
Sun Jul 25, 2021 12:42 pm
FlyingDiver offline
User avatar
Posts: 5490
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Email+ Error after Upgrading to 2021.1

Looks like a bug in the plugin to me. Try removing the í from the subject and see if it works.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Sun Jul 25, 2021 12:47 pm
matt (support) offline
Site Admin
User avatar
Posts: 20699
Joined: Jan 27, 2003
Location: Texas

Re: Email+ Error after Upgrading to 2021.1

Joe's suggestion should get it working, and we'll get the underlying bug fixed in the next release.

Image

Posted on
Sun Jul 25, 2021 2:55 pm
Bildhauer offline
Posts: 89
Joined: Sep 30, 2019
Location: 22113 Oststeinbek (near Hamburg), Germany

Re: Email+ Error after Upgrading to 2021.1

I see:

Email+ Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 345, in sendEmailAction
File "/Library/Application Support/Perceptive Automation/Indigo 2021.1/Plugins/Email+.indigoPlugin/Contents/Server Plugin/SMTPServer.py", line 66, in poll
File "/Library/Application Support/Perceptive Automation/Indigo 2021.1/Plugins/Email+.indigoPlugin/Contents/Server Plugin/SMTPServer.py", line 130, in smtpSend
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe4' in position 1: ordinal not in range(128)

Posted on
Sun Jul 25, 2021 2:59 pm
FlyingDiver offline
User avatar
Posts: 5490
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Email+ Error after Upgrading to 2021.1

Do you now have an ä in the email subject? You need to remove any non-ASCII characters.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Jul 27, 2021 2:40 pm
Betacruxis offline
Posts: 41
Joined: Apr 03, 2010

Re: Email+ Error after Upgrading to 2021.1

Correct!
Removing the "í" solved the issue.

Thanks guys!

Posted on
Thu Aug 05, 2021 2:17 am
matt (support) offline
Site Admin
User avatar
Posts: 20699
Joined: Jan 27, 2003
Location: Texas

Re: Email+ Error after Upgrading to 2021.1

Indigo 2021.1.1 is now available and fixes this bug.

Image

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest