Online Sensor plugin

Posted on
Mon Jun 08, 2020 3:17 pm
dkillmer offline
Posts: 39
Joined: Feb 23, 2015

Re: Online Sensor plugin

I decided to bag the plugin and write a simple script.

import speedtest

st = speedtest.Speedtest()

indigo.variable.updateValue("DownloadSpeed", str("{:.2f}".format(st.download()/1000000)))
indigo.variable.updateValue("UploadSpeed", str("{:.2f}".format(st.upload()/1000000)))

Posted on
Tue Jun 09, 2020 12:59 pm
kmarkley offline
Posts: 184
Joined: Nov 15, 2016

Re: Online Sensor plugin

When the plugin was built, speedtest.py automatically tried to share the results and threw an exception if unable to. It looks like the current version makes this optional. I'll need to make a few changes to the plugin to work with the new library, but should be able to do so later this week.

Posted on
Mon Aug 03, 2020 2:41 pm
jstewart30 offline
Posts: 18
Joined: Jul 03, 2014

Re: Online Sensor plugin

kmarkley wrote:
When the plugin was built, speedtest.py automatically tried to share the results and threw an exception if unable to. It looks like the current version makes this optional. I'll need to make a few changes to the plugin to work with the new library, but should be able to do so later this week.


I'm having the same error about not being able to submit results to speedtest. Running 10.13 if that helps at all. Just wanted to see if you are able to implement the above change and/or if there's any other insight as to why the error is occurring. Thanks in advance!

Posted on
Thu Apr 08, 2021 3:53 am
racarter offline
User avatar
Posts: 352
Joined: Jun 18, 2016
Location: North Yorkshire, UK

Re: Online Sensor plugin

Hi

The last couple of days I've been getting errors in the event log. I switched on debug messages and I'm getting this:

8 Apr 2021 at 10:38:17
Online Sensor Debug updating states on device "Internet Connection":
Online Sensor Debug onOffState: True

8 Apr 2021 at 10:39:54
Online Sensor Debug performSpeedtest: Internet Speed
Online Sensor Error invalid literal for int() with base 10: ''
Online Sensor Debug performSpeedtest: 0.226945161819 seconds
Online Sensor Debug updating states on device "Internet Speed":
Online Sensor Debug onOffState: False

I'm guessing Speedtest is returning something bad.

I've found a solution:

https://github.com/sivel/speedtest-cli/pull/769

Posted on
Fri Apr 09, 2021 6:46 pm
ryanbuckner offline
Posts: 761
Joined: Oct 08, 2011

Re: Online Sensor plugin

Getting the following error every few minutes:

Code: Select all
  Online Sensor Error             invalid literal for int() with base 10: ''

Posted on
Sat Apr 10, 2021 11:59 am
kmarkley offline
Posts: 184
Joined: Nov 15, 2016

Re: Online Sensor plugin

New version 0.0.15 on the plugin store updates the speedtest.py library which should fix this issue. Also (finally) makes sharing speedtest results optional.

Posted on
Sun Apr 11, 2021 3:36 pm
ryanbuckner offline
Posts: 761
Joined: Oct 08, 2011

Re: Online Sensor plugin

kmarkley wrote:
New version 0.0.15 on the plugin store updates the speedtest.py library which should fix this issue. Also (finally) makes sharing speedtest results optional.


Thanks! Just installed. I'll let you know what I see

Posted on
Fri Mar 18, 2022 12:07 pm
Liptrot offline
Posts: 4
Joined: Feb 07, 2017

Re: Online Sensor plugin

The Online Sensor plug-in Speedtest device has started giving HTTP 503 errors .

Is there any way to work around this ?


Thanks !!!!

Posted on
Sat May 14, 2022 8:37 pm
DVDDave offline
Posts: 419
Joined: Feb 26, 2006
Location: San Jose, CA

Re: Online Sensor plugin

Liptrot wrote:
The Online Sensor plug-in Speedtest device has started giving HTTP 503 errors .

Is there any way to work around this ?


Thanks !!!!

Same problem here

Posted on
Fri Jun 03, 2022 5:37 pm
TimH offline
Posts: 6
Joined: Mar 06, 2008
Location: Los Gatos, CA

Re: Online Sensor plugin

I just starting using this plugin - some nice features, but `i too am seeing the 503 errors. I did some debugging and it appears the plug-in is failing when it attempts to share the results with speedtest.net. (although I have share unchecked? - likely some left over code) It looks like when its updating its status in plugin.py (when the tests are complete) at this line : {'key':'share_link', 'value':'r.share()' }, Its getting the 503 server busy error (sometimes). As a temp fix, I updated that line to : {'key':'share_link', 'value':'No Thanks' },. And it appears to be working well now. I hope this helps until the author can take a look and make a permanent fix. And, thanks again to the author for a handy plugin!

Posted on
Fri Jun 10, 2022 8:16 am
kmarkley offline
Posts: 184
Joined: Nov 15, 2016

Re: Online Sensor plugin

I searched my logs and found a couple of these errors, but I'm not seeing them on a regular basis. The plugin needs updating to python 3 and the newest version of the speedtest library. Hopefully that will address this as well. Unfortunately it will probably be a month or two before I can get to it.

Posted on
Wed Aug 10, 2022 3:32 pm
farberm offline
Posts: 341
Joined: Feb 24, 2008

Re: Online Sensor plugin

Happy to wait, I use this plugin all the time.

Posted on
Wed Oct 05, 2022 7:15 pm
Dual offline
Posts: 238
Joined: Feb 05, 2019

Re: Online Sensor plugin

I use this plugin to test if my internet is working by pinging a variety of addresses. If they all fail then I have Indigo restart my modem and router. Will this plugin be updated to work with future versions of Indigo?

Who is online

Users browsing this forum: No registered users and 1 guest