Page 2 of 2

Re: Unable to login

Posted: Mon Jan 13, 2020 7:16 am
by ryanbuckner
Same error:

Code: Select all

Jan 13, 2020 at 8:15:32 AM
   Stopping plugin Ring (pid 6890)
   Stopped plugin Ring
   Upgrading plugin Ring to newer version 1.7.5 (previous version moved to trash)
   Loading plugin "Ring 1.7.5"
   Starting plugin "Ring 1.7.5" (pid 11381)
   Started plugin "Ring 1.7.5"
   Ring Error                      exception in deviceStartComm(Front Doorbell): year=1899 is before 1900; the datetime strftime() methods require year >= 1900
   Ring                            Attempting to connect to Ring.com API and login as ryanbuckner@gmail.com
   Ring                            Connection to Ring.com API successful

Re: Unable to login

Posted: Mon Jan 13, 2020 7:25 pm
by ZachBenz
ryanbuckner wrote:Same error:


Thanks for testing! Looks like I will have to trap this error a different way. This is what I get for using 1900 as my default initialization date.

Re: Unable to login

Posted: Mon Jan 13, 2020 7:42 pm
by ZachBenz
ryanbuckner wrote:Same error:


Just pushed out 1.7.6, which *hopefully* is the fix.

Re: Unable to login

Posted: Tue Jan 14, 2020 7:21 am
by ryanbuckner
ZachBenz wrote:
ryanbuckner wrote:Same error:


Just pushed out 1.7.6, which *hopefully* is the fix.


No errors!!

Code: Select all

Jan 14, 2020 at 8:17:32 AM
   Stopping plugin Ring (pid 11381)
   Stopped plugin Ring
   Upgrading plugin Ring to newer version 1.7.6 (previous version moved to trash)
   Loading plugin "Ring 1.7.6"
   Starting plugin "Ring 1.7.6" (pid 23389)
   Started plugin "Ring 1.7.6"
   Ring                            Attempting to connect to Ring.com API and login as ryanbuckner@gmail.com
   Ring                            Connection to Ring.com API successful

Re: Unable to login

Posted: Tue Jan 14, 2020 7:29 pm
by ZachBenz
ryanbuckner wrote:No errors!!


Excellent!

Re: Unable to login

Posted: Wed Mar 04, 2020 9:03 am
by auto_man
I'm a first time user of the RingForIndigo plugin. Yesterday I loaded the plugin for the first time from the Plugin Store, version 1.7.6. All seemed to go well with the load. After doing the configuration and clicking on the Save button, I'm getting the "Incomplete login credentials" messages in the Event Log as shown below. At the same time, email messages are coming in to my Mail account from Ring, with a verification code needed to log in. I am able to log in to my Ring account on Safari, on the same Indigo Server, using my User Name, Password, and the emailed Verification code. I am not using Two-factor authentication. I'm getting multiple email messages from Ring, each time with a new Verification Code.

Seems like most on the forum have good luck getting logged in and the Plugin working, so since I'm a first time user of this plugin, I'm thinking I'm missing something. Any ideas about what I'm dong wrong or don't have setup properly?

Enabling plugin "Ring 1.7.6"
Starting plugin "Ring 1.7.6" (pid 658)
Started plugin "Ring 1.7.6"
Ring Incomplete login credentials provided - please visit the Ring plugin's 'Configure...' menu

Ring Attempting to connect to Ring.com API and login as wilkinsjr@me.com
Ring Incomplete login credentials provided - please visit the Ring plugin's 'Configure...' menu
Ring Incomplete login credentials provided - please visit the Ring plugin's 'Configure...' menu
Ring Incomplete login credentials provided - please visit the Ring plugin's 'Configure...' menu