Page 1 of 1

Hue dimmer switch - Shims device

PostPosted: Fri Jun 12, 2020 8:06 am
by siclark
Hi Joe,

I am wondering if you could help with me debugging my Shims device. I have set it up just as I did the Aqara buttons and I see it updating on the MQTT connector device, and the MQTT topic component match trigger fires when I press a button, so it all appears to be working.

From the connector device, it shows the payload as
Code: Select all
{"battery":100,"linkquality":47,"counter":1,"brightness":255,"action":"on-press","duration":0,"elapsed":4126935,"last_seen":"2020-06-12T13:42:01.057Z"}


Screenshot 2020-06-12 at 15.08.24.png
Screenshot 2020-06-12 at 15.08.24.png (90.15 KiB) Viewed 93 times

Screenshot 2020-06-12 at 15.03.46.png
Screenshot 2020-06-12 at 15.03.46.png (25.39 KiB) Viewed 96 times


Above is the device I have created, and it updates as I press the buttons, so all good there.

My trouble is that this trigger never fires.

Screenshot 2020-06-12 at 15.05.33.png
Screenshot 2020-06-12 at 15.05.33.png (70.54 KiB) Viewed 96 times


I have been round in so many circles and recreated everything, but same thing.

Re: Hue dimmer switch - Shims device

PostPosted: Fri Jun 12, 2020 8:10 am
by FlyingDiver
The state is 'action'. The value of that state is 'on-press'. So change that field to 'action' and then put in a condition for 'action' == 'on-press'.

That field is there to avoid errors when a state isn't present at all.

Re: Hue dimmer switch - Shims device

PostPosted: Fri Jun 12, 2020 8:16 am
by siclark
I have been back to my working triggers on other devices so many times, but never spotted that. Thank you. The Hue dimmer is also working now.

Still got a few holes in my zigbee mesh, but getting some Ikea mains sockets to patch those.