Error

Posted on
Thu Dec 20, 2018 4:47 am
Coolcaper offline
Posts: 298
Joined: Aug 30, 2013
Location: Australia

Error

Hi,

Thanks for the plugin, however after installing, I get the following error:

20 Dec 2018 at 18:40:28
Installing and enabling plugin Sylvania Lightify v1.0.1
Loading plugin "Sylvania Lightify 1.0.1"
Starting plugin "Sylvania Lightify 1.0.1" (pid 34879)
Sylvania Lightify ..lightifyHubIpAddr=127.0.0.1
LightifyDirect ...Logging lightifydirect
Sylvania Lightify Error Error in plugin execution InitializeMain:

Traceback (most recent call last):
File "<string>", line 1, in <module>
File "plugin.py", line 46, in __init__
File "/Library/Application Support/Perceptive Automation/Indigo 7.2/Plugins/SylvaniaLightify.indigoPlugin/Contents/Server Plugin/lightifydirect.py", line 213, in __init__
File "/Library/Application Support/Perceptive Automation/Indigo 7.2/Plugins/SylvaniaLightify.indigoPlugin/Contents/Server Plugin/lightifydirect.py", line 218, in connect
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 228, in meth
error: (61, 'Connection refused')

Stopping plugin "Sylvania Lightify 1.0.1" (pid 34879)
Stopped plugin "Sylvania Lightify 1.0.1"


Re-enabling it produces the same result.

Posted on
Thu Dec 20, 2018 5:21 am
CliveS offline
Posts: 584
Joined: Jan 10, 2016
Location: Medomsley, County Durham, UK

Re: Error

Sylvania Lightify ..lightifyHubIpAddr=127.0.0.1 <<<<<<<<< That does not look right, should be the IP of the Sylvania hub and no way to set it up

Edit,
You could replace the 127.0.0.1 in line 44 of the plugin.py to match your real ip of the hub.

CliveS

Indigo 2021.1.1 : MacOS Catalina 10.15.1 : Mac mini Server (Mid 2011) : 2 GHz Core i7. : 8 GB. : 2 x 256GB Samsung EVO SSD
----------------------------------------------------------------------------------
The best way to get the right answer on the Internet is not to ask a question, it's to post the wrong answer

Posted on
Thu Dec 20, 2018 8:25 am
rbdubz3 offline
User avatar
Posts: 190
Joined: Sep 18, 2016
Location: San Diego, CA

Re: Error

CliveS wrote:
Sylvania Lightify ..lightifyHubIpAddr=127.0.0.1 <<<<<<<<< That does not look right, should be the IP of the Sylvania hub and no way to set it up


The Plugin Configuration will allow you to set the Hub IP address.. See Install/Setup notes here - https://github.com/rbdubz3/sylvania-lig ... tall-setup

I automate because I am lazy :D

Posted on
Thu Dec 20, 2018 8:29 am
rbdubz3 offline
User avatar
Posts: 190
Joined: Sep 18, 2016
Location: San Diego, CA

Re: Error

In hindsight - loopback ip 127.0.0.1 is a bad default - I'll change this and also improve the improve the error messaging for initial connection to the hub

I automate because I am lazy :D

Posted on
Thu Dec 20, 2018 9:40 am
rbdubz3 offline
User avatar
Posts: 190
Joined: Sep 18, 2016
Location: San Diego, CA

Re: Error

CliveS - apologies for the bad startup there. Sometimes you focus on certain pieces of the code that you overlook some glaring stuff :(

Please use V1.0.2.. It has improvements to the startup initialization and error handling/messaging.. The new version will allow you to properly set the Lightify Hub IP address.

I automate because I am lazy :D

Posted on
Fri Dec 21, 2018 2:13 am
Coolcaper offline
Posts: 298
Joined: Aug 30, 2013
Location: Australia

Re: Error

Working now. Thanks


Sent from my iPhone using Tapatalk

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest