Move 'GL-C-007' from kLightStripsDeviceIDs to kHueBulbDevice

Posted on
Wed Mar 25, 2020 10:09 am
Hackencrash offline
User avatar
Posts: 203
Joined: Dec 16, 2015
Location: UK

Move 'GL-C-007' from kLightStripsDeviceIDs to kHueBulbDevice

I notice bulb type 'GL-C-007' is currently defined as kLightStripsDeviceIDs in supportedDevices.py in this plugin. However, it did not allow me to control the colour of the bulb with the current config, only brightness and on/off.

I therefore tried moving 'GL-C-007' to kHueBulbDevice and this worked OK with the colour in Indigo. Incidently, I also tried it under kLivingColorsDeviceIDs which also enabled the colour option.

:o Interestingly, if I recreate the device in Indigo, I don't see the colour option, but if I then move 'GL-C-007' back to kLightStripsDeviceIDs (or kLivingColorsDeviceIDs for that matter) I do see the colour option, so we have a bug.

It appears that on initial device creation in Indigo, whatever 'GL-C-007' is defined as in supportedDevices.py (confirmed supportedDevices.py file saved and Hue Lights plugin restarted prior to device creation), no colour option is available for that device in Indigo. This doesn't change following a subsequent plugin restart. However, if then I move 'GL-C-007' to another colour bulb type, save supportedDevices.py and restart the Hue Lights plugin, I get the colour option appear. This is the only way I have managed to get the colour option to work in Indigo for this device type.

Please can you perhaps update the plugin so I don't have to do this trick in the supportedDevices.py file to get things working?

In the Hue iPhone app, both Colour (color) and hue controls are available, although the hue control acts a bit odd perhaps due to the lack of a W wire connected on the controller shown below:

GLEDOPTO.jpg
GLEDOPTO.jpg (505.62 KiB) Viewed 392 times

Posted on
Wed Mar 25, 2020 11:56 pm
nsheldon offline
Posts: 2199
Joined: Aug 09, 2010
Location: CA

Re: Move 'GL-C-007' from kLightStripsDeviceIDs to kHueBulbDe

Hi.

Thanks for the bug report and information. That certainly sounds like odd unwanted behavior. With version 1.7.26 of the Hue Lights plugin, I changed all of the code associated with Light Strips models such that the plugin should automatically detect the capabilities of the light strip device and update the device properties accordingly. Unfortunately, I only have the original Hue LightStrip with which to test this functionality. I'd like to get the plugin working correctly with your GLEDOPTO LED controller without having to move it to a different model grouping (which is confusingly inconsistent, especially for new plugin users). Could you please make sure you're using version 1.7.27 of the plugin (the current latest version) then try deleting the device, enable debug logging (Plugins -> Hue Lights -> Toggle Debug Logging), and re-adding the device? Then provide the debug logs from the point where debug logging was enable to the point where the device was added but lacked the correct color controls. I know deleting a device is a significant inconvenience due to other Indigo dependencies on the device, so I appreciate the help. If deleting the device is too disruptive, maybe you could create a whole new Indigo database (File -> New Database) and add the GLEDOPTO controller in that new database. (Then switch back to your original home database when done).

Posted on
Thu Mar 26, 2020 3:42 pm
Hackencrash offline
User avatar
Posts: 203
Joined: Dec 16, 2015
Location: UK

Re: Move 'GL-C-007' from kLightStripsDeviceIDs to kHueBulbDe

LightAddDebug.txt
Please rename from .txt to .zip (which is actually a compressed .rtf)
(19.45 KiB) Downloaded 7 times

Please rename from .txt to .zip (which is actually a compressed .rtf)

Please find attached debug info as requested

Posted on
Thu Mar 26, 2020 4:19 pm
Hackencrash offline
User avatar
Posts: 203
Joined: Dec 16, 2015
Location: UK

Re: Move 'GL-C-007' from kLightStripsDeviceIDs to kHueBulbDe

Forgot to mention, I'm on version 1.7.27 (current) of the Plugin.

Posted on
Thu Mar 26, 2020 6:29 pm
nsheldon offline
Posts: 2199
Joined: Aug 09, 2010
Location: CA

Re: Move 'GL-C-007' from kLightStripsDeviceIDs to kHueBulbDe

Thank you. I'll look through those logs and work on fixing that bug.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest