Ecobee Authentication issues with Indigo 7.4

Posted on
Mon Oct 07, 2019 12:18 pm
7rdr7 offline
Posts: 39
Joined: Aug 16, 2017

Ecobee Authentication issues with Indigo 7.4

Anyone experiencing any Ecobee authentication issues with Indigo 7.4. After upgrading, it began to fail authentications. I re-authenticated twice, still the same problem. The plugin authentication window confirms a successful authentication, but the errors continue.

Oct 7, 2019 at 2:06:21 PM
Indigo Cocoa client authenticated (192.168.1.10)
Enabling plugin "Ecobee 2 2.2.0"
Starting plugin "Ecobee 2 2.2.0" (pid 29061)
Started plugin "Ecobee 2 2.2.0"
Ecobee 2 Starting Ecobee
Ecobee 2 Ecobee Account (1561638859): Starting EcobeeAccount Device 1561638859
Ecobee 2 Error Ecobee Account (1561638859): Authentication lost, please re-authenticate.'
Ecobee 2 Kitchen Occupancy: Starting OccupancySensor Device 1577145367
Ecobee 2 Kitchen Thermostat: Starting EcobeeThermostat Device 702521190
Ecobee 2 Media Room Occupancy: Starting OccupancySensor Device 352480444
Ecobee 2 Media Room Pillar (LSC3): Starting RemoteSensor Device 1482903299
Ecobee 2 Media Room Thermostat: Starting EcobeeThermostat Device 911299020
Ecobee 2 Sunroom Sensor (X7FP): Starting RemoteSensor Device 938326233
Ecobee 2 not authenticated to Ecobee servers yet; not initializing state of device 311003735841
Ecobee 2 not authenticated to Ecobee servers yet; not initializing state of device 311080879621
Ecobee 2 not authenticated to Ecobee servers yet; not initializing state of device X7FP
Ecobee 2 not authenticated to Ecobee servers yet; not initializing state of device LSC3
Z-Wave received "Outdoor Probe" sensor update to 25.6 °C
Z-Wave received "Pool Probe" sensor update to 25.1 °C
Z-Wave received "Floor Drain" power load to 0.4 W
Ecobee 2 Error Error in plugin execution UiAction:

Oct 7, 2019 at 2:07:26 PM
Ecobee 2 Error Token Request failed, response = '{
"error": "authorization_pending",
"error_description": "Waiting for user to authorize application.",
"error_uri": "https://tools.ietf.org/html/rfc6749#section-5.2"
}'
Ecobee 2 Error Token Request failed, response = '{
"error": "authorization_pending",
"error_description": "Waiting for user to authorize application.",
"error_uri": "https://tools.ietf.org/html/rfc6749#section-5.2"
}'

Oct 7, 2019 at 2:09:04 PM
Z-Wave received "Main Pump" energy total to 1156.394 kWh
Trigger Control Page Pump Power Cumulative

Oct 7, 2019 at 2:11:32 PM
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Z-Wave received "Outdoor Probe" sensor update to 25.5 °C
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Z-Wave received "Pool Probe" sensor update to 25.1 °C
Z-Wave received "Floor Drain" power load to 0.1 W
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh
Ecobee 2 Error Ecobee account 1561638859 not authenticated, skipping refresh

Posted on
Mon Oct 07, 2019 12:30 pm
FlyingDiver offline
Posts: 3464
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Ecobee Authentication issues with Indigo 7.4

That's definitely telling you to redo the authentication. Not sure how it got lost. My install did not have that problem.

Just go into the config dialog for the Ecobee Account device and redo the authentication process.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Oct 08, 2019 11:40 am
Hap offline
Posts: 12
Joined: Jul 28, 2013

Re: Ecobee Authentication issues with Indigo 7.4

I had the same issue, reauthenticated and then got this:

Code: Select all
   Ecobee 2 Error                  Error in plugin execution UiClosed3:
Traceback (most recent call last):
  File "plugin.py", line 414, in closedDeviceFactoryUi
UnboundLocalError: local variable 'newdev' referenced before assignment


and this...
Code: Select all
 Ecobee 2 Error                  Error in plugin execution GetUiDynamicList:
Traceback (most recent call last):
  File "plugin.py", line 248, in get_device_list
UnboundLocalError: local variable 'available_devices' referenced before assignment

Posted on
Tue Oct 08, 2019 11:46 am
FlyingDiver offline
Posts: 3464
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Ecobee Authentication issues with Indigo 7.4

OK, I'm going to have to see if I can figure out a way to reproduce this. I'm not seeing anything like that.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Oct 08, 2019 12:29 pm
FlyingDiver offline
Posts: 3464
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Ecobee Authentication issues with Indigo 7.4

I cannot reproduction this issue. I went to the Ecobee site, logged in, then removed the Indigo 'app' from the account. Then I restarted the plugin and got the same errors:

Code: Select all
   Ecobee 2                        Ecobee Account: Starting EcobeeAccount Device 363954845
   Ecobee 2 Error                  Ecobee Account: Authentication lost, please re-authenticate.'
   Ecobee 2                        Ecobee Master Suite: Starting EcobeeThermostat Device 860569872
   Ecobee 2                        Ecobee Master Suite Occupancy: Starting OccupancySensor Device 357830907
   Ecobee 2                        Ecobee Master Suite Remote - Master Bedroom: Starting RemoteSensor Device 686322743
   Ecobee 2                        Ecobee Upstairs: Starting EcobeeThermostat Device 253943175
   Ecobee 2                        Ecobee Upstairs Occupancy: Starting OccupancySensor Device 1590516520
   Ecobee 2                        Ecobee Upstairs Remote - Bonus Room: Starting RemoteSensor Device 303466546
   Ecobee 2                        not authenticated to Ecobee servers yet; not initializing state of device 313892758064
   Ecobee 2                        not authenticated to Ecobee servers yet; not initializing state of device 311018773951


Then I went through the normal authentication process. And then I restarted the plugin again. No errors.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Oct 08, 2019 3:29 pm
7rdr7 offline
Posts: 39
Joined: Aug 16, 2017

Re: Ecobee Authentication issues with Indigo 7.4

I finally got it working after disabling/enabling the plugin, deleting/ adding the app on the Ecobee site, and authenticating. It took a few cycles, but it's finally working now.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest