TRV Controller Discussion Thread

Posted on
Mon Mar 04, 2019 8:00 am
Busta999 offline
User avatar
Posts: 663
Joined: Mar 30, 2016
Location: Wales UK

Re: TRV Controller Discussion Thread

@autolog

Any reason for the discrepancies between front and read Spirit TRVs when they are running form the same settings and same external Temp Sensor?

IMG_0445.PNG
IMG_0445.PNG (502.18 KiB) Viewed 477 times

TRV - Lounge Front.jpeg
TRV - Lounge Front.jpeg (159.83 KiB) Viewed 477 times
TRV - Lounge Rear.jpeg
TRV - Lounge Rear.jpeg (158.17 KiB) Viewed 477 times


Lounge Front Batteries dropped from 15% - 0% at midnight last night.

Disregard Battery level in Lounge Front - put new batteries in this morning - just not reflected yet.

Not an issue - just curious as to differences.

Front is on fw .15 and Rear is on .16 - that may be the difference ....?

A curiosity rather than an issue.

Posted on
Mon Mar 04, 2019 8:21 am
autolog offline
Posts: 3167
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: TRV Controller Discussion Thread

Busta999 wrote:
... @autolog any other recommended changes/config?

You can make sure that Status polling is turned off on the actual Indigo Spirit device as the plugin will do the polling. :)

I will be interested to see how you get on with those settings. :)

Posted on
Mon Mar 04, 2019 8:22 am
Busta999 offline
User avatar
Posts: 663
Joined: Mar 30, 2016
Location: Wales UK

Re: TRV Controller Discussion Thread

It appears something odd was happening with the remote Temp Sensor or more precisely the TRV's reading goof the temp.

Both Lounge Front and Rear use the Temp: Lounge (CalibratedZW) Temp sensor a Z Wave Multi Sensor 6.

One TRV was showing the external Temp Sensor as 20.0 and. the other as 20.9 - both reading the same sensor and getting different readings even though they were reading within 4 seconds of each other.

I set the incorrect one to use a different sensor - saved it, then set it back to the correct one and it refreshed with the correct reading.

I'll keep a closer eye on both radiators and see if the discrepancy occurs again.

Posted on
Mon Mar 04, 2019 8:32 am
autolog offline
Posts: 3167
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: TRV Controller Discussion Thread

Busta999 wrote:
.... Any reason for the discrepancies between front and read Spirit TRVs when they are running form the same settings and same external Temp Sensor? ....
.... A curiosity rather than an issue.

There is a difference in that the TRV temperatures are not the same between the rear and the front Spirits.

The remote stat setting is around the ambient and the different firmware could be responding slightly differently? :)

As an aside: Have you investigated the CSV creation that the TRV Controller plugin can do for you. It is effectively done on demand (via an action, normally invoked from a Control Page). I added this to the plugin as it is much more efficient in computer usage as the CSV file is only updated when its output is being viewed. :)

Posted on
Mon Mar 04, 2019 8:33 am
autolog offline
Posts: 3167
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: TRV Controller Discussion Thread

Busta999 wrote:
It appears something odd was happening with the remote Temp Sensor or more precisely the TRV's reading goof the temp.

Had you applied an offset to one and not the other?

Posted on
Mon Mar 04, 2019 8:36 am
Busta999 offline
User avatar
Posts: 663
Joined: Mar 30, 2016
Location: Wales UK

Re: TRV Controller Discussion Thread

autolog wrote:
Busta999 wrote:
It appears something odd was happening with the remote Temp Sensor or more precisely the TRV's reading goof the temp.

Had you applied an offset to one and not the other?


No both are identical - finally worked out how to get the offset in the sensor _ the best place for an offset - I had been struggling to get the offset right - but was helped elsewhere

As an aside: Have you investigated the CSV creation that the TRV Controller plugin can do for you. It is effectively done on demand (via an action, normally invoked from a Control Page). I added this to the plugin as it is much more efficient in computer usage as the CSV file is only updated when its output is being viewed. :)


No - somewhat daunted by :oops: I should do - I am really enjoying the MatPlotLib graphs right now - but should use your way as more efficient :-)

Posted on
Mon Mar 04, 2019 8:49 am
autolog offline
Posts: 3167
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: TRV Controller Discussion Thread

Busta999 wrote:
.... No - somewhat daunted by :oops: I should do - I am really enjoying the MatPlotLib graphs right now - but should use your way as more efficient :-)


I am also using MatPlotLib to generate the graphs from the CSV data that the plugin creates.

When I invoke the Control Page that has the graphs, the related server actions (on the page where I select the graph Control page) are: 1) run the TRV Controller plugin action to create the CSV files and then create the graph (via a MatPlotLib action) with a delay of 3 seconds to allow the CSV files to be created. On the Control Page that displays the graph, tapping or clicking on the graph runs the two same actions to recreate the graph.

I normally display 24 hour graphs but have added buttons beneath the graph for 12 hours, 6 hours and 3 hours. Clicking on any of those buttons will regenerate the CSV file and Graphs using the aforementioned actions. The CSV creation Action allows you to specify the period.

In the case of CSV creation using PostgreSQL, the values in the CSV file are taken directly from the Indigo Log and therefore you only get an entry when something changes. The CSV file is top and tailed so that all graph lines start at the Left of the x-axis and end at Right of the x-axis. :)

Posted on
Mon Mar 04, 2019 8:55 am
Busta999 offline
User avatar
Posts: 663
Joined: Mar 30, 2016
Location: Wales UK

Re: TRV Controller Discussion Thread

OK will give it a go

Posted on
Mon Mar 04, 2019 9:10 am
autolog offline
Posts: 3167
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: TRV Controller Discussion Thread

Busta999 wrote:
OK will give it a go

Good luck - I am here to help or for clarification if needed. :D

Posted on
Mon Mar 04, 2019 9:38 am
Busta999 offline
User avatar
Posts: 663
Joined: Mar 30, 2016
Location: Wales UK

Re: TRV Controller Discussion Thread

Ok

Understand it.

But not sure of the gain by doing it this way ?

Just let matPlotLib do its thing in the background and refresh every 15 minutes and draw the graphs and they are already there.

There is s an elegance to 'just in time' processing

Posted on
Mon Mar 04, 2019 10:14 am
Busta999 offline
User avatar
Posts: 663
Joined: Mar 30, 2016
Location: Wales UK

Re: TRV Controller Discussion Thread

Ok I think I have found a really odd one...

I have set up an action group to shut off the unused Guest rooms/bathrooms/ensuites - and to set the TRVs to 17.

Then created another action to setup the rooms and restore to a three schedule day of varying temps throughout the day.

The Off is working as expected - in the TRV properties you an see one schedule 00:001 - 23:59 - 17C great.

if you open the TRV up Scheduling still shows old three schedules.

Is it possible the TRV Config is not re-reading in its settings?

If Device start heat set point method is - Specifiy Setpoint

Also if I disabled all Schedules would it go to Default Device Start set point or Default ON Temperature settings?

Thanks

Posted on
Mon Mar 04, 2019 10:37 am
autolog offline
Posts: 3167
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: TRV Controller Discussion Thread

Busta999 wrote:
Ok I think I have found a really odd one...

I have set up an action group to shut off the unused Guest rooms/bathrooms/ensuites - and to set the TRVs to 17.

Then created another action to setup the rooms and restore to a three schedule day of varying temps throughout the day.

The Off is working as expected - in the TRV properties you an see one schedule 00:001 - 23:59 - 17C great.

if you open the TRV up Scheduling still shows old three schedules.

Is it possible the TRV Config is not re-reading in its settings?

If Device start heat set point method is - Specifiy Setpoint

Also if I disabled all Schedules would it go to Default Device Start set point or Default ON Temperature settings?

Thanks

Run an Action Show Schedule for the device - what does that show? Post the output so I can see. :)

It will (should) go to the default start setpoint if schedules are disabled.

Posted on
Mon Mar 04, 2019 11:15 am
Busta999 offline
User avatar
Posts: 663
Joined: Mar 30, 2016
Location: Wales UK

Re: TRV Controller Discussion Thread

Code: Select all
   TRV                             
================================================================================
== TRV Controller Plugin - Heating Schedule                                   ==
==                                                                            ==
== Device: 'TRV - Radiator - Bathroom'                                        ==
==   Schedule Type: 'Default'                                                 ==
==     Schedule 1: 00:01 - 06:55. Setpoint = 17.0                             ==
==     Schedule 2: Disabled                                                   ==
==     Schedule 3: Disabled                                                   ==
==   Schedule Type: 'Running'                                                 ==
==     Schedule 1: 00:01 - 23:59. Setpoint = 17.0 [*]                         ==
==   Schedule Type: 'Dynamic'                                                 ==
==     Schedule 1: 00:01 - 23:59. Setpoint = 17.0 ACTIVE                      ==
==                                                                            ==
================================================================================
[attachment=0]TRV - Actual and Config.jpeg[/attachment]
Attachments
TRV - Actual and Config.jpeg
TRV - Actual and Config.jpeg (393.35 KiB) Viewed 411 times

Posted on
Mon Mar 04, 2019 11:27 am
autolog offline
Posts: 3167
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: TRV Controller Discussion Thread

I think it is (mainly) OK :)

When you run an Action to setup a revised schedule, it doesn't alter the device definition which is the default.

However, the Show Schedule looks as though it isn't 100% correct as it should be listing out the device default schedule and it doesn't appear to be doing so, :?
I will take a look at it.

The custom states seem to show that the updated schedule is setup OK i.e. only schedule 1 active and on at 00:01 and off at 23:59.

If you override the default schedule using an Action, this has to be run on a daily basis (say at 00:15) as everything is reset at 5 minutes past midnight.

Posted on
Mon Mar 04, 2019 11:34 am
Busta999 offline
User avatar
Posts: 663
Joined: Mar 30, 2016
Location: Wales UK

Re: TRV Controller Discussion Thread

Ok

See if I get this right.

The guest rooms have two basic states -

1. Normal mode up and down - warm during day and cooler at night.
2. Not in use mode - set to stick to 17C while not in use.

If the TRV is set up to be in Mode 1 Normal - to move to Mode 2 - Not in Use it needs to be sent at time of change and at 12:15am every night while you want the state to remain.

Not an issue as I have Guest Mode Variable in use and can setup a Schedule based upon the Variable.

Any way to permanently change the default settings by action?

Page 13 of 24 1 ... 10, 11, 12, 13, 14, 15, 16 ... 24

Who is online

Users browsing this forum: No registered users and 1 guest