Fantastic Weather Plugin Bug Reports

Posted on
Tue Jan 15, 2019 8:27 pm
sumocomputers offline
Posts: 165
Joined: Jun 23, 2008

Re: Fantastic Weather Plugin Bug Reports

Dave,

I hope I am just doing something dumb, but on version 0.2.03 with Indigo 7.2, I am not getting a "Configure" option under either of the Plugin menus (see screenshot).

Nor am I able to see any Fantastic Weather device when adding a device.

I have tried reloading the plugin, stopping/starting the server, and even rebooting the Mac, but can't seem to get it to show.

Thanks,

Chris
Attachments
Screenshot 2019-01-15 18.19.34.png
Screenshot 2019-01-15 18.19.34.png (446.24 KiB) Viewed 1437 times

Posted on
Tue Jan 15, 2019 9:39 pm
DaveL17 offline
User avatar
Posts: 5261
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Fantastic Weather Plugin Bug Reports

sumocomputers wrote:
I have tried reloading the plugin, stopping/starting the server, and even rebooting the Mac, but can't seem to get it to show.

Hi Chris - sorry to hear that you're having trouble with the plugin. The symptoms that you're describing are likely related. It seems that the plugin is not loading properly so it never gets to a point where you can view devices.

This is usually the result of two or three things (in decreasing order of likelihood):
  • The preferences file where Indigo stores the plugin settings is corrupted.
  • The internal plugin file (called PluginConfig.xml) that the Indigo server uses to establish and maintain the plugin's preferences isn't loading properly. This could be due to a malformed PluginConfig.xml file--but Ive run it through syntax checkers and there doesn't appear to be anything wrong with the file.
  • There is something within the initialization of the plugin (within the __init__ method of the plugin itself to be specific) that is not returning a result, and the plugin just hangs there because it can't finish initializing.
There may be others, but let's start here.

Please take the following steps (read to the end before beginning):
  • Make sure that you've made a copy of your API key.
  • Make sure that the plugin is disabled.
  • Go to this folder: /Library/Application Support/Perceptive Automation/Indigo 7.2/Preferences/Plugins/ (or which ever is appropriate for your version of Inidgo.)
  • Make a back-up of this file: com.fogbert.indigoplugin.fantasticwWeather.indiPref. (Select the file and then type CMD-D).
  • Delete the original file you just backed-up.
  • Reload the plugin. Hopefully, you will be presented with a plugin configuration dialog
If it works, you're going to have to re-enter the plugin preferences.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Wed Jan 16, 2019 6:55 am
sumocomputers offline
Posts: 165
Joined: Jun 23, 2008

Re: Fantastic Weather Plugin Bug Reports

So this was my first time trying to install the plugin. That being said, the Plugin Preference file did not exist (see screenshot).

I did install the previous version of the Plugin (v0.2.02), and immediately got the Config Dialog.

It seems maybe v0.2.03 has an issue?
Attachments
Screenshot 2019-01-16 04.46.00.png
Screenshot 2019-01-16 04.46.00.png (358.56 KiB) Viewed 1402 times

Posted on
Wed Jan 16, 2019 7:12 am
DaveL17 offline
User avatar
Posts: 5261
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Fantastic Weather Plugin Bug Reports

Thanks for the report. The lack of the preferences file is probably why the config dialog wouldn't open. I can't guarantee it, but now that the config file exists, you should be able to update to the most current version.

I'll check it out. Could be that I mucked something up with the most recent update.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Wed Jan 16, 2019 7:13 am
sumocomputers offline
Posts: 165
Joined: Jun 23, 2008

Re: Fantastic Weather Plugin Bug Reports

Once I got the older plugin configured and it created the pref file, I got the latest version installed and reloaded, and it seems to be working on v0.2.03.

Thanks for the help.

Posted on
Wed Jan 16, 2019 7:20 am
DaveL17 offline
User avatar
Posts: 5261
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Fantastic Weather Plugin Bug Reports

Was able to find the problem pretty easily. I will post an update to the plugin as soon as I can.

Thanks again for the report. I hope you find the plugin useful.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Wed Jan 16, 2019 7:23 am
DaveL17 offline
User avatar
Posts: 5261
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Fantastic Weather Plugin Bug Reports

sumocomputers wrote:
Once I got the older plugin configured and it created the pref file, I got the latest version installed and reloaded, and it seems to be working on v0.2.03.

Thanks for the help.

Great news. Thanks for letting me know.

Cheers.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Who is online

Users browsing this forum: No registered users and 1 guest