Lost Communication with WeatherSnoop 3 using Indigo 6.1.11

Posted on
Mon Jan 30, 2017 11:26 am
wikner offline
Posts: 177
Joined: Nov 02, 2003

Lost Communication with WeatherSnoop 3 using Indigo 6.1.11

I am running Indogo 6.1.11 on an old Mac Mini (Mini 1.1 OS 10.6.8 ) and WeatherSnoop 3.1.7 (1116) on a newer Mac Mini (Late 2014 Sierra 10.12.2). Although I have purchased Indigo 7.x, I have not upgraded this installation from 6.x because it is not supported on my old Mac Mini. I am also running some old serial software that I wrote in RealBasic which listens to the printer output of my alarm system and sends that to Indigo via AppleScript. This is something that it would take considerable time to replace (maybe using serial routines in Python); I have not had time to do it..

In any case all was well until January 21, the last time I got a routine update from WeatherSnoop into Indigo. I noticed this a few days later when several weather-related triggers weren't firing. WeatherSnoop is running correctly, and I can look at its web interface from any other machine on my LAN. WeatherSnoop is also sending updates to Weather Underground successfully and continuously.

If I edit the device settings for my Indigo WeatherSnoop device, changing the hard-coded Lan Address (which is fixed on my network) to the symbolic "Homemaker-2.local:8000", I get one successful update, then updates stop. If I then change it back to "192.168.15.63:8000" I get one successful update, then updates stop. How can I debug this? It is possible that this happened after an Apple OS update, but I can't be sure.

Norman

Posted on
Mon Jan 30, 2017 12:35 pm
jay (support) offline
Site Admin
User avatar
Posts: 15880
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Lost Communication with WeatherSnoop 3 using Indigo 6.1.

Have you tried rebooting? Also, have you renamed your Mac recently? Finally, what if any errors are you seeing in the Event Log? You can select the Plugins->WeatherSnoop->Toggle Debugging to see if there are any errors occurring.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Jan 30, 2017 3:34 pm
wikner offline
Posts: 177
Joined: Nov 02, 2003

Re: Lost Communication with WeatherSnoop 3 using Indigo 6.1.

:oops: Well, that was too easy. I rebooted both machines, and now its all working. I had also been getting daily crashes of Security Spy on Homemaker-2. We'll see if that gets fixed as well...

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest