RFXCOM plugin fails to start: initialization failed

Posted on
Wed Oct 28, 2020 4:24 am
macpro offline
User avatar
Posts: 712
Joined: Dec 29, 2005
Location: Third byte on the right

RFXCOM plugin fails to start: initialization failed

I have a RFXCOM module that I bought somewhere in 2009 or before. Not sure what kind of type it is, because it is not mentioned on the outside.
The logic board mentions "I/O Module rev. 3", "0709", "94V-0" and "C-29".

Normally I use this module as the X10RF interface in Indigo. There it works fine.
When I disable this X10RF interface in Indigo (to free up the device) and then try to start the RFXCOM plugin, it fails:

Code: Select all
  Reloading plugin "RFXCOM 2.1.16"
   Stopping plugin "RFXCOM 2.1.16" (pid 9338)
   Stopped plugin "RFXCOM 2.1.16"
   Starting plugin "RFXCOM 2.1.16" (pid 9348)
   Started plugin "RFXCOM 2.1.16"
   RFXCOM Debug                    RFXCOM startup called
   RFXCOM Debug                    startup called
   RFXCOM Debug                    runConcurrentThread called
   RFXCOM Debug                    startComm called
   RFXCOM Debug                    getConfiguration start
   RFXCOM                          initializing communication on port /dev/cu.usbserial-A5001RgJ at speed 38400
   RFXCOM Debug                    serial port opened
   RFXCOM Debug                    send reset cmd: 13 0 0 0 0 0 0 0 0 0 0 0 0 0 (0D 00 00 00 00 00 00 00 00 00 00 00 00 00)
   RFXCOM Debug                    PIC INIT IS: none
   RFXCOM Debug                    send init cmd: 13 0 0 1 2 0 0 0 0 0 0 0 0 0 (0D 00 00 01 02 00 00 00 00 00 00 00 00 00)
   RFXCOM Debug                    rcvd init reply: none
   RFXCOM Error                    initialization failed (retrying in 10 seconds)
   Disabling plugin "RFXCOM 2.1.16"
   Stopping plugin "RFXCOM 2.1.16" (pid 9348)
   RFXCOM Debug                    stopConcurrentThread called
   RFXCOM Debug                    stopConcurrentThread called
   RFXCOM Debug                    startComm Exit
   RFXCOM Debug                    stopConcurrentThread called
   RFXCOM Debug                    stopConcurrentThread called
   RFXCOM Debug                    shutdown called


The FTDI driver is installed.

Any clues on what might be happening here?

"I tawt I taw a puddy tat!" Tweety

Posted on
Wed Oct 28, 2020 9:18 am
matt (support) offline
Site Admin
User avatar
Posts: 20243
Joined: Jan 27, 2003
Location: Texas

Re: RFXCOM plugin fails to start: initialization failed

The USB communication is failing (nothing is being sent back to Indigo. Are you sure you have the correct serial port selected? Also try different USB ports, including ports on USB hubs.

Image

Posted on
Wed Oct 28, 2020 9:28 am
macpro offline
User avatar
Posts: 712
Joined: Dec 29, 2005
Location: Third byte on the right

Re: RFXCOM plugin fails to start: initialization failed

100%
It is the same port I use for the Indigo X10 RF interface and that works just fine.

"I tawt I taw a puddy tat!" Tweety

Posted on
Wed Oct 28, 2020 12:52 pm
matt (support) offline
Site Admin
User avatar
Posts: 20243
Joined: Jan 27, 2003
Location: Texas

Re: RFXCOM plugin fails to start: initialization failed

So this RFXCOM interface works if you use it as an X10RF interface (I presume you are selecting the W800 interface type in Indigo?) but not if you use the RFXCOM plugin?

I'm trying to remember how it works but the RFXCOM can emulate the W800, so the problem might be that it is in W800 emulation mode instead of native RFXCOM mode.

Image

Posted on
Wed Oct 28, 2020 2:24 pm
macpro offline
User avatar
Posts: 712
Joined: Dec 29, 2005
Location: Third byte on the right

Re: RFXCOM plugin fails to start: initialization failed

That’s correct. It replaced a genuine W800RF32 long time ago.
But I can’t remember either what I did to get the RFXcom module to work.

"I tawt I taw a puddy tat!" Tweety

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 3 guests