"Image Downloader and SecuritySpy Helper Error"

Posted on
Fri Jun 17, 2022 2:59 pm
shapa offline
Posts: 448
Joined: Sep 08, 2014
Location: Swindon

"Image Downloader and SecuritySpy Helper Error"

Seeing identical errors with the new/latest version in two different environments (two homes).

" Image Downloader and SecuritySpy Helper Error Error in plugin execution ExecuteAction:

File "plugin.py", line 428, in downloadImage
File "plugin.py", line 139, in getImage
type: can only concatenate str (not "bytes") to str"

No images retrieved anymore.

Posted on
Mon Jun 20, 2022 6:55 pm
agame offline
Posts: 497
Joined: Jul 13, 2017
Location: Melbourne, Australia

Re: "Image Downloader and SecuritySpy Helper Error"

i'm being prompted to upgrade this plugin but the link is broken:

https://www.indigodomo.com/pluginstore/162/release/1.8/

Posted on
Mon Jun 20, 2022 7:13 pm
jay (support) offline
Site Admin
User avatar
Posts: 17487
Joined: Mar 19, 2008
Location: Austin, Texas

Re: "Image Downloader and SecuritySpy Helper Error"

Where are you getting that URL?

In any event, you can just go to the plugin's page in the store and click the download button.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Jun 20, 2022 7:15 pm
jay (support) offline
Site Admin
User avatar
Posts: 17487
Joined: Mar 19, 2008
Location: Austin, Texas

Re: "Image Downloader and SecuritySpy Helper Error"

Never mind, now to figure out what's broken... :)

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Jun 20, 2022 7:49 pm
jay (support) offline
Site Admin
User avatar
Posts: 17487
Joined: Mar 19, 2008
Location: Austin, Texas

Re: "Image Downloader and SecuritySpy Helper Error"

Ok, so the problem is that the developer isn't following the required pattern for naming releases. His latest release is tagged 1.8 in his github repo, but we require that release tags be X.Y.Z (must contain 3 numbers).

@vtmikel, if you're watching, you might want to delete your current 1.8 release and recreate it as 1.8.0 and it'll work correctly with the store and plugin update checks.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Jun 20, 2022 8:00 pm
agame offline
Posts: 497
Joined: Jul 13, 2017
Location: Melbourne, Australia

Re: "Image Downloader and SecuritySpy Helper Error"

Where are you getting that URL?


i gather you figured it out (the landing page after following the Indigo 'Download New Version' menu).

Posted on
Tue Jun 21, 2022 5:23 am
shapa offline
Posts: 448
Joined: Sep 08, 2014
Location: Swindon

Re: "Image Downloader and SecuritySpy Helper Error"

Any ideas on how to fix the bug? :)

Posted on
Tue Jun 21, 2022 6:23 am
FlyingDiver offline
User avatar
Posts: 6054
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: "Image Downloader and SecuritySpy Helper Error"

shapa wrote:
Any ideas on how to fix the bug? :)


Did you install version 1.8? https://github.com/mlamoure/indigo-secu ... Plugin.zip

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Jun 21, 2022 9:47 am
shapa offline
Posts: 448
Joined: Sep 08, 2014
Location: Swindon

Re: "Image Downloader and SecuritySpy Helper Error"

Sure. The issue began with 1.8 - no problems with the older version (except old python and Intel only)

Posted on
Tue Jun 21, 2022 10:11 am
FlyingDiver offline
User avatar
Posts: 6054
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: "Image Downloader and SecuritySpy Helper Error"

shapa wrote:
Sure. The issue began with 1.8 - no problems with the older version (except old python and Intel only)


Ah, sorry. confused the posters.

Yeah, that's a common Python2 to Python3 conversion error. Should be easy for the developer to fix.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Jun 22, 2022 5:11 pm
vtmikel offline
Posts: 573
Joined: Aug 31, 2012
Location: Boston, MA

Re: "Image Downloader and SecuritySpy Helper Error"

jay (support) wrote:
Ok, so the problem is that the developer isn't following the required pattern for naming releases. His latest release is tagged 1.8 in his github repo, but we require that release tags be X.Y.Z (must contain 3 numbers).

@vtmikel, if you're watching, you might want to delete your current 1.8 release and recreate it as 1.8.0 and it'll work correctly with the store and plugin update checks.


OK. Did not realize that. I'll fix on next version

Posted on
Sat Jun 25, 2022 7:29 am
vtmikel offline
Posts: 573
Joined: Aug 31, 2012
Location: Boston, MA

Re: "Image Downloader and SecuritySpy Helper Error"

I'll be posting an update to this plugin shortly. I've been testing some updates.

Posted on
Sun Jun 26, 2022 8:03 am
shapa offline
Posts: 448
Joined: Sep 08, 2014
Location: Swindon

Re: "Image Downloader and SecuritySpy Helper Error"

Works now (v1.8.1), but only for .jpg

Animated gif is not working :

"Image Downloader and SecuritySpy Helper Error Error in plugin execution ExecuteAction:

File "plugin.py", line 381, in downloadImage
type: can't concat str to bytes"

Posted on
Sun Jun 26, 2022 8:24 am
vtmikel offline
Posts: 573
Joined: Aug 31, 2012
Location: Boston, MA

Re: "Image Downloader and SecuritySpy Helper Error"

shapa wrote:
Works now (v1.8.1), but only for .jpg

Animated gif is not working :

"Image Downloader and SecuritySpy Helper Error Error in plugin execution ExecuteAction:

File "plugin.py", line 381, in downloadImage
type: can't concat str to bytes"


Could you show me a screen shot of your Action Settings on the one that is throwing an error?

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest

cron