Help with set up

Posted on
Sat May 12, 2018 6:52 am
dlleon offline
Posts: 70
Joined: Dec 14, 2012

Help with set up

I have a gen 1 unit. I went to the website and retrieved the API key and entered it into the plug in. I set up a new device in Indigo, and under Edit Device settings, set it for US. The "Device" entry above that is grayed out.

I closed the window, and the Rachio Sprinkler is in my Device list. When I try to get status, nothing happens. Here's the log. I replaced my API key with <<API>>

Any ideas?

----------

Rachio Sprinklers Error Connection to Rachio API server failed with exception: ValueError. Check the log file for full details.
Rachio Sprinklers Debug Connection to Rachio API server failed with exception:
Traceback (most recent call last):
File "plugin.py", line 201, in _make_api_call
r = method(url, headers=self.headers, timeout=self.timeout)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/api.py", line 71, in get
return request('get', url, params=params, **kwargs)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/api.py", line 57, in request
return session.request(method=method, url=url, **kwargs)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/sessions.py", line 477, in request
resp = self.send(prep, **send_kwargs)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/sessions.py", line 587, in send
r = adapter.send(request, **kwargs)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/adapters.py", line 417, in send
timeout=timeout
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/packages/urllib3/connectionpool.py", line 578, in urlopen
chunked=chunked)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/packages/urllib3/connectionpool.py", line 362, in _make_request
conn.request(method, url, **httplib_request_kw)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 1053, in request
self._send_request(method, url, body, headers)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 1092, in _send_request
self.putheader(hdr, value)
ValueError: Invalid header value 'Bearer <<API>>\n'

Rachio Sprinklers Error Error getting user ID from Rachio via API.
Rachio Sprinklers Debug API error:
Traceback (most recent call last):
File "plugin.py", line 263, in _update_from_rachio
reply = self._make_api_call(PERSON_INFO_URL)
File "plugin.py", line 238, in _make_api_call
raise exc
ValueError: Invalid header value 'Bearer <<API>>\n'

Posted on
Sat May 12, 2018 9:58 am
jay (support) offline
Site Admin
User avatar
Posts: 15683
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Help with set up

I'm not sure the v1 controller works - I only have the v2 controller to test with. The error seems to indicate that the authentication that their API specifies isn't supported on the v1 controller.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Jun 21, 2018 10:04 pm
Krikee offline
Posts: 25
Joined: Jan 03, 2014

Re: Help with set up

I recently had a power outage that forced me to take a look at the logs. I don't think the power event had anything to do with this at all, it was just the reason behind checking the logs...Anyway, I too am getting the same error as indicated by the OP. The version I was/am running is the current one. 1.1.3. My controller is a Gen2


I have as troubleshooting performed the following.
Removed the plugin
Stopped the server and restarted it.
Confirmed the plugin was not listed in the plugins list.
Downloaded the plugin again (ver 1.1.3)
Activated the plugin
Restarted the server again
Double checked my API Key and copy pasted it into the config
The error reoccured after all of the above.
Not sure if any of this info is helpful but there it is...
I am happy to do any testing you would suggest. I am currently not using indigo to schedule anything simply because I haven't spent a lot of time with this plugin yet.

Here is the log entry

Loading plugin "Rachio Sprinklers 1.1.3"
Starting plugin "Rachio Sprinklers 1.1.3" (pid 610)
Started plugin "Rachio Sprinklers 1.1.3"
Rachio Sprinklers Debug Starting concurrent tread
Rachio Sprinklers Error Connection to Rachio API server failed with exception: ValueError. Check the log file for full details.
Rachio Sprinklers Debug Connection to Rachio API server failed with exception:
Traceback (most recent call last):
File "plugin.py", line 201, in _make_api_call
r = method(url, headers=self.headers, timeout=self.timeout)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/api.py", line 71, in get
return request('get', url, params=params, **kwargs)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/api.py", line 57, in request
return session.request(method=method, url=url, **kwargs)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/sessions.py", line 477, in request
resp = self.send(prep, **send_kwargs)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/sessions.py", line 587, in send
r = adapter.send(request, **kwargs)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/adapters.py", line 417, in send
timeout=timeout
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/packages/urllib3/connectionpool.py", line 578, in urlopen
chunked=chunked)
File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/requests/packages/urllib3/connectionpool.py", line 362, in _make_request
conn.request(method, url, **httplib_request_kw)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 1053, in request
self._send_request(method, url, body, headers)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 1092, in _send_request
self.putheader(hdr, value)
ValueError: Invalid header value 'Bearer 0fa6b552-ea59-4c14-ae5a-9f22fe47640e\r\n\r\n0fa6b552-ea59-4c14-ae5a-9f22fe47640e\r\n\r\n0fa6b552-ea59-4c14-ae5a-9f22fe47640e'

Rachio Sprinklers Error Error getting user data from Rachio via API.
Rachio Sprinklers Debug API error:
Traceback (most recent call last):
File "plugin.py", line 272, in _update_from_rachio
reply_dict = self._make_api_call(PERSON_URL.format(apiVersion=RACHIO_API_VERSION, personId=self.person_id))
File "plugin.py", line 238, in _make_api_call
raise exc
ValueError: Invalid header value 'Bearer 0fa6b552-ea59-4c14-ae5a-9f22fe47640e\r\n\r\n0fa6b552-ea59-4c14-ae5a-9f22fe47640e\r\n\r\n0fa6b552-ea59-4c14-ae5a-9f22fe47640e'

Posted on
Wed Aug 08, 2018 6:30 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: Help with set up

I'm also having problems setting up. Version 1.1.3, I have a Gen 2 controller. I went to my account and got the API key. Configured the plug in with the key. Setting up the device, Type is Rachio Sprinklers, Model is Rachio Sprinkller Controller. In Edit Device Settings the Device is ghosted, nothing to select and Weather units in set to US. The polling is giving me a log error of

Rachio Sprinklers Error Error in plugin execution GetUiDynamicList:

Traceback (most recent call last):
File "plugin.py", line 476, in availableControllers
File "plugin.py", line 242, in _get_device_dict
AttributeError: 'Plugin' object has no attribute 'person'

3 minutes later this appears in the log

Rachio Sprinklers Warning You must specify your API token in the plugin's config before the plugin can be used

Is the token different that the key? If so where do you find that?

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Thu Aug 09, 2018 2:31 pm
jay (support) offline
Site Admin
User avatar
Posts: 15683
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Help with set up

No, it's the same (they changed terminology since I first developed the plugin).

There appear to be two different issues in your post. I think maybe you didn't copy the API key correctly, but that may be a red herring. Verify that it's correct and reboot your Mac and let's see what happens.

Also, delete your Indigo Rachio device and recreate it. Watch the event log for any errors.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Aug 09, 2018 4:24 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: Help with set up

Same result. In the Get API option within my account on Rachio it give you the opportunity to copy to clipboard which I did and pasted it into the API Token Line. I made sure it didn't add an extra space. Devise line is still ghosted within the edit device settings and errors still in the log. 3:11:00 was me just clicking on something within the device. 3:11:57 was the polling of the Rachio API.

Aug 9, 2018, 3:11:00 PM
Ignored device "Rachio Sprinklers" action request (communication is disabled)
Ignored device "Rachio Sprinklers" action request (communication is disabled)

Aug 9, 2018, 3:11:57 PM
Rachio Sprinklers Error Connection to Rachio API server failed with exception: ValueError. Check the log file for full details.
Rachio Sprinklers Error Error getting user ID from Rachio via API.

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Thu Aug 09, 2018 5:13 pm
jay (support) offline
Site Admin
User avatar
Posts: 15683
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Help with set up

No, different result (different error)... ;)

Email this file to me (support@indigodomo.com):

Code: Select all
/Library/Application Support/Perceptive Automation/Indigo 7/Logs/opensource.rachio/plugin.log


be sure to reference this forum thread.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Aug 09, 2018 5:31 pm
jay (support) offline
Site Admin
User avatar
Posts: 15683
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Help with set up

Looks like your copy/paste of the key didn't work:

Code: Select all
ValueError: Invalid header value 'Bearer KEYBLANKEDOUT\n\nCopy to clipboard'


Notice the extra carriage returns and the Copy to clipboard text... ;)

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Aug 09, 2018 6:21 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: Help with set up

OK, don't use the copy to clipboard option on the Rachio site. I cleared everything out and typed in the key by hand and now I have a Rachio device. Who knew convenance (copy to clipboard) would come at a cost. :-) Thanks as usual for your help!

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest