Tag error and no location state set

Posted on
Wed Apr 03, 2019 10:18 am
ottoppp offline
Posts: 11
Joined: Oct 21, 2013

Tag error and no location state set

It seems that this plugin hasn't worked for a while. The location isn't returned, and there is a 404 error for the tag (not sure what this is), and while there is lots of data returned, some of it isn't correct (Regular gas type instead of set value of Premium). Any chance there is interest in reviving it? Is the location problem due to a Google Maps API issue as another poster implied?

Posted on
Thu Apr 04, 2019 5:51 am
dgarozzo offline
Posts: 127
Joined: Jan 08, 2009

Re: Tag error and no location state set

I’ll try to look into this over the weekend. I’m pretty sure my install is still working, so I’m hoping it’s just a misconfiguration.


Sent from my iPhone using Tapatalk

Posted on
Thu Apr 04, 2019 4:19 pm
dgarozzo offline
Posts: 127
Joined: Jan 08, 2009

Re: Tag error and no location state set

Do you have the latest version of the plugin (1.0.6)? Can you enable debug logs and send me them? The plugin is still working on my system.

Posted on
Sat Apr 06, 2019 2:16 pm
ottoppp offline
Posts: 11
Joined: Oct 21, 2013

Re: Tag error and no location state set

I have version 1.0.7.

Debug doesn't show any errors. received vehicle, trip and user states, doesn't show location being received.

Redacted version:

Automatic OBD-II Debug startup called
Automatic OBD-II Debug deviceStartComm
Automatic OBD-II Debug _refreshStatesFromAPI for MyCar (C_3e272037ee32c523)
Automatic OBD-II Debug Bearer 4565d36a5d263c500083fb32567267df123aab00
Automatic OBD-II Debug received "MyCar" vehicle to {"active_dtcs":[],"battery_voltage":14.329,"created_at":"2018-03-19T16:27:28.751000Z","display_name":null,"fuel_grade":"regular","fuel_level_percent":36.0,"id":"C_3e272037ee32c523","make":"Brand","model":"Model","submodel":"Submodel","updated_at":"2018-07-26T20:21:56.092000Z","url":"https://api.automatic.com/vehicle/C_3e272037ee32c523/","year":2018}
Automatic OBD-II Debug Bearer 4565d36a5d263c500083fb32567267df123aab00
Automatic OBD-II Debug received "MyCar" trip to {"_metadata":{"count":705,"previous":null,"next":"https://api.automatic.com/trip/?started_at__gte=1431126000&started_at__lte=2545951522&limit=1&vehicle=C_3e272037ee32c523&page=2&cursor=9c74d693-1ea8-4200-934b-4d1ba1d998ca"},"results":[{"id":"T_50575b4666976e05","url":"https://api.automatic.com/trip/T_50575b4666976e05/","driver":"https://api.automatic.com/user/U_e19f52bad0aefca7/","vehicle":"https://api.automatic.com/vehicle/C_3e272037ee32c523/","vehicle_events":[],"duration_s":953.1,"distance_m":4433.6,"fuel_cost_usd":0.49,"path":"ecreFnn`jVc@k@??uAjB]d@[`@EFEHKL[`@SVAB[`@fB`Cp@~@Zb@z@hAnBnCJLlDzEn@z@`AtA??TXZd@|@jAV\\xArBl@x@BBf@r@j@v@HJ^f@dAvABDLNj@v@xArBJNtBrCJL`@j@d@n@xArB@?p@~@DF`@j@NRd@l@^h@RXf@p@PVhAzA\\d@V\\d@n@RXjA~AZ`@`AtAh@t@X^FJr@~@p@|@JLLRNPPTb@b@FDVPNJ??DB@?TLVJTH\\JXDRBB?@?N@V@V?H?HAPAZATCx@CTCf@CVAXAdBI@JBbAFlCD|ADxBBt@BpADpABbABfADlA@~@@LBhA@h@@VBdAD|ABt@BlABpABf@@j@D|A@f@B|@DjB@d@DdBDzAD~A??@P~COzBKd@CfAEj@CnDO`@A`BK|@ErBKj@Cv@EnDOtAG|CO@?~CMvAIfAG??B~@@T","fuel_volume_l":0.6,"hard_brakes":0,"hard_accels":0,"duration_over_70_s":0,"duration_over_75_s":0,"duration_over_80_s":0,"average_kmpl":7.7,"average_from_epa_kmpl":9.8,"start_address":{"name":"1 Some Street, San Francisco, CA 94101","display_name":"1 Some Street, San Francisco, CA 94101","street_number":"1","street_name":"Some Street","city":"San Francisco","state":"CA","country":"US","zipcode":"94101"},"start_location":{"lat":37.78121,"lon":-122.2000,"accuracy_m":10.0},"end_address":{"name":"1 Another St, San Francisco, CA 94101","display_name":"1 Another St, San Francisco, CA 94101","street_number":"1","street_name":"Another St","city":"San Francisco","state":"CA","country":"US","zipcode":"94101"},"end_location":{"lat":37.72000,"lon":-122.2000,"accuracy_m":5.0},"started_at":"2019-04-04T20:01:58Z","ended_at":"2019-04-04T20:17:51.100000Z","start_timezone":"America/Los_Angeles","end_timezone":"America/Los_Angeles","score_events":50.0,"score_speeding":50.0,"city_fraction":1.0,"highway_fraction":0.0,"night_driving_fraction":0.0,"tags":[],"idling_time_s":0,"user":"https://api.automatic.com/user/U_e19f52bad0aefca7/"}]}
Automatic OBD-II Debug Bearer 4565d36a5d263c500083fb32567267df123aab00
Automatic OBD-II Debug received "MyCar" user to {"id":"U_e19f52bad0aefca7","url":"https://api.automatic.com/user/U_e19f52bad0aefca7/","username":"user@examplecom","first_name":"First","last_name":"Lastname","email":"user@examplecom","email_verified":false}
Automatic OBD-II Debug AutomaticWebSocketThread starting...
Automatic OBD-II Debug AutomaticWebSocketThread started

Posted on
Sat Apr 06, 2019 4:41 pm
dgarozzo offline
Posts: 127
Joined: Jan 08, 2009

Re: Tag error and no location state set

Did you redact the start address? Was the address correct before you redacted it?

You should only receive location information when you're driving the car around.

You have the Google Maps API key and your Home Address populated in the Config?

1.0.7? My plugin's about says 1.0.6. I guess I forgot to update it in the code somewhere? Oh well.

Posted on
Sat Apr 06, 2019 4:55 pm
ottoppp offline
Posts: 11
Joined: Oct 21, 2013

Re: Tag error and no location state set

Thanks for the reply. I guess it's working fine. I did substitute the Start and End address for the trip data with fake ones, but they were correct before I changed them.

I did not understand that location was only while driving, I thought it was the "current location" regardless. Is there a way to parse out the end location of the vehicle from the last trip as a state or otherwise get it into a variable? My purpose is to know where the vehicle is parked. We don't have a garage, and street parking is sparse. With this my spouse and I wouldn't have remember to tell the other where the car is parked when it's not nearby.

The Plugin Store shows the version number as 1.0.7: http://www.indigodomo.com/pluginstore/130/

Posted on
Sun Apr 07, 2019 6:37 pm
dgarozzo offline
Posts: 127
Joined: Jan 08, 2009

Re: Tag error and no location state set

I’m fairly certain it already is accessible as a variable on the vehicle. I would imagine you could set a trigger on the vehicle off state, read the last location info, and email or text it to yourself.

How did you plan on looking up the info? If you were going to launch an app, you could launch the Automatic app on your phone. That shows you the last location, too.


Sent from my iPhone using Tapatalk

Posted on
Mon Apr 08, 2019 9:08 am
ottoppp offline
Posts: 11
Joined: Oct 21, 2013

Re: Tag error and no location state set

There aren't any device states that contain a location other than "location". I guess I could try to figure out how to extract/parse the end location from the "trip" state. You're correct that it would be easy enough to open the Automatic app and look at the parked location, but we have a dashboard (display in kitchen and at door) that shows things like that, and would like to be able to extract just that info for the dashboard.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest

cron