Cynical Weather v3.5.1 Crash

Posted on
Sat Jan 14, 2023 3:27 pm
Perry The Cynic offline
Posts: 823
Joined: Apr 07, 2008

Re: Cynical Weather v3.5.1 Crash

Thank you all for your help. That log with the rust bindings finally got me the right Google query. It turns out that when I embedded (Python) openssl in the plugin, I was a bit too... enthusiastic about throwing out unneeded files. Well, some of these files are needed - or not, depending on exactly how the Python installed on your system was installed. And upgraded. And updated. And stuff.

Anyway, I've added those files back in version 3.5.2. Let me know how it goes. I did finally manage to reproduce the problem (by using a pristine macOS system) and it fixed it there...

Cheers
-- perry

Posted on
Sat Jan 14, 2023 4:20 pm
norcoscia offline
User avatar
Posts: 1151
Joined: Sep 09, 2015

Re: Cynical Weather v3.5.1 Crash

I tried but with the new version I get an error from apple that says the developer can’t be verified and it will not run the new version - do you need to do something to prevent that or is it just apple helping me again?

Not sure how to override that since it is a plugin and not an application…..

_______
Norm

Posted on
Sat Jan 14, 2023 4:25 pm
veritas offline
Posts: 16
Joined: Dec 04, 2016

Re: Cynical Weather v3.5.1 Crash

I updated to the new version and I get the same error.
I turned off the plugin. I stopped the server and deleted the plugin, then downloaded and installed it again.
The error that appears in the event log is:

Jan 2023, 0:19:54
Action Group current weather updated
Cynical Weather Error in run_concurrent_thread: Traceback (most recent call last):
File ".../Server Plugin/cyin/debugging.py", line 67, in diagnostic_log
yield
File ".../Server Plugin/cyin/debugging.py", line 77, in diagnose_call
return method(*args, **kwargs)
File ".../Server Plugin/cyin/asynplugin.py", line 64, in run_concurrent_thread
self.run()
File ".../Server Plugin/asyn/inject.py", line 60, in run
asyn.Controller.run(self)
File ".../Server Plugin/asyn/controller.py", line 108, in run
item._can_write()
File ".../Server Plugin/asyn/resolve.py", line 76, in _can_write
self.callout(ctx, self.io)
File ".../Server Plugin/asyn/core.py", line 163, in callout
results = [cb(ctx, *args) for cb in list(self._callbacks)] # latch callback list
File ".../Server Plugin/asyn/core.py", line 163, in <listcomp>
results = [cb(ctx, *args) for cb in list(self._callbacks)] # latch callback list
File ".../Server Plugin/asyn/resolve.py", line 129, in _connected
self.callout(ctx, result)
File ".../Server Plugin/asyn/core.py", line 163, in callout
results = [cb(ctx, *args) for cb in list(self._callbacks)] # latch callback list
File ".../Server Plugin/asyn/core.py", line 163, in <listcomp>
results = [cb(ctx, *args) for cb in list(self._callbacks)] # latch callback list
File ".../Server Plugin/asyn/http.py", line 231, in _connected
self.scheme.create(self)
File ".../Server Plugin/asyn/http.py", line 148, in create
request.insert_filter(SSL, hostname=request.host, uplink=request.incoming)
File ".../Server Plugin/asyn/selectable.py", line 433, in insert_filter
filter = filter_class(self.upstream, *args, **kwargs)
TypeError: 'NoneType' object is not callable

Cynical Weather Error plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)

Posted on
Sat Jan 14, 2023 6:02 pm
Perry The Cynic offline
Posts: 823
Joined: Apr 07, 2008

Re: Cynical Weather v3.5.1 Crash

Oh great. Looks like we have two problems, and I still don't know how to make the SSL filter setup problem happen. :-(

Norcosia, those plugin bundles aren't code-signed (which is presumably what this message is about). Though I did add some .so (binary library) files to the bundle to make the other problem go away...

Grrrrr.

Cheers
-- perry

Posted on
Sat Jan 14, 2023 6:49 pm
norcoscia offline
User avatar
Posts: 1151
Joined: Sep 09, 2015

Re: Cynical Weather v3.5.1 Crash

Really weird,, below is the error I get when I try to run the update - tried restarting the server and rebooting the server machine. The only thing I did differently on this plugin install was have indigo client running on the machine I was on and also on the indigo server machine (which runs on a remote machine without a display I log into).

I don’t think that should be an issue but I just have never done it that way before - I wanted to watch the log on my local machine (since it has two monitors) while I did the update on the window I was logged into on the indigo server. Just thought I would mention it in case that could be an issue ( since I have had issues building control pages while running the client on a non server machine).

Anyway - not only is this not working but I also did not win the 1.3 billion dollar mega millions jackpot yesterday - so two unlucky days in a row :-)
Attachments
307F700D-716D-426C-A23E-95391B3DCB1E.jpeg
307F700D-716D-426C-A23E-95391B3DCB1E.jpeg (30.27 KiB) Viewed 255 times

_______
Norm

Posted on
Sat Jan 14, 2023 6:55 pm
SteveFyfe offline
Posts: 3
Joined: May 05, 2007
Location: Central Mass USA

Re: Cynical Weather v3.5.1 Crash

I tried but with the new version I get an error from apple that says the developer can’t be verified and it will not run the new version


I had this problem twice, for different plugins. The first time, Indigo was running on Monterey. I happened to open the Security system preferences and saw that the message was also shown there. But this time it had a button to allow running the plugin. No problems since I clicked that button.

The second time I saw this it was on Ventura, where the dialog that originally showed the message also had a button to allow running.

Posted on
Sat Jan 14, 2023 7:35 pm
norcoscia offline
User avatar
Posts: 1151
Joined: Sep 09, 2015

Re: Cynical Weather v3.5.1 Crash

I vaguely remember having this problem once a long while back (with something else in indigo) and there was a button I pressed to fix it but I sure can’t find one now - I opened the security panel expecting to see something today but no joy.

I hope stupid apple has not decided they know better than me - they have been doing that to me since the 80s — somehow it seems to be getting worse as time goes on.

_______
Norm

Posted on
Sat Jan 14, 2023 8:13 pm
veritas offline
Posts: 16
Joined: Dec 04, 2016

Re: Cynical Weather v3.5.1 Crash

I wanted to use the plugin to display the weather state in my control pages and several triggers bound to that state.
Can you suggest me another solution?
I can't use NOAA because I live in Europe.

Posted on
Sun Jan 15, 2023 9:01 am
norcoscia offline
User avatar
Posts: 1151
Joined: Sep 09, 2015

Re: Cynical Weather v3.5.1 Crash

As a follow up this AM I went back and tried again - noticed there was a security placeholder for the Airfoil Pro to be allowed - I have that plugin disabled so I never allowed it - turns out that the Cynical Weather plugin alert was (I guess) in a queue and never surfaced until I allowed the Airfoil pro plugin to install.

Anyway, long story it is working — so thanks Perry - if I see anything funky I’ll report in a new thread for v3.5.2

_______
Norm

Posted on
Sun Jan 15, 2023 12:55 pm
Perry The Cynic offline
Posts: 823
Joined: Apr 07, 2008

Re: Cynical Weather v3.5.1 Crash

Sigh. I've completely regenerated the embedded pyOpenSSL from scratch (updating it to the newest version on the way) -> 3.5.3. Let me know if it improves things for you.

There were some recent discussions on the Interwebs about how recent Python changes messed pyOpenSSL up for some people. That shouldn't matter given that Indigo brings its own hermetic Python environment, but perhaps that's leaky in some interesting ways. I'm running out of things to try here.

Advance warning: I'm about to go off to NYC for a week (business, not pleasure...), so good or bad, I'll be offline for a bit.

Cheers
-- perry

Posted on
Fri Jan 20, 2023 8:12 pm
t-star offline
Posts: 98
Joined: Oct 26, 2007

Re: Cynical Weather v3.5.1 Crash

I was having the "New user issue". i tried the two scripts listed above (added below for convenience) and it seemed to fix the issue for me. Woohoo!!

Code: Select all
sudo pip3 install pyOpenSSL --upgrade
sudo pip3 install cryptography --upgrade


using 3.5.1

Posted on
Mon Jan 23, 2023 2:17 pm
veritas offline
Posts: 16
Joined: Dec 04, 2016

Re: Cynical Weather v3.5.1 Crash

I downloaded the latest version 3.5.3 and I get the same error as before.
I have uninstalled and reinstalled the plugin but nothing changes.
Any ideas?

Who is online

Users browsing this forum: No registered users and 1 guest