Cannot discover Nanoleaf Aurora

Posted on
Sat Dec 01, 2018 2:30 pm
az138 offline
Posts: 11
Joined: Apr 06, 2016

Cannot discover Nanoleaf Aurora

Hi,

I've installed the plugin, but cannot get it to discover my nanoleaf device. This is the error I am getting:

Code: Select all
Dec 1, 2018 at 1:16:20 PM
   Disabling plugin "Nanoleaf 1.1.0"
   Stopping plugin "Nanoleaf 1.1.0" (pid 815)
   Nanoleaf                        Autolog 'Nanoleaf V1 Controller' Plugin shutdown requested
   Nanoleaf                        Autolog 'Nanoleaf V1 Controller'  Plugin shutdown complete
   Stopped plugin "Nanoleaf 1.1.0"
   Enabling plugin "Nanoleaf 1.1.0"
   Starting plugin "Nanoleaf 1.1.0" (pid 817)
   Nanoleaf                        Autolog 'Nanoleaf V1 Controller' initializing . . .
   Nanoleaf                        No monitoring or debugging requested
   Nanoleaf                        No monitoring or debugging requested
   Started plugin "Nanoleaf 1.1.0"
   Nanoleaf                        Initialising to poll at 300 second intervals
   Nanoleaf                        Autolog 'Nanoleaf V1 Controller' initialization complete
   Nanoleaf                        Autolog 'Nanoleaf V1 Controller' checking for Plugin update
   Nanoleaf                        Discovering nanoleaf devices on network - this should take ~30.0 seconds . . .
   Nanoleaf                        Checking for updates...
   Nanoleaf                        No updates are available
   Nanoleaf                        Autolog 'Nanoleaf V1 Controller' next update check scheduled for: Sunday, 2018-Dec-02 at 13:16

Dec 1, 2018 at 1:17:01 PM
   Nanoleaf Error                  Discovering nanoleaf devices failed to find any nanoleaf devices. Make sure nanoleaf is switched on, has been connected to network and is accessible from nanoleaf App


- My Nanoleaf device is on
- I can access my Nanoleaf device through the IOS app without any problems
- Nanoleaf IP: 192.168.7.70
- Model #: NL22
- Firmware version: 3.0.5
- Hardware version: 1.6.2
- sudo lsof -i :1900 shows nothing running in port 1900

My plugin options under configuration is:
- Override Host IP Address not checked (though I have tried it with the Indigo server IP
- Enable polling checked
- Polling interval every 5 minutes
- Max polls missed is 1
- Discovery timeout 30 (I have tried changing this to 300 also, but still no discovery)

Posted on
Sat Dec 01, 2018 4:49 pm
autolog offline
Posts: 2461
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+0]

Re: Cannot discover Nanoleaf Aurora

I have just checked my system and it is working OK with same hardware level but 3.0.3 firmware.
Can you try configuring the IP address (again), saving and then reloading the plugin - try reloading a couple of times if it doesn't work.

Also, check that you haven't got a firewall running that could prevent communication.

I will try and get my firmware updated to the same level as your Nanoleaf tomorrow and check it out for you. :)

Posted on
Mon Dec 03, 2018 4:25 am
autolog offline
Posts: 2461
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+0]

Re: Cannot discover Nanoleaf Aurora

I have updated to firmware 3.0.5 and all is working as expected. :)

Posted on
Tue Dec 04, 2018 11:19 am
az138 offline
Posts: 11
Joined: Apr 06, 2016

Re: Cannot discover Nanoleaf Aurora

I figured out what was causing this and it now works.

I am using the eero wireless mesh system in my home, and each eero unit is wired back to the main controller. I suspect that the discovery of the nanoleaf panels uses some type of broadcast packet that wasn't going between the eero devices. To fix it, I simply powered down all of the eero devices except for the main gateway which forced every device to connect to the gateway directly. The plugin was then able to find the nanoleaf without any problems. After authorization I powered up the eeros, and now that the plugin knows the IP address of the nanoleaf everything works fine.

Thanks for your help!

Posted on
Tue Dec 04, 2018 11:50 am
autolog offline
Posts: 2461
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+0]

Re: Cannot discover Nanoleaf Aurora

Thanks for the update and glad you have got it working. :)

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest