UnicodeEncodeError: 'ascii' codec can't encode characters

Posted on
Fri Dec 30, 2016 9:34 am
yassi offline
Posts: 443
Joined: Sep 06, 2015
Location: Germany

UnicodeEncodeError: 'ascii' codec can't encode characters

HI jheddings,

I have to write here, because the other subforums are locked.

It seems so, the plugin has an issue with the "umlauts" characters when in the title or in the message field:
Code: Select all
Prowl Error                     Error in plugin execution ExecuteAction:

Traceback (most recent call last):
  File "plugin.py", line 97, in notify
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib.py", line 1347, in urlencode
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-5: ordinal not in range(128)


Can you have a look please, when you have the time?

Thanks,
Yassi
Attachments
Bildschirmfoto 2016-12-30 um 16.34.04.png
Bildschirmfoto 2016-12-30 um 16.34.04.png (142.89 KiB) Viewed 1155 times

Posted on
Fri Dec 30, 2016 10:02 pm
jheddings offline
User avatar
Posts: 141
Joined: Dec 01, 2013
Location: Denver, CO

Re: UnicodeEncodeError: 'ascii' codec can't encode character

Yikes... I will definitely try that out and get back to you with a fix to test soon. I'm hoping it is a quick fix based on the encoding I'm using in the plugin. Be back to you shortly.

Posted on
Sat Dec 31, 2016 4:32 am
yassi offline
Posts: 443
Joined: Sep 06, 2015
Location: Germany

Re: UnicodeEncodeError: 'ascii' codec can't encode character

Ok, thanks for looking into it!

Yassi

Posted on
Sat Dec 31, 2016 9:25 am
jheddings offline
User avatar
Posts: 141
Joined: Dec 01, 2013
Location: Denver, CO

Re: UnicodeEncodeError: 'ascii' codec can't encode character

I have a version ready for you to test (download link below)... I was able to reproduce the issue on my end and this seems to take care of it. Please let me know if it resolves the problem for you as well. If you confirm that it fixes the issue, I'll release the new version after running a few more tests.

NOTE this (and all future) version only works with Indigo 7.

Download Here

Posted on
Sat Dec 31, 2016 10:55 am
yassi offline
Posts: 443
Joined: Sep 06, 2015
Location: Germany

Re: UnicodeEncodeError: 'ascii' codec can't encode character

Great!

It's working, was able to send "umlauts" in the title as well in the message body!

Thank you very much!!!

Yassi

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest

cron