Upgrade to Mojave -- Twisted requires zope.interface

Posted on
Sat Nov 17, 2018 12:34 pm
Ramias offline
Posts: 158
Joined: Nov 24, 2015

Upgrade to Mojave -- Twisted requires zope.interface

Plugin failing after upgrade to Mojave.

Getting:

Hikvision Error Error in plugin execution InitializeMain:

Traceback (most recent call last):
File "plugin.py", line 1, in <module>
File "/Library/Application Support/Perceptive Automation/Indigo 7.2/Plugins/Hikvision.indigoPlugin/Contents/Server Plugin/Hikvision.py", line 24, in <module>
File "./lib/twisted/__init__.py", line 53, in <module>
File "./lib/twisted/__init__.py", line 37, in _checkRequirements
ImportError: Twisted requires zope.interface 3.6.0 or later: no module named zope.interface.


I fixed it by copying the "zope_4.4.2" from the Sonos plugin and creating a symlink called "zope" to it. In case this helps anybody else. Not sure why this worked pre-Mojave but not post.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest