Phidgets Plugin Discussion

Posted on
Wed Dec 26, 2012 1:14 am
ckeyes888 offline
Posts: 2177
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Phidgets Plugin

The only thing showing in either the General or Bonjour tabs is the 2/2/2 Interface.
Don't see the light sensor. Odd that a few minutes ago when I double clicked the
interface in the General tab it opened the Phidgets app and showed the light sensor info
and values. Now it shows nothing.

Maybe post some screen shots?

Thanks,

Carl

Posted on
Wed Dec 26, 2012 2:20 am
berkinet offline
User avatar
Posts: 3402
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin

Sensors attached to a Phidget controller do not appear separately in the Phidgets preference panel app. They just appear as a value on the appropriate input. However, in Indigo, the plugin allows you to to create a separate device to represent sensors as well as digital inputs and outputs.

The Indigo device is updated automatically every time the sensor value changes. The change is actually broadcast by the 2/2/2 controller.

If you are still having problems please post a screen shot of the 2/2/2 preference pane and the Indigo device window with the sensor device and interface kit device visible.

Posted on
Wed Dec 26, 2012 9:52 am
ckeyes888 offline
Posts: 2177
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Phidgets Plugin

Hope any of this helps, and I really appreciate all the help!

Carl
Attachments
image.jpg
image.jpg (77.21 KiB) Viewed 4311 times
image.jpg
image.jpg (87.23 KiB) Viewed 4311 times
image.jpg
image.jpg (97.33 KiB) Viewed 4311 times
image.jpg
image.jpg (52.83 KiB) Viewed 4311 times
image.jpg
image.jpg (148.24 KiB) Viewed 4311 times

Posted on
Wed Dec 26, 2012 10:10 am
berkinet offline
User avatar
Posts: 3402
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin

Carl, I will contact you off-line.

Posted on
Wed Dec 26, 2012 12:25 pm
ckeyes888 offline
Posts: 2177
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Phidgets Plugin

Thanks again for all your help getting it working.

Doubt it has anything to do with the plugin, as I see the same results
in the Phidgets app, but it seems to update very sporadically if at all.
Unplugging the interface and sensor didn't help.
Have to have a look at the phidgets forum.

Carl

Posted on
Wed Dec 26, 2012 1:45 pm
berkinet offline
User avatar
Posts: 3402
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin

The frequency of the updates is a function of the Sensor Trigger Threshold (Sensitivity) and Data Rate settings in the InterfaceKit device. The Data Rate setting controls the frequency at which the interfaceKit scans for changes. When using the web service this is locked at 16 times per second. The Trigger Threshold sets the minimum change in the raw sensor value (0-1000) that is required for the new value to be reported. (See the Phidgets Analog Input Primer for more information).

If you set the Trigger threshold too high for the 1127 light sensor, you will only see significant changes in light level. For example if you set it to 500 you will effectively only see one transition between total darkness and absolute brightness.

If you are seeing the same values in the Phidgets device you created and in the Pref pane for the interfaceKit, then, as you guessed, the plugin is operating properly. Note, there is a sensitivity setting in the preference pane. But, the plugin will override that setting, so you need to adjust the sensitivity setting in the Indigo interfaceKit device.

Posted on
Wed Dec 26, 2012 1:51 pm
ckeyes888 offline
Posts: 2177
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Phidgets Plugin

Thanks. I'm using the default settings for the interface device.
I'm logging it's changes to have a better idea of what's happening.
Maybe a pattern will develop.

Carl

Posted on
Thu Dec 27, 2012 12:26 pm
ckeyes888 offline
Posts: 2177
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Phidgets Plugin

Seems I have a couple things going on with the sensor. Sometimes, no pattern to it, it will just stop reporting as seen in the Phigets app, and sometimes
it will be reporting there and the plugin doesn't see the change.

Unpluging the interface seems to reset it ok or reloading the plugin when it not seeing changes works as well.
Noticed also that hitting it with a bright light will sometimes wake it up, but might get stuck at the bright value
and not return to it's original value.

Anyone else seeing anything like this?

Thanks,

Carl

Posted on
Thu Dec 27, 2012 1:45 pm
berkinet offline
User avatar
Posts: 3402
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin

When using the Phidgets app, are you sure you are opening the interfaceKit from the Bonjour tab? The behavior you report is consistent with opening the if kit from the general tab.

Posted on
Thu Dec 27, 2012 3:48 pm
ckeyes888 offline
Posts: 2177
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Phidgets Plugin

Definitely using the Bonjour tab. For some reason it's working a bit better today.

Thanks,

Carl

Posted on
Sat Dec 29, 2012 12:42 pm
ckeyes888 offline
Posts: 2177
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Phidgets Plugin

I have no explanation for it but it has been working very well since my last post.
A very similar thing happened when I first installed the W800F32 interface.
I was about to send it back having lots of problems with range, missing inputs etc.,
but after a day or two it became rock solid.

My go figure dept. is getting quite full.

Thanks,

Carl

Posted on
Mon Dec 31, 2012 11:51 am
ckeyes888 offline
Posts: 2177
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Phidgets Plugin

Curious if setting the threshold settings to 5 should force the sensor to report in 5 point
increments? I had it set to 10 and it did move in 10 point increments and tried it
at 5 but t still only changes in 10 point increments.

Thanks,

Carl

Posted on
Mon Dec 31, 2012 1:00 pm
berkinet offline
User avatar
Posts: 3402
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin

When you look at the reported sensor values from the Phidgets 2/2/2 preference pane what increments do you see? What is the sensitivity setting on the pref pane?

Posted on
Mon Dec 31, 2012 4:54 pm
ckeyes888 offline
Posts: 2177
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Phidgets Plugin

The Phidgets app is changing in increments of 10 as well.
The sensitivity there is set to 10.

Thanks,

Carl

Posted on
Mon Dec 31, 2012 5:07 pm
berkinet offline
User avatar
Posts: 3402
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin

Try setting the pref pane app sensitivity to 5 and see if that works.

Page 4 of 35 1, 2, 3, 4, 5, 6, 7 ... 35

Who is online

Users browsing this forum: No registered users and 1 guest