Phidgets Plugin Discussion

Posted on
Mon Jan 18, 2016 7:48 pm
berkinet offline
User avatar
Posts: 3114
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

UrbanFarmer wrote:
I think I've found it under "Phidget Stand Alone Device" - "PhidgetTemperatureSensor 4 Input"
Glad you figured it out. Let us know how you use it.

Posted on
Sun Jan 24, 2016 8:07 pm
UrbanFarmer offline
Posts: 13
Joined: Nov 16, 2012

Re: Phidgets Plugin Discussion

I have wired up a pressure sensor to analogue input number three on my SBC-3.

The pressure sensor puts out 0-10vdc so I used a 10K ohm two to one voltage divider on the SBC-3 input to get 0-5 vdc.

I am trying to set up a 0999C generic sensor custom formula but I don't know what the syntax is for the formula. I need to convert the 0 to 5 volt input to 0 to 30 psi read out.

Thank you,

Oliver

Posted on
Mon Jan 25, 2016 2:01 am
UrbanFarmer offline
Posts: 13
Joined: Nov 16, 2012

Re: Phidgets Plugin Discussion

I'm using x/33 and it seems to be working, but I have yet to thread in the pressure sensor into the pipe that has between 5 and 10 PSI. I have to shut down my system to do that.

Still would like to know if that is the right formula.

The problem I was having was solved by reloading the phidgets plugin a second time.

Oliver

Posted on
Mon Jan 25, 2016 12:37 pm
berkinet offline
User avatar
Posts: 3114
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

UrbanFarmer wrote:
I'm using x/33 and it seems to be working, but I have yet to thread in the pressure sensor into the pipe that has between 5 and 10 PSI. I have to shut down my system to do that.

Still would like to know if that is the right formula.

The problem I was having was solved by reloading the phidgets plugin a second time.
First, a description of the formula syntax for the 0999C is in this post. As to whether that is the correct formula... the input to the formula is the output from the InterfaceKit - a value from 0 to 1000. Where 0=0volts=0psi and 1000=5volts=30psi. Therefore each value point = 0.03psi (30/1000). So I would think something like x*0.03 is what you want.

Posted on
Fri Jan 29, 2016 12:10 pm
4billl offline
Posts: 50
Joined: Jan 30, 2013
Location: Dripping Springs TX

Re: Phidgets Plugin Discussion

Is it possible to configure a 1204 LCD interface as a USB device? (The 1204 is controlling a 3655 4x40 LCD display) It works fine if connected via Network, plugged into an SBC. But when I try to connect directly to a USB port, the serial port never appears.
Currently I am trying to change the interface of an existing device. Deleting it would be a major rewrite. But I have disabled all the triggers that affect the LCD.
I have gone as far as restarting the entire system with the triggers disabled and the LCD interface unplugged. But when plug it directly into a USB port and try to assign a USB serial port, no new port ever shows up.

Posted on
Fri Jan 29, 2016 4:07 pm
4billl offline
Posts: 50
Joined: Jan 30, 2013
Location: Dripping Springs TX

Re: Phidgets Plugin Discussion

I tried adding another new LCD directly to a USB port (a different kit & LCD serial number) . The Phidgets service in Systems Preferences can see the new (additional) LCD 1204/3655 and can even control and initialize it. And I can control the backlight. When I try to add a standalone Phidgets device, I can chose Configure Phidget LCD Screen Device, put in the Interface kit number, Select Local USB Port, but there is still no new USB serial port number.

Posted on
Fri Jan 29, 2016 4:29 pm
berkinet offline
User avatar
Posts: 3114
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

4billl wrote:
I tried adding another new LCD directly to a USB port (a different kit & LCD serial number) . The Phidgets service in Systems Preferences can see the new (additional) LCD 1204/3655 and can even control and initialize it. And I can control the backlight. When I try to add a standalone Phidgets device, I can chose Configure Phidget LCD Screen Device, put in the Interface kit number, Select Local USB Port, but there is still no new USB serial port number.
You really should start the Phidgets Web service on the local machine (Phidgets Pref Pane) and then connect to the Phidget at the local address, 127.0.0.1. I think you will find that works much better and will still allow you to use the Phidgets Prefs pane Bonjour tab to access the display.

Posted on
Sun Jan 31, 2016 12:56 pm
hamw offline
Posts: 1117
Joined: Mar 31, 2008

Re: Phidgets Plugin Discussion

How are you all using the LCD display? I'd thought it did not offer much advantage over the Indigo control page info.

Posted on
Sun Jan 31, 2016 1:03 pm
4billl offline
Posts: 50
Joined: Jan 30, 2013
Location: Dripping Springs TX

Re: Phidgets Plugin Discussion

Even with the web service started and using the local address 127.0.0.1, I still get
Phidgets Plugin Error textLCD Exception (textLCD Error) 5: Phidget not physically attached.
(I can see and operate the LCD from the Sys Pref - Phidgets service.)

I am trying to just send status information (such as water tank levels) to display on the LCD without having to attach it to an SBC..

Posted on
Sun Jan 31, 2016 9:55 pm
berkinet offline
User avatar
Posts: 3114
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

4billl wrote:
Even with the web service started and using the local address 127.0.0.1, I still get
Phidgets Plugin Error textLCD Exception (textLCD Error) 5: Phidget not physically attached.
(I can see and operate the LCD from the Sys Pref - Phidgets service.)

I am trying to just send status information (such as water tank levels) to display on the LCD without having to attach it to an SBC..

If you have the Phidget open in the phifpdget pref one, it will not work anywhere else. Open it up in the bonjour pane instead.

Posted on
Sun Jan 31, 2016 10:38 pm
4billl offline
Posts: 50
Joined: Jan 30, 2013
Location: Dripping Springs TX

Re: Phidgets Plugin Discussion

It never shows up in the Bonjour pane.

Posted on
Sun Jan 31, 2016 11:14 pm
berkinet offline
User avatar
Posts: 3114
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

4billl wrote:
It never shows up in the Bonjour pane.

You must turn on the Phidgets web-service on the machine it is plugged into.

Posted on
Mon Feb 01, 2016 1:16 am
4billl offline
Posts: 50
Joined: Jan 30, 2013
Location: Dripping Springs TX

Re: Phidgets Plugin Discussion

After starting webservice in the Phidgets Webservice pane, it shows it is running.
The LCD is not included in the Bonjour pane, but it shows up in General and Labels.

Posted on
Mon Feb 01, 2016 10:50 am
berkinet offline
User avatar
Posts: 3114
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

4billl wrote:
After starting webservice in the Phidgets Webservice pane, it shows it is running.
The LCD is not included in the Bonjour pane, but it shows up in General and Labels.

If the display controller is plugged into your local Mac and you have the web-service turned on, and the controller is not open in the general pane of the Phidgets pref, and still does not appear in the bonjour tab... Something is wrong.

First, make sure the Phidgets driver is up to date and then I think you should contact Phidgets.

Posted on
Sun Jun 05, 2016 4:25 pm
Yves1922 offline
Posts: 14
Joined: Oct 26, 2011
Location: Plaisance, Québec

8/8/8 board error

i just installed El Captain and now have a fidget error . might just be a coincidence ;-(






tarted plugin "Phidgets Plugin 0.6.5"
Phidgets Plugin Plugin Startup.
Phidgets Plugin Your plugin version, v0.6.5, is current.
Phidgets Plugin exiting deviceStartComm with:[<_MainThread(MainThread, started -1556692992)>, <ifkit(Thread-1, started -1338380288)>]
Phidgets Plugin exiting deviceStartComm with:[<_MainThread(MainThread, started -1556692992)>, <ifkit(Thread-1, started -1338380288)>, <tempsensor(Thread-2, started -1336782848)>]
Phidgets Plugin exiting deviceStartComm with:[<_MainThread(MainThread, started -1556692992)>, <ifkit(Thread-1, started -1338380288)>, <tempsensor(Thread-2, started -1336782848)>]
Phidgets Plugin exiting deviceStartComm with:[<_MainThread(MainThread, started -1556692992)>, <ifkit(Thread-1, started -1338380288)>, <tempsensor(Thread-2, started -1336782848)>]
Phidgets Plugin exiting deviceStartComm with:[<_MainThread(MainThread, started -1556692992)>, <ifkit(Thread-1, started -1338380288)>, <tempsensor(Thread-2, started -1336782848)>]
Phidgets Plugin Error interfaceKit: Wait for Attach time exceeded for device Phidget 1019 (Hub)
Phidgets Plugin Error interfaceKit: Will continue waiting for 15 minutes
Phidgets Plugin Error TempSensor: Wait for Attach time exceeded for device phidgets-Temperature
Phidgets Plugin Error TempSensor: Will continue waiting for 15 minutes

Page 25 of 31 1 ... 22, 23, 24, 25, 26, 27, 28 ... 31

Who is online

Users browsing this forum: No registered users and 1 guest