ad2usb plugin discussion

Posted on
Sun Nov 08, 2020 12:40 pm
hamw offline
Posts: 1214
Joined: Mar 31, 2008

Re: ad2usb plugin discussion

After a lot of trial and error, it turns out that i had to install a fresh copy of the plugin. The old plugin, which was working with the 20SE board, would not accept the changes for the 20p and hold them. So for instance I set to keypad 23, but the plugin was constantly resetting to 31. After I finally guessed the problem, deleted the plugin and installed a fresh version, everything is working as expected.

Hope this may help someone else. Any ideas why the plugin would be "sticky"?

On another topic, I have set different codes for the alarm, so the workers use XXXX, and the family uses YYYY. In the documentation it states that we can log arming events to the user code. How do I implement that?

Posted on
Mon Nov 09, 2020 6:12 am
berkinet offline
User avatar
Posts: 3427
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: ad2usb plugin discussion

hamw wrote:
After a lot of trial and error, it turns out that i had to install a fresh copy of the plugin. ...
...Hope this may help someone else. Any ideas why the plugin would be "sticky"?

...On another topic, I have set different codes for the alarm, so the workers use XXXX, and the family uses YYYY. In the documentation, it states that we can log arming events to the user code. How do I implement that?
Glad to hear you fixed it. It sounds like the installed copy of the plugin somehow became corrupted. That is usually a sign of disk issues.

I would love to answer your second question. But, as I am not at the relocation where I am running the plugin, and for the moment cannot even access it, I really can't give you the answer to your question. Did you search through the release posts on this thread? I have usually documented such changes. If you don't find anything, I will look at the code to see what I can.

Posted on
Wed Nov 11, 2020 2:31 pm
roquej offline
User avatar
Posts: 445
Joined: Jan 04, 2015

ad2usb plugin discussion

I have encountered an interesting problem. I have a Vista 20P. It has been connected to AD2PI for several years without an issue. One of the zones is the garage door. I created a trigger that executes when the zone goes to FAULT. However, when the trigger executes, I get:

AD2USB Alarm Interface Error advancedReadZoneMessage: Unable to update state table for zone 04, address 18.

When it happens, the zone loses its state, and the trigger fails. Again, it triggers but causes the zone to go haywire and the actions fail. I have tried using the masquerade plugin but got the same behavior.

Any suggestions?

Thanks in advance.

JP

Posted on
Sun Jan 17, 2021 11:29 pm
classicmac offline
Posts: 9
Joined: Jan 09, 2007

Re: ad2usb plugin discussion

I have a AD2USB set up with ser2sock and the ad2usb plugin. First of all thanks for all of your work on this plugin. It is exactly what I was looking for.

The only issue I'm having is that I periodically get error messages in my Indigo logs.

Code: Select all
   AD2USB Alarm Interface Error    Error on line 791
   AD2USB Alarm Interface Error    panelMsgRead: Error: list.remove(x): x not in list

I have tried turning debugs up to intense debugs but it doesn't provide information related to those errors. When debugs are set to intense I do get these lines logged. I'm guessing they aren't the cause of the errors because the errors don't show up when those lines are logged.

Code: Select all
 AD2USB Alarm Interface Debug    calling basic
 AD2USB Alarm Interface Debug    Zone:8, Key:****D

Anyone have ideas on how to figure out what is causing the errors?

Some additional information. I have a Vista 20P with 2 partitions. My first partition has my security zones. The second I don't arm and has motion sensors I use to alert me when there is motion around the exterior of my home. Please let me know if any other information would be helpful in diagnosing the errors.

Posted on
Tue Jun 01, 2021 6:20 pm
jltnol offline
Posts: 625
Joined: Oct 15, 2013

Re: ad2usb plugin discussion

Not sure if this is allowed here, but if anyone needs a NuTech AD2USB devices, send me a PM. I have a brand new one for sale. <Hope I'm not breaking any forum rules>

Posted on
Fri Jun 11, 2021 8:15 am
7rdr7 offline
Posts: 77
Joined: Aug 16, 2017
Location: Washington DC Metro

Re: ad2usb plugin discussion

Hey Guys,
Has anyone seen errors like this?
AD2USB Alarm Interface Error panelMsgRead: Error: invalid literal for int() with base 10: '0bf'
AD2USB Alarm Interface Error Error on line 733
AD2USB Alarm Interface Error panelMsgRead: Error: invalid literal for int() with base 10: '0bf'
AD2USB Alarm Interface Error Error on line 733
AD2USB Alarm Interface Error panelMsgRead: Error: invalid literal for int() with base 10: '0bf'
AD2USB Alarm Interface Error Error on line 733
AD2USB Alarm Interface Error panelMsgRead: Error: invalid literal for int() with base 10: '0bf'
AD2USB Alarm Interface Error Error on line 733
AD2USB Alarm Interface Error panelMsgRead: Error: invalid literal for int() with base 10: '0bf'
AD2USB Alarm Interface Error Error on line 733
AD2USB Alarm Interface Error panelMsgRead: Error: invalid literal for int() with base 10: '0bf'
AD2USB Alarm Interface Error Error on line 733
AD2USB Alarm Interface Error panelMsgRead: Error: invalid literal for int() with base 10: '0bf'
AD2USB Alarm Interface Error Error on line 733
Periodically I'll get a few hundred of these errors. It goes away if I power cycle the AD2PI module. It seems to cause/effect LRR alarms on my Vista21IP panel.
Would appreciate any ideas?
Thanks.

Who is online

Users browsing this forum: No registered users and 1 guest