Problems with x axis

Posted on
Mon May 20, 2019 12:24 pm
norcoscia offline
User avatar
Posts: 845
Joined: Sep 09, 2015

Problems with x axis

Tried everything I can think of but cannot get the grid to work right - works fine on other charts but not this one - it only makes the first one. Any ideas. BTW, the CVS part does a sample every 2 seconds so not sure it that is a problem somehow.... There should be several hours on this chart.
Attachments
2019-05-20_11-21-08.jpeg
2019-05-20_11-21-08.jpeg (73.61 KiB) Viewed 253 times
2019-05-20_11-22-01.jpeg
2019-05-20_11-22-01.jpeg (90.45 KiB) Viewed 253 times

_______
Norm

Posted on
Mon May 20, 2019 12:56 pm
DaveL17 offline
User avatar
Posts: 4997
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Problems with x axis

Hi Norm - if I understand what you're trying to accomplish, that would mean that the chart would be trying to display 1,800 observations per hour (30 observations per minute x 60 minutes per hour.) Without seeing the underlying data, I can't know for sure whether the plot isn't rendering as intended. If your CSV file is limited to 1,800 observations or less, you'd only get one hour (or less).

You could try setting the X axis bins to 'Every 15 Minutes" and see if that plots more bins.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Mon May 20, 2019 2:35 pm
norcoscia offline
User avatar
Posts: 845
Joined: Sep 09, 2015

Re: Problems with x axis

This is how the CSV engine is set up - the problem is I expect to see 900, 1000 and 1100 o'clock on the bottom of the chart and it is only displaying 0800 - see red arrows. I have tried changing the interval restarting the plug-in and turning on and off about every setting - no change only see 0800
Attachments
2019-05-20_11-21-08.jpeg
2019-05-20_11-21-08.jpeg (81.52 KiB) Viewed 226 times
2019-05-20_13-31-57.jpeg
2019-05-20_13-31-57.jpeg (108.06 KiB) Viewed 226 times

_______
Norm

Posted on
Mon May 20, 2019 2:36 pm
norcoscia offline
User avatar
Posts: 845
Joined: Sep 09, 2015

Re: Problems with x axis

Odd I just looked again now it shows 0900 and 1300 - I must not be understanding something :-(

PS. You can see my cloths drying on and then cycling to maintain the correct temp - pretty cool!
Attachments
2019-05-20_13-35-37.jpeg
2019-05-20_13-35-37.jpeg (88.97 KiB) Viewed 222 times

_______
Norm

Posted on
Mon May 20, 2019 4:04 pm
DaveL17 offline
User avatar
Posts: 4997
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Problems with x axis

Hi Norm - I assume that you're expecting to see a tick mark placed at ever hour interval. In this case, Matplotlib *is* plotting hourly bins, but it's also the one deciding where to place the tick marks at the time the chart is drawn. Matplotlib is super picky when plotting time series data and there may be something that I can do to force it to display the way you expect.

I'll need to do a bit more digging.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Mon May 20, 2019 6:04 pm
DaveL17 offline
User avatar
Posts: 4997
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Problems with x axis

Turns out that the default interval for the hourly bin setting is set to four hours. I now remember selecting that interval to hopefully keep the tick labels from overlapping when hourly bins were selected.

I'll put some additional options into the plugin for the interval setting to provide more choices in the next update.

EDIT: Scratch all that, it was a bug. Will be fixed in the next update.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Tue May 21, 2019 6:03 am
norcoscia offline
User avatar
Posts: 845
Joined: Sep 09, 2015

Re: Problems with x axis

Thanks!!!!

_______
Norm

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest