MyQ Login failures starting at 1:37PM CDT

Posted on
Thu May 02, 2019 6:12 am
FlyingDiver offline
Posts: 3436
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ Login failures starting at 1:37PM CDT

DaveL17 wrote:
FlyingDiver wrote:
How many MyQ devices do you have? And do you already have Indigo devices created for them?

Uno.

The single device is the same one that was working fine (as far as I know) under 7.3.0 until the recent API change.


You didn't answer the second question. If you have one opener, and already have an Indigo device for it, what do you expect to see in that popup? There's no other MyQ device for you to select. Yeah. maybe it should show the current device. But it's still referencing the opener you have.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu May 02, 2019 6:18 am
DaveL17 offline
User avatar
Posts: 4997
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: MyQ Login failures starting at 1:37PM CDT

FlyingDiver wrote:
You didn't answer the second question.

That's what I meant by saying that the "single device is the same one"--it's created and has been for a long time.

FlyingDiver wrote:
If you have one opener, and already have an Indigo device for it, what do you expect to see in that popup? There's no other MyQ device for you to select. Yeah. maybe it should show the current device. But it's still referencing the opener you have.

That's the bit I was missing. Under the config dialog, I'd expect to see the list of available devices (even if there's only one) and the current opener device listed if it's configured. That clears up my confusion. Thanks!

Feature request: show the configured opener device in the device config dialog. :D

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Thu May 02, 2019 6:18 am
DaveL17 offline
User avatar
Posts: 4997
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: MyQ Login failures starting at 1:37PM CDT

And by the way, thanks as always for the great plugin!

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Thu May 02, 2019 6:19 am
FlyingDiver offline
Posts: 3436
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ Login failures starting at 1:37PM CDT

DaveL17 wrote:
Feature request: show the configured opener device in the device config dialog. :D


Put it in GitHub. :D

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu May 02, 2019 6:23 am
DaveL17 offline
User avatar
Posts: 4997
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: MyQ Login failures starting at 1:37PM CDT

Done.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Thu May 02, 2019 4:43 pm
mswall offline
Posts: 26
Joined: Jan 23, 2009

Re: MyQ Login failures starting at 1:37PM CDT

Upgrade to 732 - getting python errors. Created new devices for our two chamberlain doors - does not show them in the popup menu list in configure. Seems to accept the login (dialog auto-dismisses), but something seems to be sick still.

Traceback (most recent call last):
File "plugin.py", line 86, in runConcurrentThread
File "plugin.py", line 429, in getDevices
ValueError: invalid literal for int() with base 10: ''

Posted on
Thu May 02, 2019 4:53 pm
FlyingDiver offline
Posts: 3436
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ Login failures starting at 1:37PM CDT

mswall wrote:
Upgrade to 732 - getting python errors. Created new devices for our two chamberlain doors - does not show them in the popup menu list in configure. Seems to accept the login (dialog auto-dismisses), but something seems to be sick still.

Traceback (most recent call last):
File "plugin.py", line 86, in runConcurrentThread
File "plugin.py", line 429, in getDevices
ValueError: invalid literal for int() with base 10: ''


Please turn on debug logging and restart the plugin, then post.

I tested creating devices from scratch, so I'm not sure what's going on there.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu May 02, 2019 4:58 pm
mswall offline
Posts: 26
Joined: Jan 23, 2009

Re: MyQ Login failures starting at 1:37PM CDT

joe - sorry jumped the gun. I deleted my old devices (chamberlain door devices) then reloaded 732, logged in, then when I created the new devices, the Chamberlain.com names for my doors were there. seems to be working and the py errors are gone. thanks for your efforts.

Posted on
Wed Jun 19, 2019 10:39 am
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: MyQ Login failures starting at 1:37PM CDT

Wasn't working this morning. I checked to make sure I wasn't in VPN, sometimes it doesn't like the VPN server I'm on. Did a reload of the plugin and comes up with this error

Starting MyQ
MyQ Error myqLogin failure, RequestException: [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:590)

Are there some changes with the API?

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Wed Jun 19, 2019 10:55 am
FlyingDiver offline
Posts: 3436
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ Login failures starting at 1:37PM CDT

colovin wrote:
Wasn't working this morning. I checked to make sure I wasn't in VPN, sometimes it doesn't like the VPN server I'm on. Did a reload of the plugin and comes up with this error

Starting MyQ
MyQ Error myqLogin failure, RequestException: [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:590)

Are there some changes with the API?


What version of MacOS are you running? That looks like the SSL/TLS issue reported for many other web services. Looks like MyQ has upgraded their servers to require the newer version of TLS that requires Mojave or High Sierra.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Jun 19, 2019 11:28 am
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: MyQ Login failures starting at 1:37PM CDT

I thought I was running the latest version which turns out I was running 7.3.1. So I downloaded and updated to 7.3.2 to no avail.

Stopping plugin MyQ (pid 58666)
MyQ Shutting down MyQ
Stopped plugin MyQ
Upgrading plugin MyQ to newer version 7.3.2 (previous version moved to trash)
Loading plugin "MyQ 7.3.2"
Starting plugin "MyQ 7.3.2" (pid 62114)
Started plugin "MyQ 7.3.2"
MyQ Starting MyQ
MyQ Error myqLogin failure, RequestException: [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:590)

My MacOS is Sierra so I'm going to have to update to High Sierra?

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Wed Jun 19, 2019 11:33 am
FlyingDiver offline
Posts: 3436
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ Login failures starting at 1:37PM CDT

colovin wrote:
I thought I was running the latest version which turns out I was running 7.3.1. So I downloaded and updated to 7.3.2 to no avail.

My MacOS is Sierra so I'm going to have to update to High Sierra?


It’s not an Indigo issue. Yes it’s MacOS. You need to upgrade to High Sierra.


Sent from my iPhone using Tapatalk

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Jun 19, 2019 12:00 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: MyQ Login failures starting at 1:37PM CDT

I hate it when that happens. OS updates tend to break more things and impose more nanny state situations than improvements that I use. Hence I'm generally 2 or 3 OS's behind.

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Wed Jun 19, 2019 12:28 pm
FlyingDiver offline
Posts: 3436
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ Login failures starting at 1:37PM CDT

colovin wrote:
I hate it when that happens. OS updates tend to break more things and impose more nanny state situations than improvements that I use. Hence I'm generally 2 or 3 OS's behind.


This issue has been popping up regularly for the last year or so, for a number of plugins that communicate with web services. It's a security issue with the SSL library in the older versions of MacOS.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Fri Jun 21, 2019 10:53 am
eullman offline
Posts: 10
Joined: Dec 12, 2012

Re: MyQ Login failures starting at 1:37PM CDT

Ugh. Looks like this is the thing that is going to get me to upgrade my server. I almost made it 10 years with a Mac mini (Early 2009). That's pretty cool, actually.

Thanks for the guidance on the SSL handshake failure!

Who is online

Users browsing this forum: No registered users and 1 guest