JSON Decode Error

Posted on
Fri Oct 26, 2018 5:50 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

Looks like everything is back to how it was before. It's been working fine.

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Wed Oct 31, 2018 8:59 am
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

The error is back. As luck would have it, I just turned the debugging log off yesterday.

Oct 31, 2018, 7:48:36 AM
Received INSTEON "Garage I/O Fire - Mail" off
Trigger Running
MyQ Error myqLogin failure, JSON Decode Error: <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[4582762944203516256]</body></html>
Received INSTEON "Garage I/O Fire - Mail" on

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Wed Oct 31, 2018 10:01 am
FlyingDiver online
Posts: 3464
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error

colovin wrote:
The error is back. As luck would have it, I just turned the debugging log off yesterday.

Oct 31, 2018, 7:48:36 AM
Received INSTEON "Garage I/O Fire - Mail" off
Trigger Running
MyQ Error myqLogin failure, JSON Decode Error: <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[4582762944203516256]</body></html>
Received INSTEON "Garage I/O Fire - Mail" on


Does that number in the message mean anything to you? I bolded it. That's coming from the MyQ server, not the plugin.

You said previously the mobile app works. Is the phone on your local wifi network when you used it? Or on cell network? See this thread:

https://myqcommunity.chamberlain.com/ch ... fi-network

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Oct 31, 2018 10:47 am
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

No the bolded number does not mean anything to me. I'm sort of the opposite of the provided link. Since my trigger did not open the door I opened it with my cell phone which is on the local wifi network. It is a deactivated phone that I use for running so there is no cellular data available.

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Wed Oct 31, 2018 10:51 am
FlyingDiver online
Posts: 3464
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error

Have you tried the other manufacturer options in the plugin config? It's a long shot, but maybe one of the other configs might work. Other than that, I got nothing else for you.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Oct 31, 2018 11:06 am
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

None of the others worked. They all come up with different numbers.

Oct 31, 2018, 10:03:00 AM
MyQ Debug validatePrefsConfigUi called
MyQ Error myqLogin failure, JSON Decode Error: <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[4582762944228379901]</body></html>

Oct 31, 2018, 10:03:29 AM
MyQ Error myqLogin failure, JSON Decode Error: <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[4582762944217361820]</body></html>
MyQ Error myqLogin failure, JSON Decode Error: <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[4582762944217374732]</body></html>
MyQ Error myqLogin failure, JSON Decode Error: <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[4582762944228431753]</body></html>

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Thu Nov 01, 2018 12:25 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

I believe the problem is that MyQ doesn't like some of the IP address my VPN spits out. I dropped out of VPN and it connected with the server. Left the VPN off this AM and garage door opened as it should. It's not all the VPN IP address but some seem to get rejected. When I'm banking I always drop out of VPN to prevent hassles. While I'm using a Phoenix server and when you use a IP address locator it shows up in Phoenix, when I was having banking issues they said the IP was showing out of Russia. Don't know if there's bouncing going on, but that seems to be the source of the JSON Decode Error. I just need to test the IP address when I change to a different address.

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Thu Nov 01, 2018 12:27 pm
FlyingDiver online
Posts: 3464
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error

colovin wrote:
I believe the problem is that MyQ doesn't like some of the IP address my VPN spits out. I dropped out of VPN and it connected with the server. Left the VPN off this AM and garage door opened as it should. It's not all the VPN IP address but some seem to get rejected. When I'm banking I always drop out of VPN to prevent hassles. While I'm using a Phoenix server and when you use a IP address locator it shows up in Phoenix, when I was having banking issues they said the IP was showing out of Russia. Don't know if there's bouncing going on, but that seems to be the source of the JSON Decode Error. I just need to test the IP address when I change to a different address.


So the problem from that link I posted is the same - your VPN IP is blacklisted on their servers.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Apr 30, 2019 9:31 pm
Vig offline
Posts: 87
Joined: Oct 06, 2015

Re: JSON Decode Error

Getting similar error below. MyQ app on iPhone works fine while connected to the same network with the same public IP seen from outside so it's not blacklisted IP issue. Tried changing password, tested with different brands, no luck.

myqLogin failure, JSON Decode Error: <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[13495076364912072963]</body></html>

Posted on
Tue Apr 30, 2019 9:47 pm
dkillmer offline
Posts: 23
Joined: Feb 23, 2015

Re: JSON Decode Error

This error started showing up in my event log today at 11:42 am pacific.

Who is online

Users browsing this forum: No registered users and 1 guest