JSON Decode Error

Posted on
Mon Oct 22, 2018 11:10 am
colovin offline
Posts: 135
Joined: Oct 27, 2009

JSON Decode Error

I am getting this error all the time in my log

Oct 22, 2018, 10:02:00 AM
WebServer WD Weather Data Updated
MyQ Error myqLogin failure, JSON Decode Error

I have a trigger setup to enable me to open the garage door after the morning run. A number of conditions but ultimately when you open the mail box it opens the garage door. Didn't work for my wife or for me 20 minutes later because of the above error. Has been working well for awhile till now. I guess it polls every 5 minutes because error is showing up in the log every 5 minutes.

Any ideas on how to correct this?

Thanks

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Mon Oct 22, 2018 11:36 am
FlyingDiver offline
Posts: 3437
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error

Set logging to debug in the plugin prefs, then restart the plugin.

If you're still getting the error, post the log info from plugin start to the error.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Oct 22, 2018 12:07 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

It looks like it won't let me save the change to Debugging Messages.

Oct 22, 2018, 10:48:19 AM
MyQ Debug validatePrefsConfigUi called
MyQ Debug logLevel = 10
MyQ Error myqLogin failure, JSON Decode Error
MyQ Debug validatePrefsConfigUi called
MyQ Debug logLevel = 10
MyQ Error myqLogin failure, JSON Decode Error

I've check my login info with the app and it's correct. Reentered it into the plugin config with the same result. I was looking for the log file incase it was showing up. Went to /Library/Application Support/Perceptive Automation/Indigo 7/Logs and there is no folder for MyQ. I suspect a folder isn't formed until debug is successfully saved. Here is a screen shot of the config window.
Attachments
screenshot_85.png
screenshot_85.png (57.42 KiB) Viewed 832 times

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Mon Oct 22, 2018 12:12 pm
FlyingDiver offline
Posts: 3437
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error

What plugin version is this?

The login/password fields are being highlighted because the plugin is unable to login to the MyQ servers with the given data. If this is something that just started happening, then it's possible that MyQ changed the login process. The plugin uses undocumented API calls so there's no warning if they do that.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Oct 22, 2018 12:19 pm
FlyingDiver offline
Posts: 3437
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error

Install this version and try again: https://github.com/FlyingDiver/Indigo-M ... /tag/7.2.1

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Oct 22, 2018 12:43 pm
FlyingDiver offline
Posts: 3437
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error

lanbrown wrote:
Can the OP use the mobile app and the browser based site?


OP wrote "I've check my login info with the app and it's correct." in his second post.

lanbrown wrote:
Maybe it is something unique to Craftsmen since Sears sold the brand and Sears has filed for bankruptcy protection?


Very unlikely at this point. They sold the brand a while back and the bankruptcy is very recent.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Oct 22, 2018 12:48 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

I was at 7.1.10 Prior to installing 7.2.1. I checked the login info via the app. My main phone, I rarely use the app. it was used on my running phone and hasn't been used since using MyQ. Haven't used the app since updating to IOS 12 so I needed to completely log in which I was successful in doing so I know that the login info has not changed. I reentered the login information into the MyQ config page. I have seen the error in my log before. Not every 5 minutes like it is doing now so I guess something must have corrected itself. Today is the first time the system has failed to open the door.

Here is the log entry after the update

Oct 22, 2018, 11:32:54 AM
Stopping plugin MyQ (pid 5346)
MyQ Debug deviceStopComm: Removing Device Garage Door Opener (CG0810197CD1) (1079833865) from MyQ device list
MyQ Shutting down MyQ
Stopped plugin MyQ
Upgrading plugin MyQ to newer version 7.2.1 (previous version moved to trash)
Loading plugin "MyQ 7.2.1"
Starting plugin "MyQ 7.2.1" (pid 15231)
Started plugin "MyQ 7.2.1"
MyQ Starting MyQ
MyQ Error myqLogin failure, JSON Decode Error: <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[12146998511454070733]</body></html>

Here the log entry after re entering the login info again

Oct 22, 2018, 11:39:04 AM
WebServer WD Weather Data Updated
MyQ Debug logLevel = 10
MyQ Error myqLogin failure, JSON Decode Error: <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[12146998511529215891]</body></html>

Could there be a problem with my API status?

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Mon Oct 22, 2018 12:57 pm
FlyingDiver offline
Posts: 3437
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error

You might be getting locked out from over use. I would disable the plugin for 24 hours and see if it resets. Also, change the polling interval to something a little longer.

If you're using the plugin to control the door and not monitor the status, then set the polling interval to 0 so it doesn't poll at all.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Oct 22, 2018 2:18 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

OK, I will give that a try. I guess it polls every 5 minutes but is used around 3 times a day if that is over use?? Polling would be the Update device status frequency? It says' Minimum update interval is 5 minutes but it will take 0 as an entry? And yes it is only used to open the door, like I said 3 times a day so status polling is not necessary.

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Mon Oct 22, 2018 2:21 pm
FlyingDiver offline
Posts: 3437
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error

Oops. My mistake. Setting it to zero does not disable polling. I have that in several of my other plugins but not in this one.

So disable it for a day to try to get it to reset, then set it to something higher like 60 minutes.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Oct 23, 2018 5:51 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

It's been over 24 hours and still a no go.

Oct 23, 2018, 4:49:33 PM
Enabling plugin "MyQ 7.2.1"
Starting plugin "MyQ 7.2.1" (pid 85781)
Started plugin "MyQ 7.2.1"
MyQ Starting MyQ
MyQ Error myqLogin failure, JSON Decode Error: <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[12146998511695599723]</body></html>

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Tue Oct 23, 2018 7:03 pm
FlyingDiver offline
Posts: 3437
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error


joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Oct 24, 2018 12:32 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

That may have worked. Here is the log from the update

Oct 24, 2018, 11:15:56 AM
Upgrading plugin MyQ to newer version 7.2.2 (previous version moved to trash)
Loading plugin "MyQ 7.2.2"
Starting plugin "MyQ 7.2.2" (pid 42794)
Started plugin "MyQ 7.2.2"
MyQ Starting MyQ

I was able to change the Update device status frequency to the max 1440 and the event logging level to Debugging Messaages.
Oct 24, 2018, 11:17:55 AM
MyQ Debug logLevel = 10
MyQ Debug myqLogin successfull
MyQ Debug logLevel = 10
MyQ Debug statusFrequency = 86400.0
MyQ Debug myqLogin successfull
MyQ Debug getDevices: 2 Devices
MyQ Debug getDevices: MyQDeviceTypeId = 2, MyQDeviceTypeName = GarageDoorOpener, DeviceId = 496939
MyQ Debug Checking Opener Device: Garage Door Opener (CG0810197CD1) (496939) against 496939
MyQ Debug getDevices: MyQDeviceTypeId = 1, MyQDeviceTypeName = Gateway, DeviceId = 496759

And I was able to open and close the garage door via the device tab in Indigo

Oct 24, 2018, 11:25:57 AM
MyQ Debug actionControlDevice: "Garage Door Opener (CG0810197CD1)" Request Status
MyQ Debug myqLogin successfull
MyQ Debug getDevices: 2 Devices
MyQ Debug getDevices: MyQDeviceTypeId = 2, MyQDeviceTypeName = GarageDoorOpener, DeviceId = 496939
MyQ Debug Checking Opener Device: Garage Door Opener (CG0810197CD1) (496939) against 496939
MyQ Debug getDevices: MyQDeviceTypeId = 1, MyQDeviceTypeName = Gateway, DeviceId = 496759
MyQ Debug actionControlDevice: "Garage Door Opener (CG0810197CD1)" Unlock
MyQ Debug changeDevice: Garage Door Opener (CG0810197CD1), state = 1
MyQ Debug myqLogin successfull

So I'd say this version fixed my problem. Thanks for the help

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Posted on
Wed Oct 24, 2018 1:31 pm
FlyingDiver offline
Posts: 3437
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: JSON Decode Error

Let's make sure it works for a few days before I finalize the release.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Oct 24, 2018 2:03 pm
colovin offline
Posts: 135
Joined: Oct 27, 2009

Re: JSON Decode Error

I'll let you know on Friday how it's working.

Indigo 7.1.1, OS 10.14.6, MacMini .3.2 GHz 6 Intel Core i7, 64 GB ram

Who is online

Users browsing this forum: No registered users and 1 guest