Basic Installation

Posted on
Sat Feb 11, 2017 5:31 pm
jgb offline
Posts: 20
Joined: Dec 29, 2013

Re: Basic Installation

Works perfectly now. Thanks.

Posted on
Mon Feb 13, 2017 8:47 pm
blysik offline
Posts: 213
Joined: Jan 06, 2015

Re: Basic Installation

I started getting the login error after months of it working fine. I upgraded to most recent version, but I'm still getting this:

Code: Select all
MyQ Error                       Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 94, in runConcurrentThread
  File "plugin.py", line 335, in getDevices
  File "plugin.py", line 315, in myqLogin
UnboundLocalError: local variable 'err' referenced before assignment

   MyQ Error                       plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)


Any suggestion?

Posted on
Mon Feb 13, 2017 8:55 pm
FlyingDiver offline
Posts: 3461
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Basic Installation

Turn on debug logging. There should be a couple of log entries just before you get that error.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Feb 13, 2017 8:57 pm
blysik offline
Posts: 213
Joined: Jan 06, 2015

Re: Basic Installation

It's tricky, because it won't let me save the config with debug. However, It will if I stay on that panel:

Code: Select all
MyQ Debug                       myqLogin request url = https://myqexternal.myqdevice.com/api/user/validate?username=EMAIL&password=PASS&appId=LONGAPPID
   MyQ Debug                       myqLogin response = <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[5442595389213767696]</body></html>
   MyQ Error                       Error in plugin execution runConcurrentThread:


That's all I can get out of debug.

Posted on
Mon Feb 13, 2017 9:03 pm
blysik offline
Posts: 213
Joined: Jan 06, 2015

Re: Basic Installation

No crazy characters in email or password. Just letters and numbers.

Posted on
Mon Feb 13, 2017 9:04 pm
FlyingDiver offline
Posts: 3461
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Basic Installation

Did you edit that url line in the log output?

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Feb 13, 2017 9:08 pm
blysik offline
Posts: 213
Joined: Jan 06, 2015

Re: Basic Installation

Yes, I should have been clear. I anonymized my email, password, and appid.

Posted on
Mon Feb 13, 2017 9:09 pm
FlyingDiver offline
Posts: 3461
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Basic Installation

The appID is coded into the plugin, depending on the opener brand. it's not user specific.

The following line says that your login is being rejected. Are you sure the login info and brand selected are correct?

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Feb 13, 2017 9:14 pm
blysik offline
Posts: 213
Joined: Jan 06, 2015

Re: Basic Installation

100%. I've verified via the myliftmaster.com site. The weird thing to me is that it was working fine forever, and then just today I noticed the error in the logs.

Posted on
Mon Feb 13, 2017 9:14 pm
FlyingDiver offline
Posts: 3461
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Basic Installation

How often are you polling for status?

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Feb 13, 2017 9:17 pm
FlyingDiver offline
Posts: 3461
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Basic Installation

Hmm. Just checked. Mine is failing as well. I think MyQ broke the reverse engineered API we were using.

Need to do some research.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Feb 13, 2017 9:24 pm
blysik offline
Posts: 213
Joined: Jan 06, 2015

Re: Basic Installation

Ok, good to know it's not just me. :) I was polling every 9 minutes. I'll hold tight while we figure out what happened.

Posted on
Tue Feb 14, 2017 12:22 am
bkmar1192 offline
Posts: 274
Joined: Sep 12, 2015

Re: Basic Installation

mine seemed to have stopped working as well.

Traceback (most recent call last):
File "plugin.py", line 94, in runConcurrentThread
File "plugin.py", line 335, in getDevices
File "plugin.py", line 315, in myqLogin
UnboundLocalError: local variable 'err' referenced before assignment

Posted on
Wed Feb 15, 2017 8:19 pm
jgb offline
Posts: 20
Joined: Dec 29, 2013

Re: Basic Installation

same issue after working fine for several day with 7.1.5 now this error message about a million times in the last 2 days due to attempt every 10 seconds.

Traceback (most recent call last):
File "plugin.py", line 94, in runConcurrentThread
File "plugin.py", line 335, in getDevices
File "plugin.py", line 315, in myqLogin
UnboundLocalError: local variable 'err' referenced before assignment

MyQ Error plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
MyQ Error Error in plugin execution runConcurrentThread:

Have disabled and re-enabled and also cannot reconfigure plug-in. Getting the error message in the login fields as before, when attempting to get debugging messages.

MyQ Debug myqLogin request url = https://myqexternal.myqdevice.com/api/u ... HKwTmDzHOu
MyQ Debug myqLogin response = <html><head><title>Request Rejected</title></head><body>Your request has been denied.<br><br>[5442595389242462761]</body></html>
MyQ Error Error in plugin execution runConcurrentThread:

Posted on
Wed Feb 15, 2017 8:21 pm
FlyingDiver offline
Posts: 3461
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Basic Installation

It's broken. Just stop using it until I resolve the API issues.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Who is online

Users browsing this forum: No registered users and 1 guest