MyQ API down again

Posted on
Tue Aug 06, 2019 11:01 am
FlyingDiver offline
Posts: 3274
Joined: Jun 07, 2014
Location: Southwest Florida, USA

MyQ API down again

According to: https://github.com/arraylabs/pymyq/issues/22

And yes, I started getting auth errors about 7am EDT today.

Nothing I can do until the library developers reverse engineer the changes.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Aug 06, 2019 1:55 pm
FlyingDiver offline
Posts: 3274
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ API down again

Looks like there's a possible fix: https://github.com/chanomie/homebridge- ... /README.md

I guess I'll take a break from the MQTT plugin and try this.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Aug 06, 2019 2:18 pm
FlyingDiver offline
Posts: 3274
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ API down again

Um. No. I need to wait until it's ported to mymyq.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Aug 07, 2019 5:30 am
DaveL17 offline
User avatar
Posts: 4917
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: MyQ API down again

I got a bunch of denials yesterday, but none today (so far). Maybe the condition was temporary.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Wed Aug 07, 2019 6:06 am
FlyingDiver offline
Posts: 3274
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ API down again

I saw a posting on the GitHub project that the old API is working again today. And my plugin is working again too.

Background - the plugin, and most of the other HA type applications out in the wild use the reverse engineered MyQ Version 4 API. There's also a Version 5 API, which is what MyQ is switching too. For the last 24 hours (more or less), MyQ disabled the V4 API. Which broke many things. I don't know if this was intentional or not. It might have been a mistake. Or it was intentional, but they got so many complaints that reversed it. Maybe they have legitimate users of their mobile apps that never updated to new app versions for whatever reason. Who knows?

In any case, one developer did manage to reverse engineer the V5 API and write an updated library in about 12 hours. I'm waiting for it to get some more testing before I roll the changes into the plugin.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Sat Aug 17, 2019 12:41 pm
fishmg01 offline
Posts: 29
Joined: Sep 16, 2013

Re: MyQ API down again

Hi. I'm still getting log-in errors and cannot connect. Is it just me now or is everyone getting shut out?

Posted on
Sat Aug 17, 2019 12:43 pm
FlyingDiver offline
Posts: 3274
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ API down again

fishmg01 wrote:
Hi. I'm still getting log-in errors and cannot connect. Is it just me now or is everyone getting shut out?


It's working again for me.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu Aug 22, 2019 4:40 pm
fishmg01 offline
Posts: 29
Joined: Sep 16, 2013

Re: MyQ API down again

hmmm.....I'm still not able to login. I've deleted the MyQ plugin and preferences and did a clean install of your plugin, and still get the login failure error below.
I've triple checked the login and password by logging in to the Liftmaster website and that works fine. Any additional information I could send you that might help sort this out?

Aug 22, 2019, 6:24:34 PM
Installing and enabling plugin MyQ v7.3.2
Loading plugin "MyQ 7.3.2"
Starting plugin "MyQ 7.3.2" (pid 55984)
Started plugin "MyQ 7.3.2"
MyQ Starting MyQ

Aug 22, 2019, 6:24:50 PM
MyQ Error myqLogin failure, RequestException: [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:590)

Posted on
Thu Aug 22, 2019 4:42 pm
FlyingDiver offline
Posts: 3274
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ API down again

fishmg01 wrote:
hmmm.....I'm still not able to login. I've deleted the MyQ plugin and preferences and did a clean install of your plugin, and still get the login failure error below.
I've triple checked the login and password by logging in to the Liftmaster website and that works fine. Any additional information I could send you that might help sort this out?

Aug 22, 2019, 6:24:34 PM
Installing and enabling plugin MyQ v7.3.2
Loading plugin "MyQ 7.3.2"
Starting plugin "MyQ 7.3.2" (pid 55984)
Started plugin "MyQ 7.3.2"
MyQ Starting MyQ

Aug 22, 2019, 6:24:50 PM
MyQ Error myqLogin failure, RequestException: [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:590)


Looks like you're running an OS earlier than High Sierra. You need High Sierra or Mojave.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Sun Sep 15, 2019 10:44 am
mattyf offline
Posts: 53
Joined: Apr 15, 2013

Re: MyQ API down again

Is there any workaround for Sierra? I'm on an older Mac Mini and anything above Sierra slows it to a crawl....

Posted on
Sun Sep 15, 2019 10:47 am
FlyingDiver offline
Posts: 3274
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MyQ API down again

mattyf wrote:
Is there any workaround for Sierra? I'm on an older Mac Mini and anything above Sierra slows it to a crawl....


Sorry, no. The MyQ servers won't accept the older protocols that are all Sierra can do.

But I've never noticed High Sierra being all that more taxing than Sierra. Mojave is a big step because it requires the Metal graphics API.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest