[Solved] Problem with Kwikset 912

Posted on
Fri Dec 16, 2016 3:15 pm
jalves offline
Posts: 537
Joined: Jun 16, 2013

[Solved] Problem with Kwikset 912

Not sure if this is the correct place to post this question. It may or may not relate to the lock manager plugin. Anyway, I just installed a Kwikset 912 lock and have attempted to set a pin using the lock manager plugin. When I do so, the Stick gets knocked off line, but seems to recover OK. Here's the log entries:

Code: Select all
Dec 16, 2016, 4:15:06 PM
   Action Group                    Set Lock Pin
   Z-Wave Lock Manager             Setting PIN for user 3 to: 1234
   Z-Wave                          sent "020 - Entry Lock" raw command [63 01 03 01 31 32 33 34]
   Z-Wave Error                    Error in plugin execution:

Traceback (most recent call last):
  File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/serialinterface.py", line 501, in startCommThread
    self.processCommThread()
  File "/Library/Application Support/Perceptive Automation/Indigo 7/IndigoPluginHost.app/Contents/PlugIns/serialinterface.py", line 675, in processCommThread
    self.processQueueInPacket(packet)         # Subclass is required to define.
  File "zwaveinterface.py", line 2223, in processQueueInPacket
  File "zwaveinterface.py", line 2197, in _processFuncCall
  File "zwaveinterface.py", line 2258, in _processCommandReply
  File "zwaveinterface.py", line 2242, in _processFuncTriggersAndBroadcast
  File "zwaveinterface.py", line 2195, in _processFuncCall
  File "zwavecmd_security.py", line 241, in _processEncryptedPacket
  File "zwaveinterface.py", line 2258, in _processCommandReply
  File "zwaveinterface.py", line 2242, in _processFuncTriggersAndBroadcast
  File "zwaveinterface.py", line 2195, in _processFuncCall
  File "actionsensor.py", line 551, in _processAlarmSensorStatusReply
  File "actionsensor.py", line 108, in _processSensorOnOffVal
  File "actionlock.py", line 146, in _processLockSensorAlarmByte
TypeError: unsupported operand type(s) for &: 'NoneType' and 'int'

   Z-Wave Error                    exc type is <type 'exceptions.TypeError'>
   Z-Wave Error                    restarting serial connection in 5.0 seconds
   Interface Failure               lost connection with interface
   Z-Wave                          connected to Z-Stick S2 interface on /dev/cu.SLAB_USBtoUART (firmware 3.07)
Last edited by jalves on Sun Dec 18, 2016 12:57 pm, edited 1 time in total.

Running Indigo 7.4 on a 27" iMac (mid-2017), 40G memory, 1T Fusion Drive, OS X 10.15.1
Jeff

Posted on
Fri Dec 16, 2016 4:26 pm
howartp offline
Posts: 3755
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Problem with Kwikset 912

That's an interesting one.

It might be caused by a bug in my plugin, but I'll need Matt/Jay to tell me what their code is doing at that point to know what it is.


Sent from my iPhone using Tapatalk

Posted on
Fri Dec 16, 2016 5:57 pm
jalves offline
Posts: 537
Joined: Jun 16, 2013

Re: Problem with Kwikset 912

If it helps, the actual setting of the pin does succeed. I've set two different pin codes using this method (the example is a third attempt so that I didn't expose my actual pin codes here in public) each with the same result.

Running Indigo 7.4 on a 27" iMac (mid-2017), 40G memory, 1T Fusion Drive, OS X 10.15.1
Jeff

Posted on
Fri Dec 16, 2016 7:34 pm
matt (support) offline
Site Admin
User avatar
Posts: 19436
Joined: Jan 27, 2003
Location: Texas

Re: Problem with Kwikset 912

I think that is a bug I just introduced in the beta Z-Wave plugin I posted for an ID Lock tweak. Here is another newer version that should be better behaved.

Image

Posted on
Fri Dec 16, 2016 8:12 pm
jalves offline
Posts: 537
Joined: Jun 16, 2013

Re: Problem with Kwikset 912

Thanks for the quick response! I just downloaded an applied the new version and sure enough it works just fine.

Running Indigo 7.4 on a 27" iMac (mid-2017), 40G memory, 1T Fusion Drive, OS X 10.15.1
Jeff

Posted on
Sat Dec 17, 2016 7:29 am
jalves offline
Posts: 537
Joined: Jun 16, 2013

Re: Problem with Kwikset 912

Having success with the 912 on my garage entry door, I'm planning on installing the 916 on the front door today. Looking forward to figuring out different ways to utilize this new feature in our home.

Running Indigo 7.4 on a 27" iMac (mid-2017), 40G memory, 1T Fusion Drive, OS X 10.15.1
Jeff

Posted on
Sun Dec 18, 2016 1:01 pm
jalves offline
Posts: 537
Joined: Jun 16, 2013

Re: [Solved] Problem with Kwikset 912

Just updating to say that the Kwikset 916 is now installed and working properly as well. It did take several tries to get the lock properly included with encryption. A few attempts failed outright, others appeared to work, but Indigo didn't see all the features. Eventually I took the lock off the door and partially assembled it next to the Indigo Server with my z-stick (gen 2) which then resulted in a "full" inclusion. Disassembled it and remounted it on the door and all is well.

Running Indigo 7.4 on a 27" iMac (mid-2017), 40G memory, 1T Fusion Drive, OS X 10.15.1
Jeff

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest