ZWave Lock Manager

Posted on
Tue Nov 29, 2016 10:31 am
polycron offline
Posts: 100
Joined: Jan 08, 2006

Re: ZWave Lock Manager

The BE469 may not be able to poll pin's. At least that is what I'm seeing after sending the raw zwave commands and watching my debug responses. It comes back with asterisks for the pin.. I've also read in other forums that the BE469 does not respond with pins and that it was a security feature.

The way others have gotten around it is to use a database that they populate by hand and then maintain through their application (making changes at the lock would cause it to go out of sync).

As a, hopefully, quick way to simulate the database/application process, could we have an additional action added for "Set User PIN from Variable" that would give us a variable selection instead of the free form pin entry? I think the free form pin entry would need to stay as well.

Jeff

Posted on
Tue Nov 29, 2016 10:40 am
FlyingDiver offline
Posts: 3885
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: ZWave Lock Manager

Or, even easier, support variable and device substitution for the text field for PIN entry.

On line 65 of plugin.py, change:

Code: Select all
      userPin = str(pluginAction.props["userPin"])

to
Code: Select all
      userPin =  indigo.activePlugin.substitute((pluginAction.props["userPin"])

Then you can use the %%v:XXXXXXXXX%% string in that text field instead of the real PIN.

You don't really need the str() conversion since what you're going to get from pluginAction.props is always a string.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Fri Dec 02, 2016 6:20 pm
GlennNZ offline
Posts: 666
Joined: Dec 07, 2014
Location: Central Coast, Australia

Re: ZWave Lock Manager

Thanks a lot for this plugin - I'm sure Matt and Jay are thankful as well - as Pin codes are somewhat required to open door! :shock:

All going well, ... but...

Some non-lock devices are appearing in log occasionally..
(this is a Aeon ZW100 Motion Sensor - node 86)
Z-Wave received "Bathroom - downstairs - Temperature" sensor update to 22.3 °C
Z-Wave Lock Manager Debug -----
Z-Wave Lock Manager Debug Lock Status Report received:
Z-Wave Lock Manager Debug Raw command: 01 10 00 04 00 56 0A 71 05 00 00 00 FF 07 08 00 00 33
Z-Wave Lock Manager Debug Node: 86
Z-Wave Lock Manager Debug Type: 0
Z-Wave Lock Manager Debug User: 0
Z-Wave Lock Manager Unknown lock status received: 0 [Node: 86]
Z-Wave Lock Manager Debug -----

Z-Wave Lock Manager Debug -----
Z-Wave Lock Manager Debug Lock Status Report received:
Z-Wave Lock Manager Debug Raw command: 01 10 00 04 00 56 0A 71 05 00 00 00 FF 07 00 00 00 3B
Z-Wave Lock Manager Debug Node: 86
Z-Wave Lock Manager Debug Type: 0
Z-Wave Lock Manager Debug User: 0
Z-Wave Lock Manager Unknown lock status received: 0 [Node: 86]
Z-Wave Lock Manager Debug -----

Posted on
Fri Dec 02, 2016 6:24 pm
srkinard offline
Posts: 259
Joined: Apr 10, 2016
Location: Austin, Texas

Re: ZWave Lock Manager

same here...I'm getting this:

Code: Select all
Z-Wave Lock Manager             Unknown lock status received: 7 [Node: 53]


Device 53 is my Zooz 4-in-1 motion sensor/temp/humidity/luminance

Posted on
Fri Dec 02, 2016 7:49 pm
FlyingDiver offline
Posts: 3885
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: ZWave Lock Manager

I get those all the time from my garage door sensors:

Code: Select all
Z-Wave                          received "Small Garage Door Tilt Sensor" status update is off
Z-Wave                          received "Small Garage Door Tamper Switch" status update is off
Z-Wave Lock Manager             Unknown lock status received: 7 [Node: 11]
 

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Sat Dec 03, 2016 2:24 pm
aldera offline
User avatar
Posts: 109
Joined: Aug 30, 2016
Location: Michigan, USA

Re: ZWave Lock Manager

I also get the following ZWave Lock Manager entry in my log when my Nexia Z-Wave Doorbell Sensor, DB100Z is activated by a doorbell ring:

Z-Wave Lock Manager Unknown lock status received: 0 [Node: 31]

Don't know if this helps but in Indigo, the doorbell sensor is listed as a "Notification Sensor" under Model. Just making a wild guess here but does your code respond to multiple "Model" types that include Notification Sensors, Locks, etc.?

Posted on
Sat Dec 03, 2016 6:07 pm
howartp offline
Posts: 3901
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: ZWave Lock Manager

Currently I use all alarm class notifications, which is more than just locks, but I have a beta that starts to change this as the IDlock's don't use it so I've been reading more into it.


Sent from my iPhone using Tapatalk

Posted on
Tue Dec 06, 2016 4:04 pm
krissh offline
Posts: 104
Joined: Nov 18, 2012
Location: Norway

Re: ZWave Lock Manager

Thanks for a great plugin! I don't have a z-wave lock, but I have a Zipato keypad that appears as a lock in Indigo. I was able to set user pin with your plugin, but had some trouble configuring RFID tag. I was able to configure the RFID tag via raw Z-wave command but when setting "home" or "away" I get the following from your plugin:
Code: Select all
   Z-Wave Lock Manager             Unknown lock status received: 0 [Node: 13]

Would you by any chance be interested in adding some support for the keypad if I send you some debug info etc? :lol:

Posted on
Tue Dec 06, 2016 4:06 pm
howartp offline
Posts: 3901
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: ZWave Lock Manager

I'll certainly have a look.


Sent from my iPhone using Tapatalk

Posted on
Sat Dec 10, 2016 4:49 pm
clawmd offline
Posts: 87
Joined: Jan 01, 2007

Re: ZWave Lock Manager

Was able to add my Yale Touchscreen to Indigo, but Im having some problems. Indigo indicates that it is locking and unlocking, but the lock is doing nothing. Using the Plug in, I am able to add PIN # but the PIN #s don't do anything when entered. Here is the log:

Dec 10, 2016, 5:42:49 PM
Z-Wave sent "007 - Keypad Deadbolt (YRD210/220/240)" status request
Z-Wave sent "007 - Keypad Deadbolt (YRD210/220/240)" lock
Z-Wave sent "007 - Keypad Deadbolt (YRD210/220/240)" unlock

Dec 10, 2016, 5:45:04 PM
Action Group PIN
Z-Wave Lock Manager Debug setUserPin action called
Z-Wave Lock Manager Debug Indigo lock selected: 507386035
Z-Wave Lock Manager Setting PIN for user 1 to: 5174
Z-Wave sent "007 - Keypad Deadbolt (YRD210/220/240)" raw command [63 01 01 01 35 31 37 34]
Z-Wave Lock Manager Debug setRCT action called
Z-Wave Lock Manager Debug Indigo lock selected: 507386035
Z-Wave Lock Manager Debug 11111100000
Z-Wave Lock Manager Debug 111
Z-Wave Lock Manager Debug 7
Z-Wave Lock Manager Debug 11100000
Z-Wave Lock Manager Debug 224
Z-Wave Lock Manager Debug 2016
Z-Wave Lock Manager Setting lock time to 10/12/2016 17:45:5 (UK format DD/MM/YYYY HH:MM:SS)
Z-Wave sent "007 - Keypad Deadbolt (YRD210/220/240)" raw command [8B 01 07 E0 0C 0A 11 2D 05]
Z-Wave Lock Manager Debug setUserPin action called
Z-Wave Lock Manager Debug Indigo lock selected: 507386035
Z-Wave Lock Manager Setting PIN for user 2 to: 7012
Z-Wave sent "007 - Keypad Deadbolt (YRD210/220/240)" raw command [63 01 02 01 37 30 31 32]

Im not sure how to best approach troubleshooting

Posted on
Sat Dec 10, 2016 4:53 pm
srkinard offline
Posts: 259
Joined: Apr 10, 2016
Location: Austin, Texas

Re: ZWave Lock Manager

clawmd wrote:
Was able to add my Yale Touchscreen to Indigo, but Im having some problems. Indigo indicates that it is locking and unlocking, but the lock is doing nothing. Using the Plug in, I am able to add PIN # but the PIN #s don't do anything when entered.


Look at the device settings and see if it says anything on a line called Encryption.

When I added my lock, it took 3 tries to include with encryption...first two times it included, but would say something like "Encryption supported but not enabled" and the lock would do nothing. Only if the encryption is enabled will it respond to commands.

Ross

Posted on
Sat Dec 10, 2016 5:00 pm
srkinard offline
Posts: 259
Joined: Apr 10, 2016
Location: Austin, Texas

Re: ZWave Lock Manager

When you look edit the device is there a "Write to event log" button? It will tell if encryption is enabled. Here's the output from my Yale deadbolt:

Code: Select all
   Z-Wave                          Indigo Device "Lock - Front Door Deadbolt" Z-Wave Properties:
Indigo Z-Wave Version: 2.0.34
Node ID: 65
Model: Keypad Door Lock
Model ID: 00040000
Manufacturer: Yale
Manufacturer ID: 0129
Protocol Version: 3.34
Application Version: 33.32
Model Definition Version: 0
Library Type: 3
Class Name: Keypad Door Lock
Class Hierarchy: 04 : 40 : 03
Command Class Base: 62
Command Versions: 80v1 85v1 86v1 8Av1 8Bv1 4Cv1 4Ev1 98v1 20v1 62v1 63v1 70v1 71v1 72v1 75v1
Encryption Status: Enabled for Commands 80 62 63 85 86 8A 8B 4C 4E 70 71 72 75 98
Multi-Endpoint Types: - none -
Multi-Endpoint Classes: - none -
Multi-Instance Counts: - none -
Features: routing, battery, beaming, security, frequentWaking
Neighbors: 3, 4, 5, 11, 12, 13, 15, 16, 17, 19, 20, 23, 24, 25, 26, 27, 28, 29, 30, 35, 39, 40, 41, 43, 49, 50, 52, 61
Associations: 1:[1]
Config Values: - none -


Key line I believe is the Encryption Status: Enabled for Commands 80 62 63 85 86 8A 8B 4C 4E 70 71 72 75 98

Posted on
Sun Dec 11, 2016 11:39 am
clawmd offline
Posts: 87
Joined: Jan 01, 2007

Re: ZWave Lock Manager

Success! It took multiple attempts to get the encryption.

Posted on
Sun Dec 11, 2016 11:56 am
clawmd offline
Posts: 87
Joined: Jan 01, 2007

Re: ZWave Lock Manager

I have been able to enter PIN numbers and they work!
Feature Request PIN activation/deactivation interval
With the Vera UI, it is possible to define a start and end date/time for the PIN. This is really useful for rentals for obvious reasons. Could also be useful at home to provide a limited window of access without having to remember to deactivate it. I am guessing that this could all be done manually with a schedule, but it would be somewhat clumsy to use. I don't know enough about plugin scripting to know if this is a reasonable feature to request or not. Perhaps there is another way to solve this that I haven't thought of.

Posted on
Sun Dec 11, 2016 1:12 pm
FlyingDiver offline
Posts: 3885
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: ZWave Lock Manager

clawmd wrote:
Feature Request PIN activation/deactivation interval
With the Vera UI, it is possible to define a start and end date/time for the PIN. This is really useful for rentals for obvious reasons. Could also be useful at home to provide a limited window of access without having to remember to deactivate it. I am guessing that this could all be done manually with a schedule, but it would be somewhat clumsy to use. I don't know enough about plugin scripting to know if this is a reasonable feature to request or not. Perhaps there is another way to solve this that I haven't thought of.


Putting this in the plugin would, IMO, complicate the plugin needlessly. This is the kind of thing that Indigo schedules are explicitly designed for. One schedule to enable the PIN, another to disable it. OTOH, an enhancement to the plugin to actually enable/disable users/PINs. would be useful, so that the PIN numbers aren't in the scheduled events. I think the author is planning on adding a user/PIN database to the plugin, so once that's in place it's pretty straightforward. But the time-based processing? I think that's redundant.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Who is online

Users browsing this forum: No registered users and 1 guest