Lock Triggers Stopper Working

Posted on
Sun Aug 14, 2022 12:39 am
eric offline
Posts: 55
Joined: Dec 22, 2014

Lock Triggers Stopper Working

Either it was the Python 3 version or my new Mac but something happened and now lock triggers that have been working for awhile simply don't trigger.

Any suggestions as to what to try?

Is there a way to "reset" the relationship between a lock and its lock manager so they see each other as if new, without deleting everything and starting fresh?

The particular triggers that aren't working are when a door is unlocked by a particular user or when it's unlocked in general. Nothing gets reported to indigo.
.
It should also be noted that one of my locks (Yale) does not seem to be reporting battery level to indigo.

All regular lock functions still work – lock, unlock

Thanks

Posted on
Sun Aug 14, 2022 7:31 am
howartp offline
Posts: 4500
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Lock Triggers Stopper Working

Turn on debugging in the plugin config then do some test lock/unlocks.

The log should show any lock commands that the plugin is seeing, regardless of whether it's acting/triggering on them or not.

Let me know what you see/don't see in the log.

ps - is the log showing any Zwave activity for the lock itself - ie is it just the plugin that isn't working, or is Indigo not seeing the lock/unlock happening?

Peter

Posted on
Sun Aug 14, 2022 7:44 am
eric offline
Posts: 55
Joined: Dec 22, 2014

Re: Lock Triggers Stopped Working

I unlocked one lock manually and this appeared in the log:

Z-Wave Lock Manager Debug Node ID 77 (Hex 77) found in lockIDs
Z-Wave Error encrypted command received from node ID 077 has invalid CBC-MAC value (ignoring)
Z-Wave Lock Manager Debug Node ID 77 (Hex 77) found in lockIDs


And then a second lock:

Z-Wave Lock Manager Debug Node ID 75 (Hex 75) found in lockIDs
Z-Wave Lock Manager Debug Node ID 75 (Hex 75) found in lockIDs
Z-Wave Error encrypted command received from node ID 075 has invalid CBC-MAC value (ignoring)


Locking either lock got me the "found" messages above but no error.

Posted on
Sun Aug 14, 2022 9:09 am
howartp offline
Posts: 4500
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Lock Triggers Stopper Working

When you say “new Mac”, have you transferred your copy of Indigo, and stick, to a new Mac?

If so I’ll have to check with @Matt/@Jay whether the encryption key needs any handling.

Peter


Sent from my iPhone using Tapatalk Pro

Posted on
Sun Aug 14, 2022 9:26 am
howartp offline
Posts: 4500
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Lock Triggers Stopper Working

Can you try re-syncing one of the locks (still using encryption)?

That won’t break anything, but might fix that error.


Sent from my iPhone using Tapatalk Pro

Posted on
Sun Aug 14, 2022 10:50 am
matt (support) offline
Site Admin
User avatar
Posts: 21049
Joined: Jan 27, 2003
Location: Texas

Re: Lock Triggers Stopper Working

If re-syncing doesn't work, then exclude it, re-include (with encryption) and re-sync.

Image

Posted on
Sun Aug 14, 2022 12:39 pm
eric offline
Posts: 55
Joined: Dec 22, 2014

Re: Lock Triggers Stopper Working

Thanks Matt and Peter.

I actually could not get any lock to sync at all. They errored out.

So I tried excluding and including one of the locks (with encryption) and synching, which all worked as expected,

But now whereas Indigo thinks it's connected to the locks and thinks it is locking and unlocking them, it does not actually turn the locks at all.

The log does not indicate any errors, but no lock function.

Also, no communications from the lock to Indigo when the lock is operated manually.

Thanks.

Eric

Posted on
Sun Aug 14, 2022 12:40 pm
howartp offline
Posts: 4500
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Lock Triggers Stopper Working

Double checking that you had the Zwave stick in the Mac whilst you included with encryption - not took the stick to the lock?


Sent from my iPhone using Tapatalk Pro

Posted on
Sun Aug 14, 2022 1:29 pm
eric offline
Posts: 55
Joined: Dec 22, 2014

Re: Lock Triggers Stopper Working

Yes - I know that the only way to do the encrypted include is with the computer attached.

I bring the whole laptop to the lock!

But this seems like more of an Indigo / Z-wave thing than a lock manager thing I guess. My next thought is to start with the lock reset to factory settings unless you can think of anything else.

Eric

Posted on
Mon Aug 15, 2022 1:42 pm
matt (support) offline
Site Admin
User avatar
Posts: 21049
Joined: Jan 27, 2003
Location: Texas

Re: Lock Triggers Stopper Working

Did you try the sync (and lock/unlock control) while the Mac was next to the lock? I'm surprised the inclusion worked but the sync didn't.

And can you copy/paste the Event Log results showing the inclusion, re-sync and control attempts?

Image

Posted on
Tue Aug 16, 2022 3:59 am
eric offline
Posts: 55
Joined: Dec 22, 2014

Re: Lock Triggers Stopper Working

Will do when I’m back at the location in a few days…

Yes, tried sync at close range and it didn’t work (timed out), but include and exclude worked (leaving the lock non-functional via Indigo, as above).

Thanks for your help!

Posted on
Sat Aug 27, 2022 8:27 am
eric offline
Posts: 55
Joined: Dec 22, 2014

Re: Lock Triggers Stopper Working

Just to follow up (and conclude) this issue, some persistence on the non-responsive locks (so far two of my eight) and repetition of the exclude/include seems to have solved this.

Things are working, but clearly i had to re-do all the locks since replacing the computer and it has nothing to do with ZWave Lock Manager.

Thanks!

Posted on
Sat Aug 27, 2022 12:06 pm
howartp offline
Posts: 4500
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Lock Triggers Stopper Working

Thanks Eric.


Sent from my iPhone using Tapatalk Pro

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest