Page 1 of 1

Current state of this plugin (as of October 2019)

PostPosted: Wed Oct 23, 2019 10:24 am
by jay (support)
I thought I'd recap the state of this plugin given the extremely long topic that's been the focus for the past several months or so. Here's what we know:

  • This plugin works by emulating a Hue Bridge device, which some Echo devices can communicate directly with (not through the official Hue Alexa Skill).
  • This emulation only worked with Echo gen 1, Echo Dot gen 1 and Dot gen 2 devices (and perhaps other Echo devices), though that has changed (see next point).
  • Sometime in late August/early September 2019, Amazon pushed out a firmware update for all gen 2+ devices (anecdotally) which breaks the plugin. It does this because it stopped communicating on the network port number that the plugin tells it to use. Rather, it assumes port 80 (the default HTTP port), which the plugin can't open because macOS considers it a protected port and won't allow user software to use it. Attempts to work around this (port-forwarding, etc) have failed to work thus far. This change may or may not be intentional on Amazon's part, but so far they haven't corrected it.
  • Echo Gen 1 firmware that starts with 641/647/649 still appears to work for most people (see below for details). However, firmware versions that are a higher number than that appear to have this breaking change. What most users have experienced is that you must have a gen 1 echo on your network and that echo has to be the one that discovers the devices. Any other echo can control devices via the gen 1 that's on your network after a successful discovery.
  • There doesn't appear to be a way to flash older firmware to those Echo devices, nor does there seem to be a way to stop updates from happening automatically.

There are conflicting reports from users about the exact process to get up and running, but one thing is very clear: you must have an Echo Gen 1 (not a Plus) or an Echo Dot Gen 1 for continued use of the plugin. Some users have found them on Ebay, but you have to be careful as some of the Dots advertised as gen 1 on Ebay are actually gen 2. Gen 1 Echos and Echo Dots have 2 buttons on the top and the volume is controlled by rotating the top bezel. Gen 2 devices have 4 buttons on the top, the two extra control the volume and the top doesn't rotate.

Near as I can tell, this process probably will work to get you up and running assuming you have a gen 1 device on your local network. There are a few reports of this (or similar) process not working, but it seems that most who have tried have been successful. The goal is first to get Amazon to forget about all your smart home devices in all the places it caches that information then rediscovering:

  1. In the plugin settings, select Override Host IP Address and enter the IP address of the Indigo Server Mac. The plugin can normally figure it out, but apparently in Catalina the IP address discovery the plugin uses doesn't work properly. Using this setting bypasses the automatic IP discovery and uses the IP address specified.
  2. Unplug all echo devices. Wait a few minutes.
  3. I would also delete the Alexa app on all iOS (or other) devices that have it - I don't know how/when the app's device cache gets updated (see below), but this would hopefully ensure that its cache gets deleted.
  4. Forget all your existing devices. Conflicting reports here on the most effective way to do this, but I believe that going to and forgetting all devices from there may be the most reliable way. While there, I'd go ahead and delete any groups and scenes you have. The goal here is to basically force Amazon to forget about all smart home devices you have everywhere. There does seem to be some caching between their site and each echo device, which is why you want to do it on the website with all other possible cache locations disabled. Again, wait a few minutes.
  5. Reinstall the Alexa app on your iOS (or other) device.
  6. Plug in your Echo Gen 1 ONLY - leave all the rest unplugged.
  7. Add it to the Alexa app as necessary (if, for instance, you just acquired one). If it's not new to you, you may not need to do this.
  8. Make sure you have the plugin installed and running and make sure the bridge device is in discovery mode.
  9. Tell your Echo Gen 1 to discover devices.

Hopefully, it will discover the devices and control them correctly. If so, plug all the rest of the echo devices in (might want to do them one at a time) and see if they are controlling devices as well.

If this didn't work, then I really don't have any extra advice on how to troubleshoot. You can read through the topic mentioned above to see if there's anything else in there that might help.

I would request that people only post on this topic if they have direct, specific information that would augment the above information. Please don't post general "+1", "didn't/did work for me", etc., so that we can keep this topic as specific to solving problems as possible. If this process didn't work for you, I encourage you to post a new topic in this forum instead. This will help in 2 ways: 1) we'll more easily be able to follow the thread that's specific to you, and 2) it may help everyone identify other patterns that are useful. @Autolog, who has been shepherding this effort for the past few years (big thanks for that!), has full moderator access to this forum so he can update this post with any new/changed/alternate information as it's identified.

[EDIT 2019-10-25] - Added the step to override the IP address in the plugin's settings, which seems to solve some issues when running on Catalina.
[EDIT 2019-12-08] - It appears that firmware version starting with 647 also works (647588720 is confirmed to work).
[EDIT 2019-12-09] - It appears that firmware version starting with 649 also works (649598720 is confirmed to work).

Re: Current state of this plugin (as of October 2019)

PostPosted: Wed Nov 06, 2019 7:26 pm
by jgb
running Catalina 10.15.1, Indigo 7.4 on a Mac mini (late 2014)
Echo Dot Gen 1 (also have an Echo Show and an Echo Spot, and was using a Gen 2 Dot up until that quit)

Bought the gen 1 on Ebay about a month ago. After installing it, all was well until a couple of days ago, and Alexa would not respond to commands. The SW version when I installed the gen 1 dot was 641571120, checked today and the version is 647588720. So guessing that change affected the system. Tried multiple times the process that Jay detailed with no success; no devices discovered, therefore no control.

Re: Current state of this plugin (as of October 2019)

PostPosted: Thu Nov 21, 2019 3:21 pm
by Seeker
one original dot, one new (2018) dot. the above procedure got my dots/alexa hue bridge plugin working again. thanks.

Re: Current state of this plugin (as of October 2019)

PostPosted: Tue Jan 28, 2020 11:30 pm
by akimball
So this is horrible.

My alexa hue bridge has been breaking for a few months now, ever 2 or 3 weeks....and usually I can bring it back on-line by a combination of ‘discover’ commands, enabling/disabling AHB, restarting the mac, restarting the hue hub...and usually within a hour it decides to work again. No particular pattern discerned.

This time seems different. Tonight I’ve had no success after nearly 3 I decided to do some forum reading. Yikes. I’ve got two gen1 alexa devices in our home collection of 20 or 21 alexas. I want amazon to buy most of them back from me, I’m so angry right now after reading this thread, Moving the port below 1024 is just dumb if you can’t override.

Has anyone tried portforwarding? Looking into it.

The trouble I see...with well over 120 home devices and 80 connected to alexa using 6 AHB’s, is that the pain of deleting all those devices, turning off 21 hubs, and rebuilding everything using AHB is simply too much to bear. I’ve gotta life and no time for this...I realize I’m not the only one. I don’t have a device count on my automation and believe those numbers are conservative.

At least HomeKit Bridge still works but I’m feeling pure animosity for Amazon right now.

The process could be less painful if there was a way to dump the AHB configs to a save file for reloading after armageddon.

Re: Current state of this plugin (as of October 2019)

PostPosted: Wed Jan 29, 2020 7:18 am
by siclark
If you are going to rebuild, admittedly takes some time, look at the node red solution. Diane sounds like that will die as it uses Amazon's supported port 80

Re: Current state of this plugin (as of October 2019)

PostPosted: Wed Jan 29, 2020 9:42 am
by akimball
Woke up this morning and alexa was back online. Don’t know how.

Re: Current state of this plugin (as of October 2019)

PostPosted: Wed Jan 29, 2020 10:00 am
by autolog
Have you overridden the host address in the plugin config to point at the Mac running Indigo e.g. If not, it might be worth doing as it is possible that there may be some sort of network issue that is causing this problem. :)

Re: Current state of this plugin (as of October 2019)

PostPosted: Wed Jan 29, 2020 10:08 am
by akimball
I have not overridden the address yet and that’s a good next step. My mac address is on a 10.0.1.xx mapping. My understanding, probably wrong, is that I would need to build an AHB for each separate dot, with devices in the room with that particular dot...again I’m fuzzy on the specifics.

I wonder now if my issue is related at all to amazon isolating their devices to port 80...may be another issue.

Re: Current state of this plugin (as of October 2019)

PostPosted: Wed Jan 29, 2020 10:18 am
by autolog
AHBs do not map to individual Alexa devices, they exist in their own right. You just need to tell the plugin (via its config dialogue) what Indigo's IP address is e.g. Host IP Address =

Re-read Jay's recap (first post in this thread) - his step 1. is to override the IP address. :wink:

I agree that I don't think your issue is to do with Amazon port 80 issue otherwise your system wouldn't work. Yours stops working and then starts working, hence my suggestion about it being some sort of network issue. :)

Re: Current state of this plugin (as of October 2019)

PostPosted: Tue Feb 11, 2020 11:40 am
by Benwin
Does anybody know if it possible to use a raspberry pi to forward the port 80 seeing as the pi is more configurable?