Alexa says all devices are not responding

Posted on
Sun Sep 29, 2019 7:56 am
FlyingDiver offline
User avatar
Posts: 4124
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Alexa says all devices are not responding

autolog wrote:
I have been experimenting, without success so far, to create a VLAN on the Indigo mac and then assign the Alexa-Hue bridge to that VLAN and for it to listen on port 80. I have had to modify the plugin code to enable this way of working. However, I have come across another problem which is that macOS won't let the plugin listen on port 80 unless it is running as a root user - it fails with a socket error 13 - permission denied. I have been struggling with the pfctl command to get the ports redirected but not making much progress at the moment. :(


Not sure why you would need a VLAN for this. Edit: Oh, nvm that. You would want the VLAN if you need port 80 for something else. What a pain.


As you found out, the problem is binding to port 80 as a non-privileged user. See if this helps:

https://apple.stackexchange.com/questio ... bind-to-it

Once you have that, then you need a dispatcher routine which gets the request, figures out which bridge device it needs to send it along to. Hopefully there's enough information in the request headers to figure that out. I don't use Alexa, so I've never looked at how the devices are differentiated.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Sun Sep 29, 2019 8:20 am
scs offline
Posts: 35
Joined: Nov 28, 2014

Re: Alexa says all devices are not responding

FlyingDiver wrote:
autolog wrote:
I have been experimenting, without success so far, to create a VLAN on the Indigo mac and then assign the Alexa-Hue bridge to that VLAN and for it to listen on port 80. I have had to modify the plugin code to enable this way of working. However, I have come across another problem which is that macOS won't let the plugin listen on port 80 unless it is running as a root user - it fails with a socket error 13 - permission denied. I have been struggling with the pfctl command to get the ports redirected but not making much progress at the moment. :(


Not sure why you would need a VLAN for this. Edit: Oh, nvm that. You would want the VLAN if you need port 80 for something else. What a pain.


As you found out, the problem is binding to port 80 as a non-privileged user. See if this helps:

https://apple.stackexchange.com/questio ... bind-to-it

Once you have that, then you need a dispatcher routine which gets the request, figures out which bridge device it needs to send it along to. Hopefully there's enough information in the request headers to figure that out. I don't use Alexa, so I've never looked at how the devices are differentiated.


ipfw is no longer used in Mac OS ....good idea tho :wink:

Indigo 7 w/ Insteon and Z-Wave lights and outlets
Security integration.
Energy monitoring

Posted on
Sun Sep 29, 2019 8:23 am
FlyingDiver offline
User avatar
Posts: 4124
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Alexa says all devices are not responding

scs wrote:
ipfw is no longer used in Mac OS ....good idea tho :wink:


My bad, I didn't realize how old that thread was.

I think this would be fairly straightforward with a proxy setup like nginx. Even binding to an alternate IP address, if you use System Preferences to set up another one manually using the same ethernet port.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Sun Sep 29, 2019 8:56 am
autolog offline
Posts: 3235
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1 aka UTC+1]

Re: Alexa says all devices are not responding

I have setup a VLAN bound to the same ethernet port and the network is shown as active.
The first test, still using the 8178 etc series port address is to try and get discovery working.

It isn't for the Alexa-Hue Bridge on the VLAN. :|

It should do because I still have my Gen1 Echo plugged in. If I enable an Alexa-Hue Bridge which is on the original (non-VLAN) network, discovery and control works for that Alexa-Hue Bridge.

I think it might be something to do with broadcasting not working across to a VLAN.

Need to investigate further and might need some more plugin coding work-arounds?

Once (and if) I get the VLAN to work in normal mode, I can then worry about using pfctl to sort out the port 80 issue. :)

Posted on
Sun Sep 29, 2019 9:15 am
autolog offline
Posts: 3235
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1 aka UTC+1]

Re: Alexa says all devices are not responding

FlyingDiver wrote:
I think this would be fairly straightforward with a proxy setup like nginx. Even binding to an alternate IP address, if you use System Preferences to set up another one manually using the same ethernet port.


I have installed nginx. :)

Any pointers of how to configure it for this implementation would be appreciated. :wink:

Posted on
Sun Sep 29, 2019 9:26 am
FlyingDiver offline
User avatar
Posts: 4124
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Alexa says all devices are not responding

Basically, this:

Code: Select all
server {
    listen 80;
    server_name your-domain-name.com;
    location / {
        proxy_set_header   X-Real-IP $remote_addr;
        proxy_set_header   Host      $http_host;
        proxy_pass         http://127.0.0.1:2368;
    }
}


Obviously, change that port number to what you actually have the plugin listening on.

Change the listen line if needed for a specific IP address (VLAN):

Code: Select all
    listen 192.168.100.100:80;

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Sun Sep 29, 2019 10:31 am
peszko offline
Posts: 211
Joined: Mar 07, 2012

Re: Alexa says all devices are not responding

neilk wrote:
In this case it is a bit more nuanced, it is the local connection capability that is compromised by the firmware update, a native cloud integration would have kept working (at least to published API’s).

Yes, but the local capability is compromised by an automatic update by Amazon with no easy way to roll back (on a always connected device). The problem is that it is generally not in the interest of the service provider to maintain third party integrations. Possibly even further, it is in their interest to push people to their native environment by making third party integrations more troublesome. Amazon is certainly not alone, both google and apple do the same thing.

neilk wrote:
Moving forward it will become harder to be completely cloud free, and while AI based services such as voice control or image processing for security can be done locally these things rely on data to train the AI engines to be more effective and will be a lot more effort and resources intensive than a cloud service, and they may ultimately be less useful.

I understand and respect the choice and sentiment and many will recoil at the privacy implications alone, but it will mean swimming against the tide, and missing capability. My view for the benefit of reliable voice control the risk is worth it and we have a fail back to none voice control.


Unfortunately this is true. Already it is harder and harder to have local implementations and the service companies will be making it as hard as possible. Even now, the installs of most people on this forum are way beyond the capability of general public. At some point in not too distant future it will be impossible. Even further it will be suspicious if one is not connected to the cloud. And yes, I do recoil at the privacy implications as well.

Posted on
Sun Sep 29, 2019 10:35 am
autolog offline
Posts: 3235
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1 aka UTC+1]

Re: Alexa says all devices are not responding

I have set it up but still not working. :?

I had to sudo start nginx to avoid the permission 13 problem with port 80 - so at least I seem to have got round that. :)

I will take a further look at it tomorrow and see if I can make any progress.

Thanks for your assistance Joe. :)

Posted on
Sun Sep 29, 2019 5:47 pm
Aggie92 offline
Posts: 2
Joined: Dec 28, 2012
Location: Frisco, TX

Re: Alexa says all devices are not responding

following

i'm having the same problem. A couple of weeks ago my mac rebooted (not sure if that's relate) and all of my hue-bridge devices stopped working.

I've done all the same troubleshooting steps listed here, but no success.

hoping to get this figured out soon

Posted on
Mon Sep 30, 2019 3:58 pm
scs offline
Posts: 35
Joined: Nov 28, 2014

Re: Alexa says all devices are not responding

Shouldn’t it be possible to port forward from 80 to 8178 using a rule for the native Firewall (Pf) ?
I know that wouldn’t help if you had more than 1 bridge running but it’d be a fair short term workaround (assuming the echos aren’t talking a different API

Also, is it ONLY the 1st gen Echo Dot that’s using older (and compatible) firmware?
Last edited by scs on Mon Sep 30, 2019 5:06 pm, edited 1 time in total.

Indigo 7 w/ Insteon and Z-Wave lights and outlets
Security integration.
Energy monitoring

Posted on
Mon Sep 30, 2019 4:07 pm
autolog offline
Posts: 3235
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1 aka UTC+1]

Re: Alexa says all devices are not responding

I am using Gen 1 Echos (not Dots).

Regarding port forwarding - I haven't been able to get it to work so far. :(

Posted on
Mon Sep 30, 2019 9:19 pm
fyellin offline
Posts: 17
Joined: Jun 08, 2008

Re: Alexa says all devices are not responding

I am also using first generation Echo (not Echo dot, not Echo Plus) successfully.

Posted on
Thu Oct 03, 2019 3:22 pm
RAID5 offline
Posts: 86
Joined: Jan 16, 2015
Location: Sweden

Re: Alexa says all devices are not responding

autolog wrote:
I have setup a VLAN bound to the same ethernet port and the network is shown as active.
The first test, still using the 8178 etc series port address is to try and get discovery working.

It isn't for the Alexa-Hue Bridge on the VLAN. :|

It should do because I still have my Gen1 Echo plugged in. If I enable an Alexa-Hue Bridge which is on the original (non-VLAN) network, discovery and control works for that Alexa-Hue Bridge.

I think it might be something to do with broadcasting not working across to a VLAN.

Need to investigate further and might need some more plugin coding work-arounds?

Once (and if) I get the VLAN to work in normal mode, I can then worry about using pfctl to sort out the port 80 issue. :)


Hi maby I can help with networking questions, I do know some things about networking.
For example broadcast do only stay on the same IP subnet (same network) it never jumps to another LAN or VLAN.

If you setup another VLAN, I guess you have configured that VLAN on your other devices, for example network switch or WiFi router.
Else you will not be able to connect to that VLAN from any other devices.

RAID5 "A happy Swede addicted to automation"

Posted on
Sun Oct 06, 2019 11:41 am
scs offline
Posts: 35
Joined: Nov 28, 2014

Re: Alexa says all devices are not responding

I spent a few hours trying to get PF to forward packets from 80 to 8178 and never got it to work ...

The next day I ran across a deal on a full size Echo 1st gen so I bought it .
Today I deleted all the devices from the cloud, unplugged my 2 Echo 2nd gen Echo Dots... put the two Hue Bridges in discovery mode and ordered Alexa to discover devices .
She replied: Found 28 devices
I told her to turn on all the lights and it blew the breaker :wink:
J/K , all the lights work as before from any Echo.

Indigo 7 w/ Insteon and Z-Wave lights and outlets
Security integration.
Energy monitoring

Posted on
Sun Oct 06, 2019 1:01 pm
mgolden50 offline
User avatar
Posts: 184
Joined: Jan 29, 2007
Location: Chandler, AZ

Re: Alexa says all devices are not responding

I did exactly the same thing with a newly received Gen 1 Echo device from eBay.
Rediscovered all 182 HueBridge devices. All 10 of my Echo Dots worked as before the firmware change after re-regerestering them.

Now I live in the fear of the firmware will eventually be updated on the Gen 1 device by Amazon bringing everything crashing down again.
When this happened with the Harmony Hub they quickly accommodated the HA community with a fix. I doubt Amazon will be so accommodating.

During the week without HueBridge not working I came to realize how essential the capability voice control of Indigo automation has become to me--and likely to many others. During that week I began looking into (and eventually purchased an ISY HA hub).

Apparently ISY has gone to the effort of creating an Alexa skill that bridges Alexa commands to their hub, probably using a stable API embedded within the skill creation process. I have no idea yet about how well their bridge works.
'
I know that Matt and Jay have said they have not made an Alexa interface a built-in core capability of Indigo because of the lack of an appropriate API.
But considering how important Amazon has made HA voice control, and how ISY has handled their integration, shouldn't Indigo revisit the issue?

Meanwhile, I intend to explore running the ISY hub in parallel to Indigo.
Fortunately Indigo has forced me learn Python which is the same language used by ISY.

Who is online

Users browsing this forum: No registered users and 2 guests

cron