Discovery not working

Posted on
Mon Dec 17, 2018 8:31 am
rapamatic offline
Posts: 270
Joined: Aug 03, 2015
Location: Glencoe, IL

Discovery not working

So, I had everything working fine with the plugin a few months ago, but then when I tried to add additional devices to my virtual hubs discovery failed on those new devices. I killed my hue bridge device, made a new one, and still cannot get discovery to work. I have several legacy alexa devices on my network that should work - including an original echo and a G2 dot. I also don't think my network is blocking the UPNP packets, since when I look in the Alexa plugin log, I see lots of UPNP requests from my Sonos speakers and other devices on my network. BUT, every time I try to do discovery (either from the alexa app, or various alexa devices) it doesn't find anything... I wonder if something is screwed up with my Alexa devices? Has anyone seen behavior like this before?

Posted on
Wed Dec 19, 2018 9:55 am
RWBUMP offline
Posts: 5
Joined: Jun 25, 2016

Re: Discovery not working

As of this morning, I am having the same problem. I reset everything. Lastly I reset my router, and discovery on my IPAD worked. The software was upgraded 12 December 2018, and I updated after I discovered the problems this morning. I had no success with discovery until I reset my router; nevertheless, the Alexa works from the IPAD, but not from the echo device. This has happened several times in the past few years and usually I just shift to Siri and homebridge until Amazon fixes their problem. From my perspective, It appears part of the problem was Amazon changed a protocol or server and my router didn't like it and the other part of the problem appears to be between their software and echo devices. I'm not seeing any blocked Amazon servers or protocols on my router, but I'll keep looking.

Posted on
Sun Dec 23, 2018 1:38 pm
Nick offline
Posts: 17
Joined: Nov 06, 2018

Re: Discovery not working

Not sure if this helps but I had lots of problems with discovery. This is what fixed it for me today after quite some fiddling around.

Both Ethernet and wifi are working on the mac mini. In the plugin i put the fixed IP address of the wifi ip address and port 8179 in the Indigo Alexa device.

The ethernet IP address din't work!!!

Posted on
Mon Dec 24, 2018 12:39 pm
jay (support) offline
Site Admin
User avatar
Posts: 16552
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Discovery not working

Having both network interfaces enabled is a known problem with Bonjour because which interface is used is not really predictable.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Tue Dec 25, 2018 6:34 pm
guitarfreak offline
Posts: 10
Joined: Jan 17, 2017

Re: Discovery not working

I attempted to add a new device and now I'm having the same issue, I can not get discovery working. Do you need to enable the Phillips-Hue skill? I don't remember having to do that before. I've tried upgrading and downgrading different versions of the plugin. Any other troubleshooting?

Posted on
Wed Dec 26, 2018 2:41 am
autolog offline
Posts: 3403
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT aka UTC]

Re: Discovery not working

guitarfreak wrote:
Do you need to enable the Phillips-Hue skill?

No. :)
guitarfreak wrote:
I don't remember having to do that before. I've tried upgrading and downgrading different versions of the plugin. Any other troubleshooting?

What version are you running - You should use the latest Indigo Plugin Store version.
What model of Alexa Device are you using to discover devices?

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest