New Alexa User

Posted on
Wed Nov 01, 2017 3:23 pm
jyarington offline
Posts: 11
Joined: Oct 31, 2017

New Alexa User

Hi,

Received my echo yesterday and I can't get it to discover my devices. I have the following set up

Mac Mini
10.10.5
Indigo 7
Alexa Hub plugin 3.0.12
I have about 15 devices but defined 2 as Alexa to test

Alex can't seem to discover them both the Alex and the Mini are on the same wireless network. The app wants me to set up Hue which I don't have. I have logging set but nothing show up in the log file. Any help would be appreciated.

Posted on
Wed Nov 01, 2017 5:05 pm
autolog offline
Posts: 2386
Joined: Sep 10, 2013
Location: West Sussex

Re: New Alexa User

I have a few suggestions / comments:
- Have you done the Port 1900 check - see 1st sticky post.
- As long as discovery is running on your Alexa-Hue Bridge device then your two devices should be discovered.
- Discovery is best done by asking Alexa directly i.e. "Alexa discover devices." You can ignore any instructions that Alexa says about enabling smart skills.
- Do you have ethernet enabled as well as wi-fi - this can sometimes cause issues.
- Try Specifying the computer host IP in the plugin config (IP address of Mac Mini)

If you still can't get it to work, you can turn on debugging and attach the log as a zip file to a return post.
After turning on debugging, it would be best to reload the plugin so that I can see what happens from the start. I'll take a look at the log and see what I can see. :)

Posted on
Thu Nov 02, 2017 7:41 am
jyarington offline
Posts: 11
Joined: Oct 31, 2017

Re: New Alexa User

Port 1900 check

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
IndigoPlu 73104 jyarington 23u IPv4 0xd43347e8813661d9 0t0 UDP *:ssdp

This is the contents of the plug in log file it looks like the response is being sent to my AV receiver.

The IP of the Echo is 192.168.1.37
The IP of my mini is 192.168.1.19


Responder.respond: UDP Response sent to ('192.168.1.151', 4996)
2017-11-02 09:25:14.884 DEBUG Plugin.responder.run Responder.run: received: M-SEARCH * HTTP/1.1
MX: 5
ST: urn:schemas-upnp-org:device:MediaServer:1
HOST: 239.255.255.250:1900
MAN: "ssdp:discover"


2017-11-02 09:25:14.884 DEBUG Plugin.responder.respond Responder.respond called from address ('192.168.1.151', 4996)
HTTP/1.1 200 OK
CACHE-CONTROL: max-age=100
EXT:
LOCATION: http://192.168.1.19:8180/description.xml
SERVER: FreeRTOS/7.4.2, UPnP/1.0, IpBridge/1.7.0
ST: urn:schemas-upnp-org:device:basic:1
USN: uuid:c4c5d4ca-be8d-11e7-93ef-a8206612046e


2017-11-02 09:25:14.885 DEBUG Plugin.responder.respond Responder.respond: creating output_socket
2017-11-02 09:25:14.885 DEBUG Plugin.responder.respond Responder.respond: calling output_socket.sendto
2017-11-02 09:25:14.885 DEBUG Plugin.responder.respond Responder.respond: closing output_socket
2017-11-02 09:25:14.885 DEBUG Plugin.responder.respond Responder.respond: UDP Response sent to ('192.168.1.151', 4996)

Posted on
Thu Nov 02, 2017 8:47 am
autolog offline
Posts: 2386
Joined: Sep 10, 2013
Location: West Sussex

Re: New Alexa User

The port 1900 check looks OK. :)

From the log entries you have shown, I can't see any message coming in from the Echo. :|

Ideally, I would like to see the whole log from start-up to when it fails to discover; hence suggesting you zip and attach it to a reply. :wink:

Posted on
Thu Nov 02, 2017 6:25 pm
jyarington offline
Posts: 11
Joined: Oct 31, 2017

Re: New Alexa User

I tried to attach a zip file but I get errors when I choose to attach the file that zip files are not allowed.

Posted on
Fri Nov 03, 2017 12:36 am
autolog offline
Posts: 2386
Joined: Sep 10, 2013
Location: West Sussex

Re: New Alexa User

OK - In that case just attach it as a plain text file; by being attached it won't take up a lot of space in the return post. :)

Posted on
Fri Nov 03, 2017 6:48 am
jyarington offline
Posts: 11
Joined: Oct 31, 2017

Re: New Alexa User

Forgive me for being stupid. I had zipped the entire folder "Logs" my guess is that you want specific log file Just give me the file names so I can cut and paste into a text file.

Posted on
Fri Nov 03, 2017 6:55 am
autolog offline
Posts: 2386
Joined: Sep 10, 2013
Location: West Sussex

Re: New Alexa User


Posted on
Fri Nov 03, 2017 1:48 pm
jyarington offline
Posts: 11
Joined: Oct 31, 2017

Re: New Alexa User

I hope this worked. I used the text editor.
Attachments
Plug.txt
(7.12 KiB) Downloaded 20 times

Posted on
Fri Nov 03, 2017 2:43 pm
autolog offline
Posts: 2386
Joined: Sep 10, 2013
Location: West Sussex

Re: New Alexa User

I can't see anything in the log section you have sent that indicates the plugin is receiving anything from the echo. :|

As I noted previously, I need to see the whole log not just a section. I want to see what the plugin is doing when it starts up etc.
I suggest the following approach:
  1. Disable the plugin
  2. Delete the log file (move it to trash)
  3. Enable the plugin
  4. say to Alexa: "Alexa discover devices"
  5. wait for Alexa to reply that she can't find any devices
  6. disable the plugin
  7. attach the complete log to a return post - don't use a text editor on it. :wink:

Hopefully it might indicate something - we'll see. :)

Posted on
Fri Nov 03, 2017 3:49 pm
jyarington offline
Posts: 11
Joined: Oct 31, 2017

Re: New Alexa User

I followed your instructions. I did select all copy this time so I think I grabbed the entire file. Thanks.
Attachments
Pluginlog.txt
(61.89 KiB) Downloaded 20 times

Posted on
Sat Nov 04, 2017 5:07 am
autolog offline
Posts: 2386
Joined: Sep 10, 2013
Location: West Sussex

Re: New Alexa User

Thanks for the log. :) - still looks like it was edited :wink:

I can't see anything wrong with the startup.
There is still no sign of anything coming from your Echo. A lot of messages being received from 192.168.1.151 (your AV Receiver?) and also 192.168.1.52.
There are none from 192.168.1.37 (your Echo).

When the plugin is in discovery mode it will reply to any device that sends it a discovery message. It will only pass the details of the devices defined to the Alexa-Hue bridge when it gets a valid request from an Alexa device.

So it looks like the discovery request from the Echo isn't being received by the plugin for some reason.

Not sure what to suggest now , but a few ideas: :?
  • You said you are using Wi-Fi, do you have an ethernet port enabled or connected? If so it might be worth disabling it.
  • Do you run a firewall that could be preventing the messages getting through - if so it might be worth disabling it temporarily as a test?
  • It might be worth turning off the AV Receiver while you run discovery and ask Alexa to discover devices.

Posted on
Sat Nov 04, 2017 7:08 am
jyarington offline
Posts: 11
Joined: Oct 31, 2017

Re: New Alexa User

1. Ethernet port on Mini is set to off
2. No firewall enabled
3. AV receiver is off

Tried to grab the entire log not sure if I was successful.
Attachments
plugin.txt
(69.57 KiB) Downloaded 19 times

Posted on
Sat Nov 04, 2017 7:52 am
autolog offline
Posts: 2386
Joined: Sep 10, 2013
Location: West Sussex

Re: New Alexa User

You don't need to edit the file. :)
When you attach the log file (via Choose file), just navigate to the log folder and choose plugin.log.
The file is located in folder: /Library/Application Support/Perceptive Automation/Indigo 7/Logs/opensource.alexa-hue-bridge

I see another device with a lot of entries at 192.168.1.34 which suggest it is a media server?

I am clutching at straws here but you could turn off that device as well as the AV receiver.
Then go through the previous mentioned procedure (all 7 steps) - Make sure you delete the log file prior to re-enabling the plugin i.e step 2.

We'll see if that gets us any further. :)

Posted on
Sat Nov 04, 2017 12:30 pm
jyarington offline
Posts: 11
Joined: Oct 31, 2017

Re: New Alexa User

No change and I unplugged both receivers. New log.
Attachments
Plugin.txt
(22.94 KiB) Downloaded 25 times

Who is online

Users browsing this forum: No registered users and 3 guests