Echo Show not discovering

Posted on
Wed Jul 12, 2017 5:28 pm
jay (support) offline
Site Admin
User avatar
Posts: 16264
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Echo Show not discovering

BTW, I just tested my Dash Wand, which is associated with the same Amazon account as the Echo and dots. It also works fine controlling the lights just like the various Echos. I'm really thinking at this point that there's a firmware issue with the Show that's causing a problem. I believe the Show runs a different OS than the Echos do (one that's an android derivative).

Is there a way to factory reset it? I wonder if that would help...

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Jul 24, 2017 6:19 am
jabeard3 offline
Posts: 52
Joined: Nov 30, 2012

Re: Echo Show not discovering

I've tried de-registering the device from the account which seems to put it back into the default setting of "setting up a new device" but I'm not sure if there is a more complete "factory reset" . Haven't had any time to play with it in a couple weeks now but hope to do so soon.

Has anyone else bought a show yet?

Posted on
Mon Jul 24, 2017 6:32 am
jabeard3 offline
Posts: 52
Joined: Nov 30, 2012

Re: Echo Show not discovering

Well... that was easy...

Something is still not "right" with the discovery process on the show as there is no logging/updates in my Indigo log however.. controlling Indigo devices is now working. I had apparently enabled the Hue "skill" at some point when trying to get discovery to work. Now that I've disabled that skill my Indigo devices are responding. That's good enough for me.

Posted on
Mon Jul 24, 2017 6:50 am
autolog offline
Posts: 3243
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1 aka UTC+1]

Re: Echo Show not discovering

Good to hear that your Echo Show is now working. :)

Have you got the option Log Discovery ticked in the Plugin Config?
If that is ticked you should get the discovery listed in the event log. :)

Posted on
Mon Jul 24, 2017 9:58 am
jabeard3 offline
Posts: 52
Joined: Nov 30, 2012

Re: Echo Show not discovering

I do have that option checked (as well as all the other debug options and I'm still not getting anything in the logs from the show. Discovery from either echo show as intended... Picking up 3 dots later today, I'm assuming they will work as well as the echo.

Posted on
Mon Jul 24, 2017 10:24 am
autolog offline
Posts: 3243
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1 aka UTC+1]

Re: Echo Show not discovering

I am using an Echo and a Dot - they both work fine (for me). :)

I am surprised (and confused) that when you run a discovery, nothing is showing in the Indigo Event Log with that option set. That would imply that nothing is being discovered. :?

It will be interesting to see what happens when you try out a Dot. :)

Posted on
Mon Jul 24, 2017 1:02 pm
freshwuzhere offline
Posts: 95
Joined: Apr 05, 2012

Re: Echo Show not discovering

Hi,

Same problem here - Amazon Show can't access the devices - I created them with my old Echo and it still works.

In your post you mentioned that you disabled the Hue skill and it started working. I never had the Hue skill enabled - but still not working....

Any more details on how you got it working would help.

Thanks in advance.

Posted on
Mon Jul 24, 2017 4:23 pm
jay (support) offline
Site Admin
User avatar
Posts: 16264
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Echo Show not discovering

I suspect that there are bugs in the Show's firmware since discovery and control always seem to work on the Echo, dot, and Dash wand.

Remember that the Show runs a special version of Android - not the embedded system that the other Echo products use (and, presumably, the Dash wand). So it seems likely that the Show just has some bugs in discovery (and apparently some inconsistencies in control as well).

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Tue Aug 01, 2017 12:06 pm
freshwuzhere offline
Posts: 95
Joined: Apr 05, 2012

Re: Echo Show not discovering

Actually the Alexa Show seems a LOT dumber than the regular Alexa. The change in processor has certainly detracted from the performance in our experience. (Not to mention the poor discovery of Hue devices).

Posted on
Tue Sep 05, 2017 7:08 am
autolog offline
Posts: 3243
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1 aka UTC+1]

Re: Echo Show not discovering

Just taking another look at this following info gleaned for this thread: Unable to Discover Devices (FireTV)

When you tell the Echo Show Alexa Discover Devices, do you get a similar response to an Echo or Echo Dot i.e. Starting discovery, this can take up to 20 seconds. If you have Philips hue press the button on then bridge?

Posted on
Fri Oct 06, 2017 8:02 pm
freshwuzhere offline
Posts: 95
Joined: Apr 05, 2012

Re: Echo Show not discovering

No you just get "Discovery is complete - I couldn't find any smart home devices"

Posted on
Fri Oct 06, 2017 8:06 pm
freshwuzhere offline
Posts: 95
Joined: Apr 05, 2012

Re: Echo Show not discovering

And I should add - to make things more frustrating the old Alexa still works perfectly. Funny how forward progress sometimes feels like moving backwards.

Who is online

Users browsing this forum: No registered users and 1 guest