Scene Controllore 1.0.40 Not executing commands

Posted on
Fri Sep 11, 2020 7:02 am
Sharek326 offline
User avatar
Posts: 354
Joined: Jul 20, 2014
Location: Lansford, PA

Scene Controllore 1.0.40 Not executing commands

Recently upgraded to version 1.0.40. Prior all my commands were working using the original release. Now all the scenes stopped responding I deleted all of the scenes and only recreated 1 just to troubleshoot.

I am using the Aeotec Minimote set to single click button 1 to toggle on / off a light. The log shows the key press but nothing happens

Sep 11, 2020, 9:00:14 AM
Z-Wave received "Office Minimote" button 1 pressed

Posted on
Fri Sep 11, 2020 9:14 am
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Scene Controllore 1.0.40 Not executing commands

Hi Sharek

Stick a ZWave Watcher on the minimote so we can see what's coming in/out.

If the Mac and Indigo is seeing the commands, there's no reason why the plugin won't.

Peter

Posted on
Fri Sep 11, 2020 1:33 pm
Sharek326 offline
User avatar
Posts: 354
Joined: Jul 20, 2014
Location: Lansford, PA

Re: Scene Controllore 1.0.40 Not executing commands

Setup watcher on the Minimote and get this

Sep 11, 2020, 3:32:29 PM
Z-Wave received "Office Minimote" button 1 pressed
Z-Wave Watcher Debug Raw command received (Node 81): 01 0A 00 04 00 51 04 2B 01 01 00 8F

I also noticed it isn't just the MiniMote. The Quad Wallmote in the Bath is doing the same no scenes will execute here is a button push from that to turn on 4 HUE bulbs on the vanity

Sep 11, 2020, 5:51:43 PM
Z-Wave received "Bath Wallmote" button 1 pressed
Z-Wave Watcher Debug Raw command received (Node 49): 01 0B 00 04 00 31 05 5B 03 7E 00 01 E3

Posted on
Sun Sep 13, 2020 8:38 am
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Scene Controllore 1.0.40 Not executing commands

Turn on the plugin debug (Indigo > Plugins > ZWave Scene Controller > Configure) then restart the plugin.

The first thing it does is subscribe to incoming commands.

When any 2B01 command (Basic Scene) is received, it will log it even if it has no corresponding trigger to do anything.

Peter

Posted on
Sun Sep 13, 2020 4:14 pm
Sharek326 offline
User avatar
Posts: 354
Joined: Jul 20, 2014
Location: Lansford, PA

Re: Scene Controllore 1.0.40 Not executing commands

When I rolled it back to .28 everything is fine. I upgraded again to .40 everything stops working ......

Here is the debug on and plugin restarted

Sep 13, 2020, 6:12:21 PM
Stopping plugin Z-Wave Scene Controller (pid 91141)
Stopped plugin Z-Wave Scene Controller
Upgrading plugin Z-Wave Scene Controller to newer version 1.0.40 (previous version moved to trash)
Loading plugin "Z-Wave Scene Controller 1.0.40"
Starting plugin "Z-Wave Scene Controller 1.0.40" (pid 6223)
Started plugin "Z-Wave Scene Controller 1.0.40"
Z-Wave received "Office Outlet" energy total to 337.449 kWh
Z-Wave received "Office Outlet" power load to 65.949 W
Indigo Cocoa client authenticated (192.168.100.73)
Z-Wave received "Office Minimote" button 1 pressed
Z-Wave Watcher Debug Raw command received (Node 81): 01 0A 00 04 00 51 04 2B 01 01 00 8F
Z-Wave Scene Controller Debug logging enabled
Reloading plugin "Z-Wave Scene Controller 1.0.40"
Stopping plugin "Z-Wave Scene Controller 1.0.40" (pid 6223)
Z-Wave Scene Controller Debug Stop processing trigger Office Light On / Off
Z-Wave Scene Controller Debug Stop processing trigger Poweder Vanity Off
Z-Wave Scene Controller Debug Stop processing trigger Poweder Vanity On
Z-Wave Scene Controller Debug Stop processing trigger WallMote Vanity Off
Z-Wave Scene Controller Debug Stop processing trigger WallMote Vanity On
Z-Wave Scene Controller Debug Stop processing trigger WallMote Vanity On Purple
Z-Wave Scene Controller Debug Stop processing trigger WallMote Wirlpool
Z-Wave Scene Controller Debug shutdown called
Stopped plugin "Z-Wave Scene Controller 1.0.40"
Starting plugin "Z-Wave Scene Controller 1.0.40" (pid 6466)
Started plugin "Z-Wave Scene Controller 1.0.40"
Z-Wave Scene Controller Debug startup called -- subscribing to all incoming Z-Wave commands
Z-Wave Scene Controller Debug Start processing trigger Office Light On / Off
Z-Wave Scene Controller Debug Start processing trigger Poweder Vanity Off
Z-Wave Scene Controller Debug Start processing trigger Poweder Vanity On
Z-Wave Scene Controller Debug Start processing trigger WallMote Vanity Off
Z-Wave Scene Controller Debug Start processing trigger WallMote Vanity On
Z-Wave Scene Controller Debug Start processing trigger WallMote Vanity On Purple
Z-Wave Scene Controller Debug Start processing trigger WallMote Wirlpool
Z-Wave received "Office Minimote" button 1 pressed
Z-Wave Watcher Debug Raw command received (Node 81): 01 0A 00 04 00 51 04 2B 01 01 00 8F

Posted on
Mon Sep 14, 2020 12:16 am
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Scene Controllore 1.0.40 Not executing commands

Can you send me the zip or .indigoPlugin file for .28

I didn't used to keep old versions so I don't have that one to compare back to.

Peter

Posted on
Mon Sep 14, 2020 6:16 am
Sharek326 offline
User avatar
Posts: 354
Joined: Jul 20, 2014
Location: Lansford, PA

Re: Scene Controllore 1.0.40 Not executing commands

The .28 Plugin? sure where do you want me to send it to

Posted on
Mon Sep 14, 2020 10:37 am
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Scene Controllore 1.0.40 Not executing commands

I’ll send you a pm.


Sent from my iPhone using Tapatalk Pro

Posted on
Mon Sep 14, 2020 1:59 pm
Sharek326 offline
User avatar
Posts: 354
Joined: Jul 20, 2014
Location: Lansford, PA

Re: Scene Controllore 1.0.40 Not executing commands

I emailed it

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest