Bug?

Posted on
Sun Jan 12, 2020 10:42 am
Bildhauer offline
Posts: 32
Joined: Sep 30, 2019

Bug?

Hello,

is this a bug or what can I do to get rid of it?

Z-Wave received "Taster Wohnzimmer" scene 5 (0005)
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Debug Central Scene Command received:
Z-Wave Scene Controller Debug Raw command: 01 0B 00 04 00 87 05 5B 03 B5 00 05 FF
Z-Wave Scene Controller Debug Node: 135
Z-Wave Scene Controller Debug Button: 5
Z-Wave Scene Controller Debug ActionID: 0
Z-Wave Scene Controller Debug Action: Click
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Error Error in plugin execution ReceivedBroadcast:

Traceback (most recent call last):
File "plugin.py", line 193, in zwaveCommandReceived
File "plugin.py", line 242, in triggerEvent
KeyError: key id 812343885 not found in database

Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Debug Central Scene Command received:
Z-Wave Scene Controller Debug Raw command: 01 0B 00 04 00 87 05 5B 03 B5 00 05 FF
Z-Wave Scene Controller Debug Node: 135
Z-Wave Scene Controller Debug Button: 5
Z-Wave Scene Controller Debug ActionID: 0
Z-Wave Scene Controller Debug Action: Click
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Error Error in plugin execution ReceivedBroadcast:

Traceback (most recent call last):
File "plugin.py", line 193, in zwaveCommandReceived
File "plugin.py", line 242, in triggerEvent
KeyError: key id 812343885 not found in database

Z-Wave received "Taster Wohnzimmer" scene 1 (0001)
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Debug Central Scene Command received:
Z-Wave Scene Controller Debug Raw command: 01 0B 00 04 00 87 05 5B 03 B6 00 01 FF
Z-Wave Scene Controller Debug Node: 135
Z-Wave Scene Controller Debug Button: 1
Z-Wave Scene Controller Debug ActionID: 0
Z-Wave Scene Controller Debug Action: Click
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Error Error in plugin execution ReceivedBroadcast:

Traceback (most recent call last):
File "plugin.py", line 193, in zwaveCommandReceived
File "plugin.py", line 242, in triggerEvent
KeyError: key id 812343885 not found in database


Z-Wave received "Zwischenstecker Thunderbolt-Monitor 1 (links)" power load to 0.00 W
Z-Wave received "Taster Wohnzimmer" scene 6 (0006)
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Debug Central Scene Command received:
Z-Wave Scene Controller Debug Raw command: 01 0B 00 04 00 87 05 5B 03 B8 00 06 FF
Z-Wave Scene Controller Debug Node: 135
Z-Wave Scene Controller Debug Button: 6
Z-Wave Scene Controller Debug ActionID: 0
Z-Wave Scene Controller Debug Action: Click
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Error Error in plugin execution ReceivedBroadcast:

Traceback (most recent call last):
File "plugin.py", line 193, in zwaveCommandReceived
File "plugin.py", line 242, in triggerEvent
KeyError: key id 812343885 not found in database

Z-Wave received "Taster Wohnzimmer" scene 2 (0002)
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Debug Central Scene Command received:
Z-Wave Scene Controller Debug Raw command: 01 0B 00 04 00 87 05 5B 03 BA 00 02 FF
Z-Wave Scene Controller Debug Node: 135
Z-Wave Scene Controller Debug Button: 2
Z-Wave Scene Controller Debug ActionID: 0
Z-Wave Scene Controller Debug Action: Click
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Error Error in plugin execution ReceivedBroadcast:

Traceback (most recent call last):
File "plugin.py", line 193, in zwaveCommandReceived
File "plugin.py", line 242, in triggerEvent
KeyError: key id 812343885 not found in database


Z-Wave received "Taster Wohnzimmer" scene 5 (0005)
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Debug Central Scene Command received:
Z-Wave Scene Controller Debug Raw command: 01 0B 00 04 00 87 05 5B 03 BB 00 05 FF
Z-Wave Scene Controller Debug Node: 135
Z-Wave Scene Controller Debug Button: 5
Z-Wave Scene Controller Debug ActionID: 0
Z-Wave Scene Controller Debug Action: Click
Z-Wave Scene Controller Debug -----
Z-Wave Scene Controller Error Error in plugin execution ReceivedBroadcast:

Traceback (most recent call last):
File "plugin.py", line 193, in zwaveCommandReceived
File "plugin.py", line 242, in triggerEvent
KeyError: key id 812343885 not found in database



Best regards

Stephan O. Merckens

Posted on
Mon Jan 13, 2020 5:29 pm
Bildhauer offline
Posts: 32
Joined: Sep 30, 2019

Re: Bug?

Anyone available? Still waiting for help!

Posted on
Wed Jan 15, 2020 3:48 am
howartp offline
Posts: 4138
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Bug?

You’re still waiting for help within 24 hours of me replying to your private message.

My whole family is struggling with colds and (my dad) flu at the moment, and I’ve succumbed to staying in bed today.


Sent from my iPhone using Tapatalk Pro

Posted on
Wed Jan 15, 2020 3:58 am
Bildhauer offline
Posts: 32
Joined: Sep 30, 2019

Re: Bug?

Sorry for urging you.

Posted on
Thu Jan 16, 2020 4:06 pm
jay (support) offline
Site Admin
User avatar
Posts: 16312
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Bug?

I'll take a guess and say that you configured a trigger event from the plugin with a device that no longer exists (one with ID 812343885). You can sort the devices list by ID by clicking on the Device ID column title then you can see if that device is in your system. If not, then you'll need to find the Trigger that specifies an event that uses that ID and change or delete it.

I don't think you're using the most recent version of the plugin from the Plugin Store (the line numbers mentioned in the error don't appear to line up with the plugin source) so first make sure you are using the latest version.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sat Jan 18, 2020 4:16 pm
howartp offline
Posts: 4138
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Bug?

jay (support) wrote:
I don't think you're using the most recent version of the plugin from the Plugin Store (the line numbers mentioned in the error don't appear to line up with the plugin source) so first make sure you are using the latest version.

To be fair - on this occasion - I think i've got out of sync with my releases.

1.0.28 was latest on plugin store, 1.0.19 was latest announced, but 1.0.33/1.0.34 were live on Github and linked in at least one thread to help another user.

I've just merged them all into 1.0.37 and updated plugin store!

Peter

Posted on
Sun Jan 19, 2020 5:32 am
Bildhauer offline
Posts: 32
Joined: Sep 30, 2019

Re: Bug?

Hello,

I've update to your new version. Now the pug doesn't do anything.Evetn log shows:

19. Jan 2020 at 12:25:31
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 74.23 W
Z-Wave received "Taster Büro" scene 5 (0005)
Z-Wave received "Taster Büro" scene 5 (0005)
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 81.19 W

19. Jan 2020 at 12:26:26
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 1 (links)" energy total to 35.62 kWh
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 1 (links)" power load to 40.22 W

19. Jan 2020 at 12:26:53
Z-Wave received "Zwischenstecker Aquarium Licht Wohnzimmer" power load to 88.81 W

19. Jan 2020 at 12:27:14
Z-Wave received "Taster Büro" scene 5 (0005)
Z-Wave received "Taster Büro" scene 1 (0001)
Z-Wave received "Taster Büro" scene 5 (0005)
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" energy total to 138.22 kWh
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 73.57 W
Z-Wave received "Taster Büro" scene 1 (0001)
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 80.77 W
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 72.99 W
Z-Wave received "Taster Büro" scene 5 (0005)


So the triggers are not addressed by having an event on a wall switch …

Settings are attached as screenshots
Attachments
Trigge.jpg
Trigge.jpg (73.59 KiB) Viewed 937 times
Configure Scene Commands.jpg
Configure Scene Commands.jpg (52.11 KiB) Viewed 937 times
Configure.jpg
Configure.jpg (85.21 KiB) Viewed 937 times
Actions.jpg
Actions.jpg (89.45 KiB) Viewed 937 times
Action Group.jpg
Action Group.jpg (66.39 KiB) Viewed 937 times

Posted on
Wed Jan 29, 2020 12:52 pm
Bildhauer offline
Posts: 32
Joined: Sep 30, 2019

Re: Bug?

Hello,

updating to version 1.038 is without any effect.

The log shows:

29. Jan 2020 at 19:47:12
Z-Wave received "Qubino Laterne Weg hinten" power load to 32.7 W
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 65.14 W
Stopping plugin Z-Wave Scene Controller (pid 1070)
Z-Wave Scene Controller Debug Stop processing trigger Büro Licht an
Z-Wave Scene Controller Debug Stop processing trigger Büro Licht aus
Z-Wave Scene Controller Debug Stop processing trigger Büro Licht DUNKLER
Z-Wave Scene Controller Debug Stop processing trigger Büro Licht HELLER
Z-Wave Scene Controller Debug Stop processing trigger Erdgeschoss + Büro komplett GOOD NIGHT
Z-Wave Scene Controller Debug Stop processing trigger Erdgeschoss komplett GOOD NIGHT
Z-Wave Scene Controller Debug Stop processing trigger Wohnzimmer Licht AN
Z-Wave Scene Controller Debug Stop processing trigger Wohnzimmer Licht AUS
Z-Wave Scene Controller Debug shutdown called
Stopped plugin Z-Wave Scene Controller
Upgrading plugin Z-Wave Scene Controller to newer version 1.0.38 (previous version moved to trash)
Loading plugin "Z-Wave Scene Controller 1.0.38"
Starting plugin "Z-Wave Scene Controller 1.0.38" (pid 7806)
Started plugin "Z-Wave Scene Controller 1.0.38"
Z-Wave Scene Controller Debug startup called -- subscribing to all incoming Z-Wave commands
Z-Wave Scene Controller Debug Start processing trigger Büro Licht an
Z-Wave Scene Controller Debug Start processing trigger Büro Licht aus
Z-Wave Scene Controller Debug Start processing trigger Büro Licht DUNKLER
Z-Wave Scene Controller Debug Start processing trigger Büro Licht HELLER
Z-Wave Scene Controller Debug Start processing trigger Erdgeschoss + Büro komplett GOOD NIGHT
Z-Wave Scene Controller Debug Start processing trigger Erdgeschoss komplett GOOD NIGHT
Z-Wave Scene Controller Debug Start processing trigger Wohnzimmer Licht AN
Z-Wave Scene Controller Debug Start processing trigger Wohnzimmer Licht AUS
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 59.62 W
Z-Wave received "Taster Büro" scene 5 (0005)
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 63.81 W
Z-Wave received "Zwischenstecker Küche Spülmaschine" energy total to 13.65 kWh
Z-Wave received "Zwischenstecker Küche Spülmaschine" power load to 82.40 W
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 60.62 W
Z-Wave received "Taster Büro" scene 5 (0005)
Z-Wave received "Taster Büro" scene 1 (0001)

29. Jan 2020 at 19:48:29
Z-Wave received "Taster Büro" scene 1 (0001)
Z-Wave received "Zwischenstecker Aquarium Licht Wohnzimmer" energy total to 819.85 kWh
Z-Wave received "Zwischenstecker Aquarium Licht Wohnzimmer" power load to 87.78 W
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 78.75 W
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 69.75 W
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 61.68 W
Z-Wave received "Zwischenstecker Küche Spülmaschine" power load to 4.26 W
Indigo Cocoa client authenticated (192.168.13.5)
Z-Wave received "Zwischenstecker Thunderbolt-Monitor 2 (rechts)" power load to 57.65 W

Please check.

Posted on
Thu Jan 30, 2020 4:40 pm
jaga01 offline
Posts: 54
Joined: Aug 24, 2017

Re: Bug?

Hi - I have the same situation. I have used the Scene Controller for a danish Multi level Switch (ZHC5010 from Logic-Group) - None of my 5 is working any more. I have tried to figure out what is going on. It seems that I get the same reaction as Bildhauer.

What can i do to solve the problem?

Regards, Jacob

Posted on
Fri Jan 31, 2020 2:29 am
howartp offline
Posts: 4138
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Bug?

I’ve not looked yet but I thought it was unique to Bildhauer.

My scene controller is in use daily with no problem.


Sent from my iPhone using Tapatalk Pro

Posted on
Sun Feb 02, 2020 2:56 pm
Bildhauer offline
Posts: 32
Joined: Sep 30, 2019

Re: Bug?

@howartp

Is ist possible to send us the setup one one of your triggers and a log files showing it when used?

Thanks in advance!

Bildhauer

Posted on
Sun Feb 02, 2020 5:43 pm
howartp offline
Posts: 4138
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Bug?

Can you roll back to previous version on plugin store.

It’s gonna be a few days before I get time to play with it.


Sent from my iPhone using Tapatalk Pro

Posted on
Mon Feb 03, 2020 4:03 pm
jaga01 offline
Posts: 54
Joined: Aug 24, 2017

Re: Bug?

Hi, I downgraded to 1.28. Now everything works again. Regards Jacob

Posted on
Sun Feb 09, 2020 3:52 pm
Bildhauer offline
Posts: 32
Joined: Sep 30, 2019

Re: Bug?

Hello Jacob,

where scan I get this working version (1.0.28)?

thx

Bildhauer

Posted on
Sun Feb 09, 2020 4:41 pm
howartp offline
Posts: 4138
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Bug?

On the plugin store.


https://www.indigodomo.com/pluginstore/39/


Sent from my iPhone using Tapatalk Pro

Who is online

Users browsing this forum: No registered users and 1 guest